Beiträge von Ammaletu

    Zitat

    Die Frage ist: ob es was einfacheres dafür gibt?

    Nein, das ist so in etwa, was ich auch vorgeschlagen hätte. Ist doch super, die Funktion schaut auch schon, dass sie nicht mitten im Wort kürzt. Du musst das allerdings nicht vor den Loop packen. Besser wäre in die functions.php, damit es sich auf allen Seiten auswirkt (index.php, search.php, archive.php). Es sei denn, das ist nicht gewünscht.

    Zitat

    Gerne würde ich Dir einen Link zum Theme geben. Nur wie geht das?

    Na, irgendwo musst Du das Theme doch her haben?! Es wäre jetzt natürlich nett, wenn Du dem Theme-Autor Bescheid sagen würdest und vielleicht dem ein oder anderen Benutzer des Themes etwas Grübelei ersparst. :)

    Arbeitest Du mit dem normalen Editor oder mit der HTML-Ansicht? Für die HTML-Ansicht gibt es ein Plugin, mit dem man sehr simpel Buttons hinzufügen kann (Add Quicktag). Du könntest dann z.B. das Icon-Bild in den uploads-Ordner laden und den Button-Quelltext als neuen Button in den Editor einfügen. Du müsstest nach dem Einfügen des Quelltextes nur jeweils den Link anpassen auf den aktuellen Download.

    Für den TinyMCE geht das sicher auch irgendwie, ist aber auf jeden Fall aufwändiger. Das würde ich auch auf jeden Fall an einer lokalen Testinstanz ausprobieren, denn den TinyMCE kann man sich auch schon mal kaputt konfigurieren. ;)

    Welches Theme verwendest Du? Hast Du schon mal im Backend geschaut, ob das Theme eine Optionsseite hat (unter Design, vermutlich), auf der man die Tiefe des Menüs vielleicht einstellen kann? Wenn nicht müsstest Du das wohl manuell im Theme anpassen, was dann sehr davon abhängt, wie genau das da umgesetzt ist.

    Hast Du noch mal umgebaut seit gestern? Aktuell ist das Video in der Kategorie "Videos", in der man es auch findet, wenn man die Kategorie aus der Sidebar aus aufruft. Da sehe ich also kein Problem?!

    Ich ergänze mal kurz die wahrscheinliche Ursache: Manche Themes schauen nach, ob es sich um eine einzelne Seite handelt (is_single() || is_page()) oder um eine Übersichtsseite und zeigen abhängig davon den Excerpt an oder den ganzen Content. Wenn Du mehrere Artikel auf einer statischen Seiten anzeigst, passt das natürlich nicht zusammen.

    Verwendest Du denn in dem Seitentemplate für die Vorschauanzeige the_excerpt() oder the_content()? Letzteres zeigt den ganzen Text an.

    Also wenn schon die manuelle Plugin-Installation nicht geht, dann muss da mit den Dateirechten wirklich durcheinander sein. Schau mit Deinem FTP-Programm mal, dass die Ordner die passenden Rechte haben. Google sollte ANleitungen ausspucken, welche Rechte richtig sind, und im Codex steht es auch.

    Dass RSS-Widget ist gedacht zum Anzeigen der Inhalte fremder Seiten. Wenn Du da Deine eigene Feed-Adresse einträgst kann das gravierende Performance-Auswirkungen haben. Es wäre auch nicht sehr sinnvoll.


    Zitat

    Ein Besucher meines Blogs meinte das der RSS Hyperlink nicht funktioniere.

    Da hat er Dir hoffentlich gesagt, welchen Link genau er meint. Meistens gibt es ja diverse Feed-Links auf einer WP-Seite. Dann kannst Du das sehr simpel nachprüfen, ob der Link tatsächlich nicht geht. Falls Ja sieht man in der Regel auch relativ leicht, ob der Link tatsächlich kaputt ist, etwa weil er im Theme falsch gebaut wird. Ansonsten probier doch mal die Feed-Links Deiner Seite durch, ob sie alle das gewünschte Ergebnis liefern.

    Tja, dann wirst Du leider selber mal mit einem Tool wie Firebug schauen müssen, welche Styles die display-Angabe überschreiben. Eventuell muss ja nur der Selektor in der neuen Angabe spezieller gemacht werden.

    Ansonsten probier mal nach dem Ändern der Styles Strg + F5 zu drücken. Nicht dass Dein Browser bloß noch die alten Styles cacht.

    Prinzipiell hast Du nur diese beiden Möglichkeiten, denke ich: Eine DB-Abfrage (Loop) pro gewünschter Kategorie machen oder eben nur eine Abfrage machen und das Ergebnis nach Kategorien sortieren.

    Du kannst natürlich einen Loop nehmen und angeben, zu welchen Kategorien die Posts gehören sollen. Dann beschränkst Du das Ergebnis sagen wir mal auf 50 Posts, ohne Paging und sortierst das dann nach Kategorien. Beim Ausgeben kannst Du dann ja dafür sorgen, dass pro Kategorie nicht mehr als fünf Posts ausgegeben werden. Das kann dann aber eben dazu führen, dass nicht für jede Kategorie fünf Posts angezeigt werden, wenn eben in der Kategorie länger nichts geschrieben wurde. Wenn das ok ist (die nicht angezeigten Posts sind dann ja auf jeden Fall älter), ist der Ansatz vielleicht nicht so schlecht.

    Fehler 500 heißt, dass es zu einem internen Fehler gekommen ist. Das kann eine falsche .htacces-Datei sein, aber in 99% der Fälle ist es ein PHP-Fehler. Du musst also dafür sorgen, dass Fehler in eine Logdatei geschrieben werden und dann nach so einem Fehler 500 schauen, was da drin steht. Könnte ein Fehler in einem Plugin oder im Theme sein, der sich eben nicht bei jedem Seitenaufruf auswirkt.

    Zitat

    Dies funktioniert leider nicht zuverlässig.

    Was heißt das? Die Styles werden nicht immer angeboten? Oder die Styles wirken sich nicht immer aus?

    Prinzipiell würde ich das immer über das Zuweisen von Klassen regeln und diese dann im Stylesheet des Themes definieren. Wenn es mal nicht so aussieht wie gewünscht, kannst Du mit Tools wie Firebug schauen, woran es liegt.