Beiträge von r23


    kann mir bitte jemand helfen den Code von gaxx-keywords plugin so zu ändern, dass bei der Ausgabe in den Meta Tags nach dem Komma ein Leerzeichen eingefügt wird.

    füge das Leerzeichen einfach ein

    Beispiel
    aus

    Code
    $parsed = str_replace(" ",",",$str);


    wird

    Code
    $parsed = str_replace(" ",", ",$str);

    PHP Handbuch
    http://de.php.net/manual/de/function.str-replace.php

    Auf die Zeile solltest du dann allerdings verzichten

    Code
    $keywords = preg_replace("/, $/","", $keywords);

    Hoffe die Antwort hilft weiter

    ralf


    5. Andere User mit ähnlichen Problemen haben ihre .htaccess-Datei (hatte ich bislang nicht, musste ich erstellen) um folgenden Code erweitert: AddType x-mapp-php5 .php
    # BEGIN WordPress

    Beachte die Systemanforderungen von WP... Ich persönlich verwende bevorzugt 5.2.14 wegen kompatibitäts Problemen mit 5.3.x bei einigen Plugins...


    Dann hieß es wieder: Zugriff verweigert.

    Damit die Domain A auf die Datenbank der Domain B zugreifen kann, muss dein Provider dir dies erlauben (konfigurieren).

    Was steht in der Error Log Datei vom WebServer oder MySQL-Damon?

    cu

    ralf


    entsprechend der Vorlage habe ich im php Script (wp-config-sample.php) die Änderungen vorgenommen, unter wp-config.php auf den Server geladen und im Browser http://www.bewepe.org/wp-admin/install.php angewählt mit dem Ergebnis, dass er es nicht genommen hat.

    Die Dateien sind vermutlich in einem falschen Verzeichnis. Überprüfe einfach noch einmal das Verzeichnis. Einfach eine Grafik in das Verzeichnis
    von http://www.bewepe.org/wp-admin/install.php legen und im Browser pürfen, ob die Grafik angezigt wird mit http://[URL="http://www.bewepe.org/wp-admin/install.php"]http://www.bewepe.org/die_grafik.jpg [/URL]



    Im php Script stand im Kommentar ich soll unter ttps://api.wordpress.org/secret-key/1.1/salt/ WordPress.org Keys generieren lassen. Das habe ich getan und diese seltsamen Sonderzeichen in Zeile 44 bis 51 eingetragen

    einfach die Zeilen kopieren und im Script einfügen. Die Keys werden zur Sicherheit verwendet. (Autorisierung des Systems)

    Wie - steht in den Quellen, die dir zur Verfügung stehen. Einfach nach in den Quellen nach dem Key suchen

    Beispiel
    Suchen nach: AUTH_KEY

    Code
    wp-admin\network.php(341): $keys_salts = array( 'AUTH_KEY' => '', 'SECURE_AUTH_KEY' => '', 'LOGGED_IN_KEY' => '', 'NONCE_KEY' => '', 'AUTH_SALT' => '', 'SECURE_AUTH_SALT' => '', 'LOGGED_IN_SALT' => '', 'NONCE_SALT' => '' );
    wp-admin\setup-config.php(233): case "define('AUTH_KEY":
    wp-admin\includes\ms.php(683): $secret_keys = array( 'AUTH_KEY', 'SECURE_AUTH_KEY', 'LOGGED_IN_KEY', 'NONCE_KEY', 'AUTH_SALT', 'SECURE_AUTH_SALT', 'LOGGED_IN_SALT', 'NONCE_SALT' );
    wp-content\plugins\openid\Auth\OpenID\DumbStore.php(55): $this->auth_key = Auth_OpenID_SHA1($secret_phrase);
    wp-content\plugins\openid\Auth\OpenID\DumbStore.php(96): return $this->auth_key;
    wp-includes\pluggable.php(1333): if ( defined('AUTH_KEY') && ('' != AUTH_KEY) && ( $wp_default_secret_key != AUTH_KEY) )
    wp-includes\pluggable.php(1334): $secret_key = AUTH_KEY;
    wp-includes\pluggable.php(1348): if ( defined('SECURE_AUTH_KEY') && ('' != SECURE_AUTH_KEY) && ( $wp_default_secret_key != SECURE_AUTH_KEY) )
    wp-includes\pluggable.php(1349): $secret_key = SECURE_AUTH_KEY;
    Es wurden 13 Vorkommen in 7 Datei(en) gefunden.

    Datei (Zeile) Programmzeile

    Gruß

    ralf


    Nun habe ich ein Problem: Drei vier mal am Tag schaue ich auf Regionalen-Internetseiten nach Nachrichten aus meiner Region. Mir geht es auf den Keks alle Seiten jedesmal zu starten.

    Daher die Idee: Ich lege mir ein kleines WP an. Irgendwo tief auf meinem Server und nur für mich. Dieses WP soll ein Script / Plugin haben, dass ständig die RSS Feeds meiner regionalen Nachrichtenseiten im Auge hat. Sobald hier ein Artikel erscheint, postet das PlugIn diese RSS Meldung der Seite in meinem WP. So brauche ich nur noch eine Seite aufrufen und habe hier immer eine Übersicht der aktuellen Nachrichten. Und vor allem Nachrichten die mich wirklich interessieren.

    Dafür verwendet man in der Regel einen PLANET

    http://getlilina.org/

    Laut Wiki kann man auche einen Feed Aggregator (Planet) mit WP und einem Plguin erstellen

    http://de.wikipedia.org/wiki/Planet_%28Software%29



    169 Euro dafür zu bezahlen. Gibt es da noch etwas anderes?

    http://www.youtube.com/watch?v=JI3Df7-KFtw

    Gleichzeitig sollte man sich vorher mit den Rechten der Autoren beschäftigen

    http://de.wikipedia.org/wiki/Urheberrecht

    Nur weil eine Webseite einen Feed anbietet, sollte man nicht daraus ableiten, dass man den Inhalt auf seiner Seite einbinden darf.

    gruß

    ralf


    ich habe folgende Fehlermeldungen auf meinem Dashboard (Admin Bereich) stehen.

    wp-security-scan verwendet ein sehr alte simplepie Klasse.

    Diese Klasse hat einen Fehler in deiner Umgebung gefunden

    und kann den gefundenen Fehler nicht per error_log ausgeben, weil deine Umgebung merkwürdig konfiguriert ist.

    Schalte die error_log einfach ein und sehe dann nach, was das Problem ist.
    Wie man die error_log einschaltet steht im PHP Handbuch
    http://www.php.net/manual/de/

    oder rufe deinen Prodiver an.... und frage dort auch nach, warum deine Umgebung Fehler-Meldungen an den Browser sendet... und so Angreifer schon mal die Pfade auf dem System mitteilt. (total sinnvolle Konfiguration)

    cu

    ralf


    Ich habe die media.php bei der -base Domain in old benannt und eine "unbefleckte" von WP hochgeladen, und die media.php bei der -forum Domain ebenfalls in old umbenannt, nun kommt folgende Fehlermeldung:

    schön - aber dabei hast du vergessen, dass du auch auf -forum eine media.php augenscheinlich benötigst.


    Fatal error: require() [function.require]: Failed opening required '/home/www/doc/22765/unheilig-forum.com/www/wp-includes/media.php' (include_path='.:/usr/local/lib/php:/usr/local/php/lib/php:/usr/local/php/share/pear') in /home/www/doc/22765/unheilig-forum.com/www/wp-settings.php on line 130

    und was verstehst du an dieser Meldung nicht?

    cu

    ralf


    Und, ich habe versucht das 1. ein RSS Feed auf meinem Blog angezeigt wird wo jedoch noch nichtmal das Widget angezeigt wird und wenn ich auf beim der Plugin Verwlatung auf Speichern gehe bekomme ich diese Fehlermeldung

    Code
    Parse error: syntax error, unexpected $end in /users/{name entfernt}/www/blog/wp-includes/class-simplepie.php on line 13546

    Doch die besagte Zeile besteht nur aus:

    simplepie kann von dem RSS Feed keinen Type ermitteln.

    PHP
    function get_type()
        {
            if (isset($this->file->headers['content-type']))
    ...
            else
            {
                return $this->unknown();
            }
        }

    D.h. vermutlich wird file->headers['content-type']) leer sein, weil
    nichts angekommen ist.

    Dies kann viele Gründe haben.
    Falsche URL vom Feed (z.b. ohne http://)
    oder
    Schrottige PHP Installtion bei einem Massenhoster bei dem wichige PHP Funktionen fehlen.
    oder
    fehlerhafter Feed
    oder
    fehlende Erlaubnis für den Zugriff per simplepie
    usw.

    Ob Simplepie den Feed lesen kann, kann man über die Homepage von dem Projekt prüfen
    http://simplepie.org/demo/


    cu

    ralf

    Hallo Till,


    Nun bin ich drauf und dran, im Backend den Button "Auf 3.0 aktualisieren" zu drücken. Dazu gesagt, ich bin absoluter Laie.

    - Erstelle eine Datensicherung von der Daten in der Datenbank mit einem richtigen Datenbank Tool und nicht mit einem PHP-Scriptchen!

    - Erstelle von den Dateien eine Sicherung

    - aktualisiere auf die 3.0

    Wenn es schief geht, spiele deine Datensicherung zurück.


    > sry, echt k.A.)

    Suche dir jemanden, der Ahnung hat.


    3. Es sind ein paar spezielle Sachen wie Forum, Facebook Connector etc. eingebaut. Die beeinträchtigen doch sicherlich die Installation des neuen WP 3.0

    Warum? Sind dies wilde eigen bastelleien? Dann bau diese mit Deinem Entwicklungs Tool, dass dir Diffs (unterschiede zwischen den PHP Skripten) anzeigt nachträglich in die 3.o ein - oder erstelle pflegbare WP-Plugins.


    cu

    ralf

    Hallo,


    Ich verfüge bereits über den Code für das Form und den PHP code für den Parser und die Eintragung in die externe Mysqldatenbank. Eingefügt in einer normalen Wordpress Seite funktioniert das wunderbar.

    Nun möchte ich diese Funktionalität als Widget in meine Sidebar integrieren, Die Herausforderung dabei ist, dass wenn der Submit Button gedrückt wird, die Seite nicht neu geladen werden, sondern lediglich die Anfrage an die DB geschickt werden soll (und das Textfeld geleert).

    Das übersenden des Textfeldes an Deine Anwendung erfolgt über ein
    Formular.

    Evtl. hilft dir für ein besseres Grundlagen verständnis die PHP FAQ#s der Newsgroup

    Wie übergebe ich Variablen aus einem Formular an ein PHP-Script?
    http://www.php-faq.de/q-formular-variablen.html


    Würdet ihr solch eine Problemstellung mit einem Ajax Widget lösen, welches eine PHP Datei aufruft, und an diese den Textfeldinhalt übergibt?

    Wie von dir schon richtig erkannt, funktioniert die Sendung des Textfeldes mit PHP alleine nicht. Du benötigst, zur Vermeidung von "die Seite nicht neu geladen werden" Ajax - wenn man - aus welchen Gründen auch immer Javascript in der Seite haben möchte -

    http://de.wikipedia.org/wiki/Ajax_%28Programmierung%29

    In dem Beispiel kannst du sehen, wie man Daten per get - methode an das PHP Skript *datum.php* übersendet

    http://de.wikipedia.org/wiki/Ajax_%28P…ung%29#Beispiel



    Oder gibt es eine einfachere Lösung, ggf. in einem Wordpressplugin?

    In der Regel erstellt man Datenbank-Scripte so, dass man diese mit den unterschiedlichsten Methoden (POST, GET... REST) ansprechen kann und verzichtet hierbei auf JavaScript gebastel.

    http://www.php-faq.de/q-formular-methode.html

    Optinonal kann man Ajax verwenden reduziert sich hierbei allerdings erheblich in den Cleints.

    cu

    ralf

    Hallo Yvonne,


    “1.JPG” konnte wegen eines Fehlers nicht hochgeladen werden
    Die hochgeladene Datei konnte nicht nach C:\Inetpub\vhosts\yvonne-pauli.de\httpdocs/wp-content/uploads/2010/07 verschoben werden.

    evtl. ist der gebuchte Speicherplatz bei deinem Provider voll. Oder die Rechte für C:\Inetpub\vhosts\yvonne-pauli.de\httpdocs/wp-content/uploads/ wurden geändert.

    Am einfachsten wendest du dich an deinen Provider.

    cu

    ralf

    na, daß man ein von WP programmiertes Update 10-20 mal installieren resp.

    Gibt deinem Script ZEIT und RAUM für eine Ausführung der Befehle und dann muss nichts x fach installiert werden. Wenn die Ausführungszeit für PHP nicht aussreicht erhöhe diese. Wenn du die Zeit nicht selber ändern kannst, wende Dich an deinen Provider.

    Für die Ausführung von Datenbank-Aktionen kann PHP auch mal etwas mehr Speicher benötigen. Wenn PHP auch mal eben eine ZIP-Datei entpacken soll,
    benötigt PHP auch Speicher. Wenn du PHP zuwenig Speicher gibst, erhöhe den Speicher.. wenn du dies nicht selber ändern kannst, wende Dich an deinen Provider.

    Wenn du bei einem Massenhoster bist, suche dir einen Provider.

    cu

    Ralf

    Hallo Sylvie

    Ich habe versucht, auf WP 3.0 upzudaten, auch bei mir hat es nicht funktioniert,

    Ich hatte auf meinen System keine Probleme. Dieser Hinweis bringt dich jetzt nicht weiter, aber ich wollte damit nur ausdrücken, dass das System
    auch funktionieren kann.


    Problem ist nur, daß bei den unzählen Versuchen es upzudaten wohl irgendwas teilweise installiert wurde und nun - im Moment - das plugin fotobook nicht mehr funktioniert.

    Vor dem Upgrade erstellt man sich in der Regel ein Buckup. Punkt 1 der Anleitung
    http://doku.wordpress-deutschland.org/Upgrade#1._Erstelle_ein_Backup.21

    Ist dieses Buckup vorhanden so installiere dir dieses einfach zurück.
    Sollte es nicht vorhanden sein? Solltest du den Fehler für eine funktionierenden Hilfe repruduzierbar erklären... oder über eine Job Ausschreibung einen Dienstleister für wenig Geld dir suchen.


    auf jeden Fall muit Abhilfe geschaffen werden, da ich keine Lust habe die hunderten von Bilder nochmal irgendwo hochzuladen, damit ich diese auf WP darstellen, resp. präsentieren kann.

    Welche Fehlermeldungen erhälst du?
    Kannst du das Pluign deaktivieren?
    Gibt es von dem Hersteller eine neue Version?
    Hast du einen Link zum Pluign für uns?

    Viel Glück

    Ralf

    Hallo Magnus,

    lass mich raten... du verwendest PHP 5.3.x?


    Beim Versuch zu Exportieren kommt dieses hier:
    Warning: Illegal offset type in isset or empty in /var/www/MBuehl/htdocs/wp_it/wp-includes/taxonomy.php on line 176

    Was passiert, wenn du die Zeile 176 an deine Umgebung "anpassts"?

    PHP
    return isset( $wp_taxonomies[$taxonomy] );

    Was verursacht die Meldung? D.h. was steht in $taxonomy und oder in $wp_taxonomies bei der Erzeung der Fehlermeldung?

    http://de3.php.net/manual/de/function.print-r.php

    cu

    ralf


    Hab den gesammten Wordpress Ordner gelöscht und das neue WP 3.0 geuppt. Danach den wp-content Ordner und die wp-config.php mit denen von WP 3.0 ersetzt. Anschließend wie gefordert die Update Seite geöffnet und die Datenbank aktuallisiert.

    Ich hoffe du hast das Verzeichnis ~/wp-content/ nicht auf dem Server gelöscht?
    Auch deine alte .htaccess sollte nicht gelöscht werden.


    Code
    [B]
    Objekt nicht gefunden![/B]
    
    
     
    [B]Error 404[/B]

    Woran kanns liegen?

    Was steht in der error-log Datei vom WebServer? Was im Browser angezeigt wird, interessiert bei einer Server Seitigen Lösungen keinen... zumindest mich nicht.

    cu

    ralf

    Hallo,

    ich würde jetzt / heute beginnen und nicht auf irgendeine Software warten, die evtl. in wenigen Wochen mit vielen Fehlern veröffentlicht wird.

    die 2.9.2 version ist stabil, und dafür gibt es kostengünstige fertige templates.

    und im sommer, wenn die leser so oder so in den sommerferien sind, sucht man sich einen Dienstliester, der für das Unternehmen ein passendes Template für die wp 3.x erstellt und läßt das update von einem Dienstleister *wink* durchführen.

    Aber in den Sommerferien, würde ich kein "neues Firmen-Projekt* anfangen wollen.

    Gruß

    Ralf

    Diese datei wird in der neuen Version nicht mehr vorhanden zu sein oder nicht mehr unterstützt werden:

    Die Fehlermeldung wird durch die Server Konfiguration von der Datei erzeugt

    Code
    // very often exec()or passthru() is disabled. No chance for Imagick
            if ( ini_get('disable_functions') ) {
                $not_allowed = ini_get('disable_functions');
                if ( stristr($not_allowed, 'exec') || stristr($not_allowed, 'passthru') ) {
                    $this->errmsg = 'exec() or passthru() is not allowed. Could not execute Imagick';
                    $this->error = true;
                    return false;
                }
            }

    die Zeile

    Code
    $this->errmsg = 'exec() or passthru() is not allowed. Could not  execute Imagick';

    gibt die Meldung aus
    exec() or passthru() is not allowed. Could not execute Imagick

    Ergo: No chance for Imagick

    Selbstverständlich funktioniert bei entsprechenden Serverumgebungen die
    Verwendung von Imagick

    cu

    Ralf