Bei der Installation über den WordPress Upload bekam ich eine Fatal Error Fehlermeldung (allowed memory size...)
Genau das dürfte auch die Ursache für die leere (weiße) Seite sein. Das memory_limit des Servers ist nicht ausreichend. Wie Du das Ändern kannst findest Du via Forensuche. Ggf. kann auch nur der Hoster bzw. ein Wechsel in ein anderes Hostingpaket helfen.