Hast Du den Code im Editor eingegeben, oder wird der in einer Template Datei aufgerufen? Für den ersten Fall: Das funktioniert nicht. Um PHP in Posts oder Pages auszuführen, benötigst Du ein zusätzliches Plugin, das dies ermöglicht
http://wordpress.org/extend/plugins/search.php?q=php
Beiträge von mfitzen
-
-
Das sieht mir eher nach einer sortierbaren Tabelle aus... Das kann man auch mit wp-table reloaded hinbekommen.
Alternativ hier mal schauen: http://wordpress.org/extend/plugins/search.php?q=event&sort=
-
Frag mal Deinen Hoster, warum die Datei nicht zugänglich ist. Die error.log ist nicht bei allen Hostern verfügbar. Warum weiß der Geier...
Ohne zu wissen wodurch der Fehler verursacht wird, fischen wir im Trüben...
Hast Du nach dem Deaktivieren der Plugins den Browsercache mal geleert?
Versuche mal http://www.example.com/wp-admin/themes.php aufzurufen (ersetze example.com durch Deine Domain). Wenn das geht, aktiviere bitte das Standardtheme.
-
Es gibt bei der Variante die ich vorgeschlagen habe keine bedenklichen Fallen oder Stolpersteine.
Doch die gibt es. Man erlebt oft, dass User nicht wissen, was PHPMyAdmin ist und wie man die Oberfläche bedient, geschweige denn Ahnung davon haben, die verlinkten Punkte zu finden. Klingt komisch, ist aber so.
Bedenke bitte auch, dass dieser Thread nicht nur vom Threadersteller gelesen wird. Selbst wenn dieser den Tipp nachvollziehen u. durchführen kann, wird es immer wieder User der eben beschriebenen Kategorie geben. Eben solche die sich nicht damit beschäftigt haben/beschäftigen wollen. Wenn man nicht weiß was man tut, kann man viel kaputt machen.
-
Ich rate von Punkt 4 des obigen Links ab! Eingriffe in die Datenbank sind nicht ohne. Plugins deaktivieren geht auch ohne DB (und da spielt es keine Rolle ob diese irgendwelche Tabellen erstellt haben...). Einfach die Ordner der Plugins umbenennen. Plugin wird nicht mehr gefunden, ergo deaktiviert. Ggf. gibt es Fehler im Theme, wenn dort ein Templatetag des jeweiligen Plugins eingefügt wurde. Dann muss dieser eben auskommentiert/entfernt werden.
Hinweis: Die unterstrichenen Begriffe hier im Forum sind anklickbar. Weiße Seite bedeutet zu 99% ein PHP Fehler, der am Bildschirm nicht ausgegeben wird. Ein Blick in die error.log dürfte Licht ins Dunkel bringen (sofern verfügbar).
Häufige Ursache für eine weiße Seite ist z.B. ein zu niedriges memory_limit, oder ein Leerzeichen/eine Leerzeile in einer Datei (BOM).
-
Hattest Du auch die functions.php übernommen?
-
Bilder werden in der Mediathek nur angezeigt, wenn sie auch über die Mediathek-Uploadfunktion hochgeladen wurden.
-
Beschreibe Dein Problem bitte genauer. Deine jetzige Beschreibung ist nicht aussagekräftig genug. Was hast Du genau vor?
-
-
Google + wordpress menü erstellen =
-
Zitat
Meine Seiten werden einfach alphabetisch sortiert sag ich mal
Wenn das Theme die WP-Menüfunktion unterstützt, dann kannst Du die Seiten per Drag & Drop nach Deinen Wünschen anordnen.
Du verwendest ein Theme, welches mit Artisteer erstellt wurde. Kann es sein, dass dabei noch eine alte Version der Software genutzt wurde? Da scheint es mal Probleme gegeben zu haben...
ZitatArtisteer 2.5 (WordPress 3.0 compatibility update)
...
Horizontal menu order was not workingEDIT: Gerade getestet. Das Theme unterstützt die Menüfunktion (siehe Design->Menüs) und das Sortieren der Seiten funktioniert darüber problemlos.
-
Ich hab schon vieles gelesen und plugins benutzt aber nichts hat geholfen ...
Welche Plugins wurden benutzt? Welche Fehler gab es? Welches Theme benutzt Du? Wie werden die Seiten aktuell sortiert? Werden die Seiten von einem Widget ausgegeben oder wird ein Template Tag verwendet? Schonmal versucht beim Schreiben unter Attribute eine Reihenfolge festzulegen?
http://www.google.com/cse?sitesearch…gsradar-de.html
Falls ein Template Tag genutzt wird, dann kann man der Funktion wp_list_pages() einen Parameter übergeben, mit dem man festlegen kann wonach sortiert werden soll. Hier wäre dann
zu verwenden.
-
Du kannst beim Schreiben der Seiten auswählen ob Kommentare erlaubt werden sollen oder nicht. Dazu gibt´s eine kleine Box (ggf. unter Optionen einblenden -> oben rechts aktivieren) in der Du entsprechende Haken setzen kannst. Wenn das nicht greift, wie es bei Dir der Fall ist, dann könnte der Browsercache oder ein Cache Plugin dazwischenfunken.
Möglichkeit 2 wäre die Kommentarfunktion im Seitentemplate zu entfernen.
-
Dann deaktiviere die Option "Organisiere Uploads nach Jahren u. Monaten" (sinngem. Wortlaut). Die Einstellung findest Du irgendwo in den Backendeinstellungen (ich meine unter Mediathek)
-
Deaktiviere bitte wie bereits von Marcus[IS] angemerkt mal alle Plugins und wechsel zusätzlich auf´s Standardtheme. Dann lösche den Browsercache und prüfe ob das Problem weiterhin besteht.
-
alchymyth: Danke, dass Du bis hierhin weitergemacht hast!
Kurze Zwischenfrage: Wäre es nicht einfacher statt die ganzen Kategorien auszuschließen sowas zu benutzen:
?
-
Wenn Dir die englische Beschreibung reicht:
ZitatProblem: Getting error message “WP Super Cache is installed but broken. The path to wp-cache-phase1.php in wp-content/advanced-cache.php must be fixed!” at the bottom of the page source of the site.
Solution: Go to your FTP account and download the file advanced-cache.php from wp-content. If you mahe moved your site from one server to another then you will have to change the path of the file wp-cache-phase1.php in the advanced-cache.php file. Open the downloaded file and there you can see two paths provided in the PHP file. Change those paths to the correct one on your server and then upload the file. You are done. Now you can reload the page and check he page source. There at the bottom of the page source, you can see WP Super Cache ran successfully.
-
Das Plugin versucht etwas in das Verzeichnis wp-content/cache/ zu schreiben. Prüfe 1. ob dieses Verzeichnis existiert und 2. ob das Verzeichnis beschreibbar ist (CHMOD). Wenn das Verzeichnis nicht existiert, erstelle es per FTP Tool und gib ihm die nötigen Schreibrechte (CHMOD 755 oder je nach Hoster CHMOD 777). Das kannst Du ebenfallls mit dem FTP Tool machen.
-
Naja, wenn Du nicht gewillt bist, Dir die angebotenen Lösungsvorschläge anzuschauen, dann kann man Dir auch nicht wirklich helfen.
Zumal Dein Thread auch noch nicht all zu alt ist... Siehe Forenregeln
-
Schonmal den Link (u. die darin angegebenen weiterführenden Links) näher betrachtet?