Das wird vermutlich über eine individuelle Programmierung eingefügt sein, ist bei UserCentrics leider notwendig. Oft macht man das über ein Code Snippet Plugin oder die functions.php vom Child-Theme. Schau dir daher mal deine Plugins an und was diese ermöglichen. Da Du dass kommerzielle Theme Divi nutzt, könnte es auch darüber irgendwo eingefügt sein - ob und wo das geht müsstest du deren Support fragen.
Beiträge von threadi
-
-
Relevant zur Analyse sind nicht die kompletten Dateien sondern nur der zeitlich passende Abschnitt wo der Fehler aufgetreten ist. Den kannst Du hier im Forum mit einem code-Tag einfügen.
-
Programmierst Du das selbst oder suchst Du nach einer Klick-Lösung? Wenn ersteres, wie hast Du die eine einzelne Datei bisher dem Posttype-Datensatz zugeordnet?
-
Ein kritischer Fehler wird im Error-Log im Hosting dokumentiert. Aus diesem ist i.d.R. die Ursache zu erkennen. Suche daher dein Error-Log und schau es dir an. Gerne kannst Du den dort dokumentierten Fehler hier auch zeigen damit man das für dich analysieren kann.
WordPress benötigt normalerweise keinerlei FTP-Zugangsdaten für irgendetwas. Wenn Du so etwas machen sollst, dann ist dein WordPress entweder durch eine Angabe in der wp-config.php falsch eingestellt oder die Verzeichnisse und Dateien deines Hostings sind nicht beschreibbar. Letzteres könnte auch ein Grund für den kritischen Fehler sein. Falls es so ist, müsste der Support deines Hostings das für dich klären können.
-
Ich kann im Quellcode keinerlei Bildbeschriftungen sehen. Laut Anleitung von Elementor https://elementor.com/help/basic-gallery-widget/ sollten die nur angezeigt werden, wenn sie in der Medien-Datenbank zu dem Bild hinterlegt sind.
Wenn Du weitere Fragen zu Elementor hast, würde ich dir deren Supportforum empfehlen: https://wordpress.org/support/plugin/elementor/
-
Das Plugin schickt offenbar eine Anfrage an den Server um danach irgendetwas darzustellen. Als Antwort kommt jedoch
wodurch das Plugin nichts weiter verarbeitet.
Warum das so ist, sollte dir der Support des Plugins am ehesten sagen können: https://wordpress.org/support/plugin…or-woocommerce/
-
Such dir ein für dich passendes Newsletter-Plugin. Das kann unabhängig von Elementor verwendet werden: https://de.wordpress.org/plugins/tags/newsletter/
-
Da es von deiner Website aus nicht änderbar ist: nein.
Die Alternative wäre solche textlichen Inhalte nicht per embed einzubinden sondern zu importieren. Wenn die eingebundene Website diese auch als RSS-Feed bereitstellt, kannst Du in deinem WordPress einen Import dieser Inhalte ergänzen. Dann hast Du auch volle Kontrolle darüber wie diese ausgegeben werden. Setzt aber den RSS-Feed voraus, dazu musst du dich an den Betreiber der anderen Website wenden.
-
War ein richtig gutes Event. Die Videos der Vorträge sind bereits online: https://wordpress.tv/event/wordcamp-karlsruhe-2024/
-
-
Opinion ist ein kommerzielles Theme. Das wird hier vermutlich niemand extra kaufen um dir die Frage zu beantworten. Ein Link zur Seite, wie in den Forenregeln beschrieben, wäre hilfreich. Alternativ müsstest du dich für deine Frage an den Support deines Themes wenden, den du eigentlich mitgekauft hast.
-
Dann wende dich an den Support des Themes. Da läuft offenbar etwas falsch.
-
Das Problem ist nicht der doppelte Slash sondern der in der URL enthaltene absolute Pfad zur Datei. Absolute Pfade gelten nur auf dem Server, nicht beim Aufruf im Browser.
Wie hast Du die Schriftart eingebunden? Ich vermute dass an der Stelle der falsche Pfad gesetzt wurde. Das müsstest Du anpassen.
-
Das mache ich bei einigen Shops mit diesem kommerziellen Plugin: https://codecanyon.net/item/woocommer…options/7908619
Ob es auch bei diesem kostenfreien geht weiß ich nicht, aber kannst es versuchen: https://wordpress.org/plugins/woo-extra-product-options/
-
Schau mal unter Werkzeuge > Website-Zustand nach, ob dort Auffälligkeiten genannt werden. Insbesondere bei Info, wo die Verzeichnisse aufgelistet werden.
Schau nach, ob du ein Sicherheitsplugin oder ein Plugin hast was Updates für dich managed. Das könnte auch hieran Schuld sein.
Schau auch mal in die Datei wp-config.php, ob dort eine Zeile mit FS_METHOD enthalten ist. Wenn diese NICHT so aussieht
entferne sie mal testweise oder ändere den Wert auf direct ab.
-
-
-
PS r23: das Formular wird nur intern genutzt ohne Datenbankabfrage
Das spielt keine Rolle. In jeder Umgebung sollte jede Software möglichst gut abgesichert sein. Du hast dort ein richtig großes Loch aufgemacht. Wer sagt dir, dass in 5-6 Jahren dieser Code immernoch nur intern genutzt wird? Irgendwer öffnet es, ohne von dieser Sicherheitslücke zu wissen, das Netz nach außen. Oder jemand kopiert es von hier im Forum oder aus deiner Datei woanders hin und schon knallt es. Wenn man als Entwickler etwas Ehre hat, sollte man auf Hinweise dazu schon anders eingehen.
Denn die Absicherung wäre so einfach. filter_input(), sanitize_text_field(), wp_unslash() wäre ein Anfang. Ich weiß nicht wieso man darüber erst noch reden muss?
-
Du solltest keine Dateien ändern die dem WordPress Core gehören. Nur Dateien in deinen eigenen Plugins oder deinem Child-Theme solltest du anpassen.
Wenn Du eine Eigenschaft im CSS siehst die vermeintlich der Grund sein könnte, überlade diese Eigenschaft mit einem CSS-Code den Du selbst in einer eigenen CSS-Datei ergänzt. Da es ums Backend geht, kannst Du solche Änderungen nicht im Customizer hinterlegen.
Die Eigenschaft
steht in jedem Fall in mehreren CSS-Dateien vom Core. Ich bezweifle jedoch, dass die Angabe der Höhe ein Grund ist. Diese Angabe gibt es schon seit vielen Jahren im Core und ich kenne niemand anderen der damit ein Problem hat.
-
@b3317133
Jetzt muss ich noch genau finden, in welcher CSS-Datei diese Anweisung ist...^^Das ist rechts neben der Zeile zu sehen wo du diese Eigenschaft im FF siehst. Den Dateinamen kann man anklicken oder auch mit der Maus drüber fahren um den Pfad zu sehen.