Zur Ursache kann ich Dir auch nicht wirklich was sagen, aber bist Du zufällig bei 1&1? Das Thema gab es nämlich vor ein paar Tagen gerade schon mal (Wink mit dem Zaunpfahl: Suchfunktion *g*): http://forum.wordpress-deutschland.org/konfiguration/…-geaendert.html
Beiträge von Ammaletu
-
-
Oder es tritt generell ein PHP-Fehler auf (Plugin? Fehler in der page.php?), was Du im PHP-Errorlog überprüfen kannst.
-
Wenn Du Dir nicht sicher bist, was die einzelnen Dateien eines Themes tun, kannst Du das z.B. hier nachlesen:
The Template Files List
Template HierarchyKurz gesagt: In der single.php sollte die comments.php eingebunden sein, und da steht dann die ganze Ausgabe der Kommentare und des Kommentar-Formulars drin. Wie es auszusehen hat, kannst Du Dir wie gesagt am Standard-Theme anschauen. Falls dort alles richtig aussieht, folge doch mal jottliebs Vorschlag und stelle das Blog kurz testweise auf das Default-Theme um. Falls es da auch nicht geht, liegt es an was anderem (Optionen, Plugins). Apropos Optionen, das Kommentieren ist aber erlaubt, oder?
-
Fast richtig. Es ist: for-wii-fans.de
(Richtig, Syntronica?)
Inwiefern er Dir weiterhelfen kann, weiß ich allerdings auch nicht. -
Was spricht dagegen, einen entsprechenden Link irgendwo im Theme unterzubringen? Klassischerweise ist ja immer das Headerbild entsprechend verlinkt, aber man kann doch auch einfach als ersten Link in der Sidebar einen Home-Link einfügen, oder?
-
Also da fällt mir spontan das RoleManager-Plugin ein. Damit kann man wohl wesentlich genauer Berechtigungen an Rollen vergeben als WP das von Haus aus kann. Vielleicht hilft Dir das ja weiter. Ob man damit das Ziel nach dem Login ändern kann, weiß ich aber auch nicht. Aber wurde das hier im Forum nicht vor wenigen Wochen gerade schon mal gefragt?! Kommt mir so bekannt vor...
-
Ja sicher, mittels CSS. Siehe z.B. SelfHTML.
-
Ich würde das mal so beantworten: Wenn Du Widgets für die Sidebar nutzt, musst Du nehmen, was Du als Widgets findest oder eines selber schreiben. Da ich selber Widgets nicht nutze, kann ich Dir da aber leider keine weiteren Hinweise geben.
Wenn Du keine Widgets für die Sidebar nutzt, dann wird die Sidebar aus der sidebar.php in Deinem Theme aufgebaut. Und da kannst Du an PHP/HTML/JS reinschreiben, was immer Du möchtest.

Wenn Du lieber bei Widgets bleiben möchtest, müsste mal jemand anders sagen, ob es da entsprechende Widget-Plugins gibt. Kann aber sein, dass es das nicht gibt, denn Widgets sind extra dafür da, möglichst einfach zu sein, manchmal auf Kosten der Konfigurierbarkeit (was man so liest jedenfalls).
-
Bzw. was ich mal aufgeschnappt habe: Man kann Akismet auch statt als WordPress-Plugin als SpamKarma-Plugin laufen lassen. Vielleicht verbessert das ja die Erkennungsrate?! Für die Details müsstest Du mal googlen...
-
Dass z.B. das Umschalten zwischen visuell und Code-Ansicht nicht geht, ist schon mal komisch.Treten dabei denn JavaScript-Fehler auf? Ansonsten würde ich den FF vielleicht mal im Safe Mode starten, dann kannst Du die Add-Ons ggf. etwas zuverlässiger ausschließen.
-
Ich habe jetzt rausgefunden, wieso manchmal die Optionen des Plugins sich einfach nicht auswirken. Ich denke, es ist ein Bug und habe es dem Plugin-Autor entsprechend gemeldet. Der Fall tritt IMHO auf, sobald man wenigstens eine Option an der st_the_tags-Funktion definiert hat. Für alle anderen Optionen werden dann die default-Werte benutzt (Wer mag kann sich die Gründe im File simple-tags.php in der Funktion extendedTagCloud() anschauen).
Man muss also entweder st_the_tag_cloud() ganz ohne Parameter aufrufen oder alle benötigten Paremter dort angeben. Mit einem Aufruf von z.B. st_the_tag_cloud('color=false') bekommt für alle nicht als Funktionsargumente angegebenen Optionen die Default-Werte statt der gespeicherten Werte.
Mit etwas Glück behebt der Autor das in der nächsten Version. Wer sich mit PHP auskennt, kann es auch selber umschreiben. Am einfachsten ist es aber sicher, einfach beim Aufruf der Funktion alles benötigte zu setzen (wegen des color-Parameters geht es bei mir jedenfalls nicht ganz ohne).
Inwiefern das dann mit den Widgets zusammenspielt, weiß ich auch nicht. Falls die Widget-Funktion intern extendedTagCloud() mit Argumenten aufruft, passiert dort natürlich das gleiche, nur dass man da nicht viel dran machen kann. Da weiß ich aber leider zu wenig über Widgets, um da genaueres sagen zu können.
-
Nur noch mal als Anmerkung dazu: Falls Du mit Deinem Edit nicht Informationen gelöscht hast, ist Dein Posting ein Musterbeispiel dafür, wie man es nicht machen sollte. Damit jemand etwas dazu sagen kann, hättest Du Informationen wie WordPress-Version oder den Namen des Themes angeben sollen. Ob Du im PHP-Fehlerlog nachgesehen hast, wäre auch mit meine erste Frage gewesen. Und in 9 von 10 Fällen hilft ein Link zur Seite, wo man sich das ganze live anschauen kann, weiter.
Ist nicht böse gemeint, ich wollte es nur mal angemerkt haben. Ggf. fürs nächste Mal.

-
Also das klingt soweit richtig und machbar. Die tabellarische Darstellung ist kein Problem, denke ich. Du musst halt die Ausgabe in der entsprechenden Datei Deines Themes anpassen. Folgende Dateien stellen im Default-Theme Listen von Beiträgen dar: index.php (Startseite), archive.php (Archiv nach Kategorie, Tag, Monat, Jar, Autor) und search.php (Suchergebnisse). Eventuell hat Dein Theme noch mehr oder weniger Dateien dieser Art. Man kann z.B. ein extra Template für die Kategorie-Ansicht anlegen (category.php, glaube ich).
In diesen Dateien werden in einer while-Schleife die einzelnen Beiträge ausgegeben. Da kannst Du genauso gut außerhalb der while-Schleife eine Tabelle definieren und dann innerhalb jeweils eine Tabellenzeile mit den nötigen Infos erzeugen.
Was ich Dir aus dem Kopf jetzt nicht so genau sagen kann, ist die Sortierung bzw. Umsortierung der Beiträge. Standardmäßig sind sie ja chronologisch absteigend sortiert. Vermutlich kann man sich da aber auch reinhängen und das ändern.
-
Wie man auf dem Screenshot sehen kann, hat der Content-Bereich an sich schon die richtige Größe. Nur der Header wird abgeschnitten. So auf den ersten Blick denke ich, könnte das daran liegen, dass der Header-Container keine Weite definiert hat!? Aber genauer lässt sich das eigentlich nur an der Seite selber sagen. Ist die schon online?
-
Die Funktion wp_update_user() ist im File "wp-includes/registration.php" definiert. Die Funktion validate_username() steht in der gleichen Datei. Die Fehlermeldung ist ja eigentlich eindeutig: PHP findet die Funktion nicht. Das sollte in 9 von 10 Fällen eigentlich heißen, dass die Datei fehlt oder kaputt ist. Schaue also auf dem Server mal bitte nach der Datei und lade sie ggf. neu hoch.
-
Dazu fällt mir auf Anhieb nur ein, dass zwischen WP 2.2 und 2.3 einiges an der Tabellenstruktur geändert wurde, wegen der neuen WP-Tags. Kann es sein, dass das Plugin dafür noch nicht angepasst wurde?
-
Also was schon mal ganz leicht geht ist das Ausblenden einer Kategorie aus der Kategorienliste in der Sidebar. Dazu einfach den entsprechenden Aufruf in der sidebar.php um den exclude-Parameter erweitern, z.B. so (aus dem Kopf zitiert, ggf. noch mal die Syntax nachschlagen):
Nach exclude= kommt dabei die ID der auszuschließenden Kategorie. Die taucht dann in der Liste nicht mehr auf und kann an anderer Stelle manuell verlinkt werden. Damit obiges geht, musst Du allerdings die Sidebar per sidebar.php aufbauen und nicht über Widgets (da gibt es ggf. ähnliche Möglichkeiten, keine Ahnung).
Teil zwei wäre dann ja, auch beim Schreiben neuer Einträge diese Kategorie auszublenden -- außer für Administratoren. Dafür habe ich gerade die genaue Lösung nicht parat. Aber ich denke grob skizziert müsste das so gehen: Schreibe ein Mini-Plugin, das aus einer Funktion besteht, die eine Liste an Kategorien annimmt und wieder zurückgibt. Die Funktion prüft, ob der aktuelle Nutzer Admin ist, wenn nicht, filtert sie diese Kategorie aus der Liste heraus. Die Funktion wird dann mit dem passenden Hook für die Kategorien-Ausgabe versehen.
Hm,ich schaue hier gerade mal in die Liste der vorhandenen Filter. Der passende könnte der hier sein: "list_cats_exclusions" Das würde dann wahrscheinlich auch sowohl fürs Backend als für die eigentliche Seite funktionieren, glaube ich.
-
Ich würde als erstes mal das PHP-Errorlog kontrollieren. Wenn beim Aufruf der Seite ein Fehler auftritt, muss der ja eigentlich geloggt werden (vorausgesetzt der Server ist entsprechend eingerichtet). Mit dem Wortlaut der PHP-Fehlermeldung sollte sich dann doch eigentlich sagen lassen, was da passiert. Wenn z.B. aus irgendeinem Grund in der DB was Falsches steht, kannst Du das ggf. manuell korrigieren.
-
Also ich verstehe im Moment nicht so ganz, was Du daran als Kategorie abbilden willst. Sollen "2007", "lalala", "abc" und "123" alles Kategorien sein, hinter denen sich eine Reihe an Beiträgen verbirgt? Oder willst Du eher die Beiträge mit den Infos "Jahr", "Produkt", "Kunde" und "Titel" versehen und die Liste der Beiträge tabellarisch darstellen? Erklär doch einfach mal genauer, wie Du Dir das vorstellst.

-
Wenn Du schreibst "mit vielen Fehlern"... meinst Du dann die Darstellung oder die Inhalte an sich? Solange die Inhalte an sich alle da sind, kannst Du die aktuelle DB ja behalten. Darstellungs-Probleme kann man (hoffentlich) lösen. Das mit den Cookies ist interessant, das hab ich mehrfach gelesen in letzter Zeit...
http://forum.wordpress-deutschland.org/allgemeines/25…ie-problem.html
http://forum.wordpress-deutschland.org/installation/2…keine-cook.htmlEin Hinweis aus dem ersten Thread war z.B. in der Tabelle "WP_Options" die Werte "siteurl" und "home" anzupassen. Was mich zu der Frage bringt ob Du in dem eingespielten Dump sowohl URL als auch Server-Pfade an den neuen Standort angepasst hast?