- Wird das Bild als sog. "Beitragsbild" verwendet? In dem Fall gibt das Theme das Format vor.
- Link zu so einem Beitrag? Siehe auch Forenregeln, Punkt II.
Beiträge von b3317133
-
-
Ein manuelles Backup von Updraft kann schon mal etwas dauern, siehe dazu die Hinweise in Antwort #2.
-
Wozu der API-Key dient, steht in der Beschreibung des Plugins unter FAQ.
Man braucht einen API-Key nicht zwingend, dann fehlen einige Dinge, auch das steht im FAQ.
Evtl. nochmal die Beschreibung bzw. die FAQ Punkte durchgehen, dann klärt sich evtl. vieles.
-
Der Ordner [FONT=Courier New]wp-includes[/FONT] stand in Deiner Aufzählung bereits mit drin, nur [FONT=Courier New]wp-admin[/FONT] nicht.
Schade, dass jetzt alles nachträglich entfernt wurde, so können spätere Mitleser nicht wirklich daraus lernen.
-
Mind. auch noch den Ordner [FONT=Courier New]wp-admin[/FONT] wieder einspielen, der gehört zum WordPress Core.
Falls nötig, die genauere Ursache einer weissen Seite steht meist im Server Error Log, das kann man üblicherweise beim Hosting einsehen.
Evtl. hat auch das Hosting ein eigenes Backup aller Dateien und Datenbank von z.B. gestern und kann das komplett auf den Stand zurücksetzen, frage ggf. dort mal nach.
-
Jegliche Ausgaben eines Shortcodes schreibt man in eine Variable und gibt diese am Ende zurück, siehe auch Beispiele.
Alternativ verwendet man am Beginn des Shortcodes [FONT=Courier New]ob_start();[/FONT] und am Ende [FONT=Courier New]return ob_get_clean();[/FONT] ähnlich wie hier.
-
Beides in der Dantenbank.
-
Der Shortcode gibt Inhalte direkt per [FONT=Courier New]echo[/FONT] aus (falsch) statt nur am Ende des Shortcodes per [FONT=Courier New]return $ausgabe;[/FONT] o.ä., eine Rückgabe am Ende des Shortcodes fehlt bei Dir völlig. Siehe auch Beispiele.
Die leeren [FONT=Courier New]return;[/FONT] am Ende der Dateien sind überflüssig / falsch.
Ob sonstige inhaltliche Fehler vorliegen, musst Du selbst anhand Deiner PHP Error Logs ermitteln. Den Code sehe ich nicht weiter an.
-
- Das [FONT=Courier New]add_shortcode(...)[/FONT] gehört nur in das Plugin, sonst nirgendwohin.
- Wenn der Shortcode [FONT=Courier New][nmevents][/FONT] wie gezeigt in Elementor eingefügt wird, muss/darf er natürlich nicht zusätzlich anderen einzelnen PHP Dateien eingefügt und aufgerufen werden.
- Aus dem geposteten Codeteil des Plugins geht leider nicht hervor ob Dinge direkt ausgegeben werden oder am Ende per return zurück, so ist schwer Hilfe möglich.
- Das [FONT=Courier New]add_shortcode(...)[/FONT] gehört nur in das Plugin, sonst nirgendwohin.
-
Man kann an der fehlenden deutschen Übersetzung des Plugins mitarbeiten oder alternativ selbst eine Sprachdatei mit Poedit erstellen oder das Plugin Loco Translate verwenden.
-
- Poste den Shortcode Code [size=10](mit dem kleinen [+] Symbol im Forum Editor)[/SIZE], gibt er direkt Dinge aus oder alles per "return" am Ende?
- Wurde der Code zusätzlich auch in ein Seitentemplate eingebaut?
- Wie genau wird der Shortcode in Elementor eingefügt / aufgerufen, sieht man im Screenshot nicht.
- Poste den Shortcode Code [size=10](mit dem kleinen [+] Symbol im Forum Editor)[/SIZE], gibt er direkt Dinge aus oder alles per "return" am Ende?
-
- Deaktiviere alle Cache- und Optimierungsplugins
- Leere Deinen lokalen Browser Cache
- Link zur Seite? Siehe auch Forenregeln, Punkt II
Am Rande für Mitleser, wieder mal ein schönes "you get what you pay for" Beispiel.... Ich habe mir über Fiver eine Webseite erstellen lassen ... Der Mensch ist aber leider momentan nicht erreichbar und kann nicht helfen.
-
Das Problem ist über z.B. die Chrome DevTools mit Auswahl irgendwelcher iPhones o.ä. im "device toolbar" und einem simplen Reload direkt reproduzierbar.
Es tritt wie bereits oben beschrieben nicht nur in PHP/WordPress sondern auch bei einfachen HTML-Dateien [FONT=Courier New]/readme.html[/FONT] oder Textdateien [FONT=Courier New]/license.txt[/FONT] oder Bild-Dateien[FONT=Courier New] /wp-content/uploads/2020/11/AdobeStock_300203735_klein.jpg[/FONT] usw. auf.
Mit Syntax Fehlern oder [FONT=Courier New]wp_is_mobile()[/FONT] oder auch anderen Theme- oder Pluginproblemen hat das daher nichts zu tun, lt. der ebenfalls bereits geposteten [FONT=Courier New].htaccess[/FONT] Datei gibt es dort keine Regeln, die in Datei-Requests eingreifen würden.
-
Um eine HTML-Datei auf einem Server aufzurufen, braucht man keine Frösche oder sonstige Hilfsmittel, sondern einfach einen Webbrowser, in dem man am PC und am Tablet oder Mobiltelefon den o.g. Link eingibt, das ist eine bei WordPress mitgelieferte einfache HTML-Datei, und sich das Ergebnis ansieht.
Eine entsp. technisch versierte Person wird diese Zugänge benötigen, um div. Dinge nachvollziehen zu können, Logs einzusehen, Änderungen zu machen usw., frage Leute in Deinem näheren Umfeld ob sich jemand gut mit "Webseiten und solchen Sachen" auskennt, alternativ suche Kontakte über lokale WordPress Meetups (finden derzeit oft online statt) oder poste ein Gesuch in der Jobbörse hier im Forum, dann bekommst Du sicherlich einige Angebote für direkte Hilfe.
Der genannte Pluginorder ist untergeordnet innerhalb der WordPress Installation, nicht übergeordnet, daher ist diese .htaccess nicht relevant.
-
Von aussen schwer weiter eingrenzbar, auch einfache Bilder in den Uploads oder reine HTML-Dateien ergeben bei "mobilem" User-Agent einen Fehler 500, z.B.
Das solltest Du zusammen mit jemandem ansehen, der dann direkten Zugriff auf den Server und das Hosting hat. Evtl. gibt es z.B. noch .htaccess Dateien in einem übergeordneten Ordner oder sonstige Einflüsse... -
Was erscheint im Error Log, wenn jetzt der Server Fehler auf einem Tablet o.ä. erscheint? Der o.g. Eintrag bzgl. der Redirects ist schon 4 Tage alt...
Ansonsten deaktiviere der Reihe nach temporär alle sonstigen Plugins und falls das Problem weiterbesteht, versuche es temporär mit einem Standard Twenty XXX Theme, um das einzugrenzen.
Und steht etwas anderes als hier beschrieben in der [FONT=Courier New].htaccess[/FONT] Datei? Die Zeile mit [FONT=Courier New]Authorization[/FONT] ist ggf. nicht da, das ist aber kein Problem.
-
-
- Ist durch die Deaktivierung des Plugins (welches Plugin genau) das Problem behoben?
- Welche Weiterleitungen genau wurden wie eingerichtet? Screenshots? Dann kann man ggf. logische Fehler sehen.
- Warum werden diese Weiterleitungen benötigt? Der Website funktioniert auch ohne Weiterleitungen für Mobilgeräte, er ist "responsive"...
-
Spiele ein Backup der Datenbank und Dateien von vor allen genannten Änderungen ein, also von als die Seite noch problemlos lief, um alle Einflüsse durch irgendwelche Basteleien wieder zu entfernen.
Und dann aktualisiere nicht einfach "alles was möglich ist", sondern einzeln Stück für Stück, damit Du die Fehlerursache eingrenzen kannst.
-
- Was verstehst Du unter "mobil"?
- Wie/wo/womit genau rufst Du welche Seite genau auf wenn der Fehler gezeigt wird?
- Was steht dann im Server Error Log? Die Error Logs bei Strato stehen üblicherweise unter "Datenbanken & Webspace -> Statistik -> Logfiles (oben) -> Error-Logfile anzeigen (Button)". Exemplarisch hier ein Screenshot wie man da hinkommt.