Beiträge von b3317133

    Tipps am Rande:

    In einem Widget Container wurde der komplette HTML Code einer offenbar anderweitig generierten Navigationsseite mit [FONT=Courier New]topnav[/FONT] usw. eingefügt, das hat dort nichts verloren und sollte ersatzlos raus.

    Die Seite wurde mit [FONT=Courier New]http[/FONT] im Feld WordPress URL eingerichtet, ein SSL-Zertifikat ist aber augenscheinlich vorhanden, man sollte sie noch sauber auf [FONT=Courier New]https[/FONT] umziehen, mehr dazu in der Suchfunktion WordPress Umzug o.ä.

    Welches genaue Theme? Welche Plugins? Welche WordPress Version? Link? Siehe auch Forenregeln, Punkt II.

    Sonst ist es ein ziemliches Ratespiel, ein Plugin Cherry Trending Posts wird vermutlich nicht verwendet, sonst hättet ihr das wohl schon selbst gefunden.

    Die Fehlermeldung in der Browser Konsole ist damit weg.

    Lösche das Plugin und teile der Quelle wo Du es geholt hast mit, dass es hoffnungslos veraltet ist und Fehler erzeugt.

    Ergänzung: Derzeit integriert die Startseite aus welchen Gründen auch immer im Hintergrund ein YouTube Video und enthält unsichtbare Testimonials, evtl. sollte man diese Elemente noch wirklich rausnehmen, statt sie einfach nur in allen Responsive Einstellungen per CSS zu verstecken.

    Du nutzt Elementor Pro, verwende das mitgelieferte Nav Menu Widget, mehr dazu hier oder beim Elementor Pro Support, den Du mitgekauft hast.

    Das genutzte Elementor Hello Theme sollte bereits selbst die WordPress Menüs nutzen, siehe auch Theme Dokumentation Header.

    Wird das o.g. veraltete Plugin derzeit überhaupt aktiv verwendet? Woher kommt es? Oder ist es ggf. nur im Hintergrund ungenutzt aktiv und erzeugt die Fehlermeldung in der Browser Konsole? Deaktiviere es einfach mal, funktioniert dann Dein Menü noch?

    Code
    Uncaught TypeError: this.el is null in _init /wp-content/plugins/navmenu-addon-for-elementor/assets/js/frontend.min.js?ver=1.1.6:408

    Einstellungen > Lesen > Startseite zeigt > statische Seite > bei Startseite die Home Seite auswählen > Änderungen übernehmen.

    Ergänzung: Das derzeit genutzte Plugin NavMenu Addon For Elementor bekam sein letztes Update Ende 2018 und wurde im August 2020 komplett aufgegeben, es ist nicht kompatibel zur verwendeten WordPress Version 5.8.1 und erzeugt jQuery Scriptfehler, sowas sollte man nicht verwenden.

    "Lasse das Feld frei" = setze keinen Haken = guid wird nicht durchsucht = überspringen
    1339 Ergebnisse

    "angehakt" = auch guid wird durchsucht = nicht überspringen
    3000 Ergebnisse

    Alles bestens, mehr Felder in der Datenbank werden durchsucht, mehr Ergebnisse.

    Die Zahlen sind plausibel, offenbar wurde diese Installation bis auf die reine Anpassung der URLs in Einstellungen > Allgemein überhaupt nicht umgezogen.

    Wende Dich am besten an die Person, die diese Liveschaltung vorgenommen hat und lasse das entspr. nacharbeiten bevor Du selbst daran herumbastelst, diese Liveschaltung war mangelhaft.

    Der oben verlinkte Beitrag mit Post-ID 678 und auf aktuell gestelltem Datum wird weiterhin am Ende der Blogübersicht auf der Startseite (derzeit auf Seite 3) gezeigt:

    Code
    https://bahr-kardiologie.de/bewegungen-mit-verblueffender-sofortwirkung/
    https://bahr-kardiologie.de/wp-json/wp/v2/posts/678


    Am Beginn der Blogübersicht wird jetzt eine neue erstellte Kopie dieses Beitrags mit der neuen Post-ID 1364 und neuem "slug" gezeigt:

    Code
    https://bahr-kardiologie.de/bewegungen-mit-verblueffender-sofortwirkung-wunderuebungen-fuer-jeden-tag/
    https://bahr-kardiologie.de/wp-json/wp/v2/posts/1364


    Das eigentliche Problem ist damit also nicht gelöst.

    Das Datum des Beitrags ist lt. REST-API aktuell, theoretisch müsste der Beitrag in einer WordPress Standardinstallation damit in der Blogübersicht und auch im RSS Feed oben gezeigt werden, was hier aber augenscheinlich nicht der Fall ist.

    Möglicherweise sind auf diesem Website andere Einflüsse für die Beitragsreihenfolge vorhanden, z.B. anhand eingestellter Kategorien oder Schlagworte oder Post-ID o.ä.

    Weiter eingrenzen kann man sowas über temporäres Deaktivieren aller Plugins bzw. Umstellen auf ein Twenty XXX WordPress Standard Theme

    @Putzlowitsch Erzeugt Dein Plugin in etwa einen solchen .htaccess Eintrag?

    Apache Configuration
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^meinecloud/ - [F,L]
    </IfModule>


    Falls nein, könntest Du diesen Eintrag noch testweise ganz an den Beginn Deiner .htaccess setzen (also ausserhalb/oberhalb des existierenden [FONT=Courier New]# BEGIN WordPress[/FONT] Blocks) und mit den o.g. genannten beiden URL Aufrufen testen?

    Code
    wp-beispiel.de/meinecloud/status.php
    wp-beispiel.de/meinecloud/owncloud/status.php


    Anmerkung zum .htaccess Eintrag: Das [FONT=Courier New]F[/FONT] erzeugt 403 Forbidden, will man 404 Not Found erzeugen, ersetzt man das [FONT=Courier New]F[/FONT] durch [FONT=Courier New]R=404[/FONT]

    Möglichkeiten:

    • Blauen Herunterladen Button in der Plugin Beschreibung anklicken, .zip Datei entpacken, Code lesen.
    • Code online lesen, z.B. hier.
    • Anfrage im Plugin Support Forum mit Bitte um vollständige Auflistung und Beschreibung der Parameter und Argumente.


    Bei Code lesen ist zu beachten, dass man die exakte Verwendung und Auswertung der Parameter auch an anderen Stellen im Code nachvollziehen sollte, die ist in diesem Plugin auch nicht überall wie eigentlich erwartet, z.B. was hier und da "true" als Parameter angeht.

    Das "Widget" als solches wirst Du nicht an diese Stelle bekommen, da dort kein "Sidebar" vorhanden ist. Beliebige klassische "Widgets" als "Blöcke" zu verwenden, funktioniert im Gutenberg Projekt aktuell leider nicht, auch wenn die Darstellung im Backend ähnlich erscheinen mag.

    Daher erstelle eine Shortcode Block und gib dort diese Zeile ein:

    Code
    [rpwe post_type="page" styles_default="false"]


    Ergänze dann weitere Parameter im Shortcode für Dein gewünschtes Aussehen.

    Aber: Wie bereits ausgeführt, ist die aktuelle Version des Plugins fehlerhaft implementiert, daher geht das derzeit nur mit der Angabe [FONT=Courier New]styles_default="false"[/FONT] und ohne eigenen [FONT=Courier New]css="..."[/FONT] Parameter. Der Autor des Plugins sieht sich das nach kurzem Kontakt bzgl. dieser Sache gerade an.

    Interessant wäre jetzt, ob in der Datenbank der Inhalt dieses "Ort Text (neu)" Blocks (noch) vorhanden ist.

    Falls ja (und auch als genereller Ansatz für eine solche Problemsuche) deaktiviere alle sonstigen Plugins (bis auf das offenbar zum Theme gehörige Cryout Serious Theme Settings), und falls dann (nach dem Leeren des Browser Caches und dem Löschen aller Cookies usw.) die Blockinhalte im Backend bzw. JSON Export wieder sichtbar werden sollten, reaktiviere die Plugins einzeln der Reihe nach, um so Einflüsse einzugrenzen. Bauchgefühl hier: Yoast SEO wäre auch so ein Kandidat, der schon viele Probleme mit Gutenberg hatte.

    Die PHP Version kann insofern durchaus Einfluss haben, dass neuere WordPress oder Plugin Versionen damit fehlerhaft arbeiten und beim Speichern/Lesen dann mittendrin ein PHP Fehler auftritt,der zum leeren Inhalt führt.

    Ergänzung: Generell sollte eine solche Installation mit uralter PHP-Version, uraltem nicht weiter entwickeltem Theme aber neuster dazu nicht passender WordPress Version so nicht betrieben werden. Sowas wird immer früher oder später irgendwo knirschen und knacken, ganz unabhängig vom aktuellen Problem.