Beiträge von b3317133

    In beiden oben angegebenen Codezeilen werden [FONT=Courier New]%Platzhalter%[/FONT] ersetzt und im Falle eines Arrays wird aus dem Ersatzwert ein kommaseparierter String erstellt.

    Code
    1367: $message = str_replace('<'.'%'.$item.'%'.'>',(is_array($value)?(implode(", ",$value)):($value)),$message);
    1368: $message = str_replace('%'.$item.'%',(is_array($value)?(implode(", ",$value)):($value)),$message);


    Evtl. enthalten die Ersatzwerte bei Dir verschachtelte Arrays o.ä.

    Probiere es in einer frischen, leeren WordPress Installation ohne sonstige Plugins aus. Wenn es dann immer noch auftritt, wäre der Plugin Support der beste Ansprechpartner.

    ... truely Managed WordPress Hosting ...


    Viele "Managed WordPress Tarife" versprechen Dinge wie "technische und serverseitige Verwaltung"," Pflege und Sicherheit", "Betrieb und Wartung", "Kostenloser Support "und ähnliches.

    Für einfache Endkunden klingt es oft so, als müssten sie sich bei "Managed" Angeboten um nichts mehr technisches kümmern.

    Nicht selten stellt sich sowas jedoch im Fall der Fälle als reines "Marketing Ding" heraus.

    Daher sollte man sich explizit zusichern bzw. in den jeweiligen AGBs zeigen lassen, was im Detail z.B. unter "Sicherheit" oder "Wartung" usw. verstanden wird. Dabei nicht vergessen, wer wann wie genau z.B. nach einem Hack oder für ggf. nötig werdende Codeanpassungen von Plugins oder Themes oder beim Wechsel von PHP-Versionen zuständig ist. Oft muss man sich hier nämlich dann doch wieder selbst kümmern.

    Normale automatische Updates ohne weitere Eingriffe kann WordPress selbst alleine von Haus aus.

    Es sind weiterhin HTML-Fehler vorhanden, die sollte man erst beheben.

    Ergänzung: Danach noch den Abstand der Checkbox nach unten wegnehmen, im o.g. bereits genutzten Block:

    Code
    .wpcf7 .wpcf7-acceptance input {
       width: auto;
       margin-bottom: 0;
    }


    Und etwas Abstand zum Button:

    Code
    .wpcf7 .wpcf7-submit {
       margin-top: 1.5em;
    }

    Da wurdest Du schlecht bzw. falsch beraten.

    Der viele Platz jetzt kommt von diesem bei Dir manuell eingegebenem CSS in Design > Customizer > Zusätzliches CSS:

    Code
    .wpcf7 input {
       width: 75%;
       margin-left: 150px;
    }


    Schreibe zusätzlich dazu am Ende darunter dieses CSS, das entfernt den meisten Platz.

    Code
    .wpcf7 .wpcf7-acceptance input {
         width: auto;
    }


    Soll auch der Rand ganz links entfernt werden, nutze diese Alternative:

    Code
    .wpcf7 .wpcf7-acceptance input {
         width: auto;
         margin-left: 0;
    }

    Behebe erstmal die HTML-Fehler:

    [acceptance acceptance-166][COLOR=#ff0000]<div class half="datenschutz">[/COLOR]<strong>Datenschutz:</strong> Ich stimme zu, dass meine Angaben aus dem Kontaktformular zur Beantwortung meiner Anfrage erhoben und verarbeitet werden. Die Daten werden für 10 Jahre gespeichert oder auf Wunsch gelöscht. [/acceptance][COLOR=#ff0000]</div>[/COLOR]
    <div><strong>Hinweis:</strong> Sie können Ihre Einwilligung jederzeit für die Zukunft per E-Mail an info@ho[...]ing.de widerrufen. Detaillierte Informationen zum Umgang mit Nutzerdaten finden Sie in unserer <a href="https://fin[...]tenschutz/"><strong>Datenschutzerklärung</strong></a>.
    [COLOR=#ff0000]</p>[/COLOR]</div>

    Ich möchte daher um Eure Tipps bitten, was ich sonst noch alles probieren könnte um das Problem zu beheben!

    Mich würde es auch interessieren, wie ich dahinter komme, welche Plugins am meisten Memory verbrauchen? Gibt es dafür eine Möglichkeit darauf zuzugreifen?


    Du kannst z.B. eines der Plugins verwenden, die den aktuellen Speicherverbrauch anzeigen, dann einzelne andere Plugins temporär deaktivieren und die Auswirkungen sehen.

    Die eine Fehlermeldung zeigt das Plugin Jetpack, je nach Einstellung kann es viele Ressourcen beanspruchen. Würde das Plugin auch aus DSGVO Gründen generell nicht verwenden.

    In der Browser Konsole erscheint derzeit ein JavaScript Fehler "Uncaught SyntaxError: missing ) after argument list", das deutet darauf hin, dass irgendwas generell nicht korrekt eingerichtet ist bzw. das Cache-/Minify-Plugin ggf. nicht korrekt arbeitet.

    Dieser Scriptfehler führt derzeit dazu, dass die Cookie Zustimmung Abfrage nicht angezeigt wird.

    Generell wird aber eine ggf. getätigte Einstellung bei der Cookie Zustimmung sowieso nicht beachtet, der Website lädt derzeit auch ohne Zustimmung alles mögliche wie Google Analytics und andere Statistiken. Das Cookie Plugin ist also ggf. falsch eingerichtet.

    Dein Problem kann aber auch generell nur alleine durch aufgelaufene Datenmengen in der Datenbank verursacht werden, falls ggf. zwischenzeitlich allgemein zu viel Statistikkram oder Metadaten aufgelaufen sind und WordPress dadurch bei jedem Request generell mehr Speicher als früher braucht.

    Zusammengefasst: Üblicherweise geht man erst der Ursache eines auftretenden Fehlers auf den Grund und sucht dann nach passenden Lösungen.

    Auf dem Website läuft Enfold 4.4.1 vom Juni 2018. Nutze es zusammen mit einer PHP Version und einer WordPress Version aus dieser Zeit oder kümmere Dich um ein Update von Enfold, eigentlich sind die Updates dort inklusive.

    Ergänzung: Mehr zum Verfahren der Updates ab 4.4.1 hier auf dem Enfold Website, dafür wird der Envato/Themeforest Account des Kaufs benötigt.

    Es handelt sich um ein Kauf Theme. Evtl. ist keine Lizenz (mehr) für Updates vorhanden. Eine aktuelle Version sollte lt. Changelog PHP 8 unterstützen. Der Enfold Support hilft in der Regel zeitnah weiter.

    Wenn Backp Plugins abbrechen, kann man ermitteln, welche Ordner/Unterordner meist in wp-content/uploads/ sehr grosse Datenmengen enthalten, diese Ordner im Backup Plugin dann extra nicht mit ins Backup aufnehmen und im Nachgang diese Ordner manuell per FTP umkopieren.

    Es ist ein .htaccess / .htpasswd Schutz für den wp-admin Ordner eingerichtet. Lass Dir Benutzer/Kennwort davon geben. Beim Kunden ist das möglicherweise im Browser gespeichert oder es ist ein IP-Bypass o.ä. für ihn eingerichtet. Alternativ entferne den Schutz per FTP oder wende Dich an die Person, die den Website technisch betreut und lasse den Schutz entfernen.

    Ein solcher Schutz wird hier und da zur Erhöhung der Sicherheit empfohlen, hat aber unter Umständen je nach Website auch Einfluss auf die Funktionalität von WordPress.