Der einzig sinnvolle Tipp ist die Antwort #2 oben von @Marcus[IS]
Beiträge von b3317133
-
-
Anhand dieser Beschreibung ging der Hersteller Support hier weit über den beim Verkauf angebotenen Support hinaus, Respekt dafür.
Um weniger Bilder zu generieren, kannst Du auch ein Child Theme erstellen, darüber die Grössen des Themes entspr. mit z.B. [FONT=Courier New]remove_image_size()[/FONT] beeinflussen und dann im gesamten Theme überall alle Vorkommen der entfernten Bildgrössen über das Child Theme ersetzen. Das ist meist nicht ganz trivial, da der Theme Hersteller die Bildgrössen aus bestimmten Gründen genau so eingerichtet hat und diese dann von WordPress bzw. vom Browser automatisch passend verwendet werden, z.B. auch für hochauflösende Gerätedisplays usw. Auf ein paar MB mehr oder weniger auf dem Server kommt es heutzutage nicht an.
Wenn man ein Plugin für etwas benötigt, dann verwendet man dafür ein passendes Plugin. Es ist nicht zielführend, krampfhaft irgendwelche Pluginzahlen im Auge zu haben.
Sehe ähnliche Probleme auch bei anderen Themes kommen, die Du auswählen wirst, vielleicht die Erwartungshaltung überdenken oder jemanden beauftragen, der für ein gewähltes Theme ein Child Theme entspr. extakt nach einer klar definierten Liste von Anpassungen erstellt, aber das kann je nach Ansprüchen auch relativ aufwändig = teuer werden.
Danke auf jeden Fall für die Aufklärung und viel Erfolg mit dem Website.
-
Bei den ersten beiden Support-Fragen wurden dann entweder Plugins zur Lösung relativ kleiner Probleme empfohlen oder eine kostenpflichtige Code-Anpassung. Deshalb rücke ich gedanklich gerade von diesem Theme ab
Was konkret waren denn diese "relativ kleine Probleme"? Haben die Plugins nicht funktioniert? Warum sollten Code-Anpassungen kostenlos geliefert werden? Evtl. gibt es ein grundsätzliches Missverständnis, was bzgl. Support mitgekauft wurde bzw. was nicht. Sowas könnte bei anderen Themes wieder passieren, daher sollte man das erstmal klären. -
Der Website wurde gehackt. Alles auf dem Server inkl. Datenbank ist als kompromitiert zu betrachten.
Das nachträgliche Entfernen einzelner Schadcodes oder Auswirkungen ist nicht ausreichend.
Das allgemeine Vorgehen bei einem Hack ist z.B. hier beschrieben, das könntest Du mit jemandem mit WordPress Erfahrung bei Dir im näheren Umfeld zusammen durchgehen. Jeden einzelnen Punkt.
Erste Massnahmen: Backup aller aktuellen Dateien und Datenbank für spätere Analyse, Offlineschalten des Websites z.B. über ein .htpasswd oder einen generellen Error 503 über .htaccess für alle Zugriffe für Vermeidung der akuten Verbreitung von Schadcode.
Ergänzender Tipp am Rande: Auf dem Screenshot ist u.a. die Verwendung eines uralten Plugins "Lightbox Plus Colorbox" zu sehen, das vor über 7 Jahren aufgegeben wurde, sowas sollte man im Livebetrieb keinesfalls nutzen. Evtl. gibt es noch weitere ähnlich alte andere Komponenten, was bei der Suche nach der Ursache des Hacks hilfreich sein könnte.
-
2. Klicke 1x Einstellungen > Permalinks > keine Änderung > Speichern Button unten
Dieser Punkt hat/hätte die .htaccess Datei neu erzeugt.Jetzt solltest Du Dich noch um das lokale Hosten der aktuell extern eingebundenen Google Webfonts kümmern, und das Google Tag Manager Tracking entfernen bzw. erst nach Zustimmung der Besucher zulassen.
Und einige Grafiklinks zeigen offenbar noch auf die Entwicklungsdomain, das sollte der Fiverr noch zuende umstellen.
-
Ohne das Cache-Plugin mit den veralteten Inhalten scheint es jetzt zumindest von hier aus gut zu funktionieren.
-
Es gibt dort auch aussagekräftige Bilder zum Anschauen und Schlussfolgerungen ziehen.
Wer einen Website betreuen will, wird an vielen Stellen mit englischer Terminologie konfrontiert werden. Meist erst recht dann, wenn es kritisch wird oder Notfälle passieren. Damit sollte man also klar kommen, z.B. Ansatz externe "Übersetzungshilfe", oder jemanden anders mit wenigstens grundsätzlichen Sprachkenntnissen in die Betreuung mit einbeziehen.
-
Ab besten liest man dazu die offizielle Contact Form 7 Dokumentation:
-
Hast Du Dir schon die umfangreiche Theme Reykjavik Dokumentation angesehen?
-
Nutze ein Twenty Seventeen Child Theme und überlagere damit die Datei [FONT=Courier New]template-parts/footer/site-info.php[/FONT] mit angepasstem HTML Code mit den Links dort oder mit einem eigenen [FONT=Courier New]wp_nav_menu()[/FONT] für diese Punkte.
-
Der Fehler ist geblieben.
Aktuelles Zitat aus dem Error-Log?Den Codeblock mit der o.g. von Dir zitierten Zeile 117 gibt es nach Deiner Beschreibung jetzt nicht mehr. Was ist der aktuelle Fehler?
Die Ursache der Probleme dürfte wie beschrieben die Umstellung der PHP Version des Servers sein, ohne alles auf Kompatibilität zu prüfen. Die o.g. Zeile mit [FONT=Courier New]create_function[/FONT] erzeugte mit PHP8 einen Fatal Error, evtl. gibt es noch weitere Komponenten des Websites, die nicht PHP8 kompatibel sind.
-
Für Mitleser: Meist liegt sowas an einem Cache-Plugin oder einem nicht geleerten Browser Cache.
Extra dauerhaft laufende Plugins sind bei sauberer https/SSL Einrichtung bzw. Umstellung von WordPress nicht nötig.
-
Solche Ergänzugen werden auch gern von mehr oder meist weniger kompetenten "Managed WordPress" Dienstleistern eingefügt.

In diesem Fall führt das mit PHP8 zu einem PHP Fatal Error, wenn Adminbereich aufgerufen wird.
Vermutlich wurde hier die PHP Version des Servers umgestellt, ohne alles auf Kompatibilität zu prüfen.
Entferne diesen ganze "Override" Codeblock bzw. falls Dir nicht absolut klar ist, was Du da tust, wende Dich an die Person, die den Website technisch eingerichtet hat bzw. betreut.
Stelle auch sicher, dass Du immer Backups vor allen Änderungen hast. Alles einfach auf automatisch zu schalten, ohne Kontrolle und Rollbackmöglichkeiten zu haben, ist keine Lösung und auch keine "Website Betreuung".
-
- Deaktiviere Cache-Plugins
- Klicke 1x Einstellungen > Permalinks > keine Änderung > Speichern Button unten
- Leere Browser Cache
-
z.B. das:
... und weiteres Debugging ...
Suche Dir am besten eine Person in Deinem näheren Umfeld mit entspr. technischem Sachverstand und gehe das Problem zusammen mit dieser Person an Deinem PC durch. Das dürfte in diesem Fall die zielführendste Lösung sein. -
.. und es taucht nicht bei allen auf, dafür aber bei dieser Seite
Die dort verwendete MediaWiki Version 1.34 aus 2019 ist nicht PHP8 kompatibel.Für das di-basis Theme wende Dich an den Theme-Support und frage nach einem PHP8 kompatiblen Update.
-
Ich habe als Beitragsseite "Kräuterseite" eingegeben
- Verwende nicht die gleiche Seite als Homepage und Beitragsseite, siehe auch die klar angegebene Warnung auf Deinem Screenshot: Diese Seiten sollte nicht gleich sein
- Auf der Beitragsseite werden automatisch Deine Beiträge gezeigt, siehe auch im Menü Beiträge von WordPress
-
Dein Hoster hat recht.
Diese Meldung ist in vielen Fällen nicht relevant, führt derzeit aber leider zu diversen Installations- und Konfigurationsversuchen von unbedarften Benutzern, die dadurch ihre Websites verschlimmbessern oder unbemerkt mit Fehlern versehen, weil irgendwelche Dinge bei ihnen gar nicht Cache kompatibel sind usw.
-
Hoster hat sich zurück gemeldet:
... beim Aufruf Ihrer Website ansehen, erkennen Sie direkt Fehler:- Uncaught TypeError: e.dispatchEvent is not a function
Der in Antwort #11 genannte Fehler tritt weiterhin auf. Hier sollte man bei der weiteren Problemsuche ansetzen.Von aussen kaum machbar, Deaktivieren von Plugins, ggf. Umschalten Theme und weiteres Debugging werden nötig sein.
-