Beiträge von marX

    Ja, na immerhin steht was da. Steht das immer so da, beim Aufruf der Kategorie und beim Aufruf des einzelnen Artikels? Und die "1" ist auch jeweils die richtige Kategorie-ID (kann ich ja von hier nur raten ;-))? Und die "1" hat auch Unterkategorien die angezeigt werden können?

    Kannst du vielleicht mal nen Link zur Seite anbieten, wo man sich das live anschauen kann?

    Ich hatte oben die schließenden Anführungszeichen beim ID-Attribut vergessen. :oops: Trag das mal nach, vielleicht ist das schon der ganze Fehler.

    Nebeneinander dürfte auch möglich sein, aber eins nach dem anderen. ;)

    hmm.. wie genau meinst du das mit dem sidebar-loop?
    soll ich den code da einfach einfügen und was dann?

    PHP
    <?php if ( is_category() || is_single() ) : ?>
    [CODE][COLOR="Red"]<!--
    Kategorie-ID: <?php var_dump($categoryvariable); ?>
    Query: <?php var_dump($query); ?>
    -->[/COLOR][/CODE]
    <ul>
      <?php while ($postsInCat->have_posts()) : $postsInCat->the_post(); ?>
      <li><a href="<?php the_permalink() ?>"><?php the_title(); ?></a></li>
      <?php endwhile;?>
    </ul>


    Wenn du das so einfügst, dann sollte (als HTML) die Kategorievariable und die Query angezeigt werden, die an der Stelle ausgeführt wird. Steht dort jeweils die korrekte ID drin oder nicht? Schau mal bitte nach (kannst du ja auch hier posten).


    Zitat

    der andere tipp von dir, dass er - falls vorhanden - unterkategorien zeigen soll, geht auch nicht...
    also da zeigt er mir garnichts an..


    Könnte diesselbe Ursache haben, schau bitte erstmal nach der Kategorievariablen.


    Zitat

    p.s.: kannst die ruhig zusammenführen


    *done* :)

    1) gebe ich bei den folgenden Zeilen die Daten ein, die auch in der wp-config.php meines ersten Blogs stehen.

    2) gebe ich anstelle von 'wp_' z.B. 'wp2_' in der folgenden Zeile ein
    [code=php]$table_prefix = 'wp_'; // Nur Zahlen, Buchstaben und Unterstriche bitte!


    Ja. Und die wp-config-sample.php benennst du anschließend in wp-config.php um - wie in der Installationsanleitung beschrieben.


    Zitat

    Ist das alles, oder muß ich noch etwas beachten?


    Ja das ist alles.

    Zitat

    Ich möchte, daß der Blog ersteinmal noch nirgendwo sichtbar ist, bevor ich ihn auf meiner Homepage verlinke. Was muß ich beachten?


    In den Privatsphäre-Einstellungen schaltest du Suchmaschinenzugriffe ab. Gleichzeitig werden Pings verhindert, die andere Seiten auf dein Blog aufmerksam machen würden.

    Im wp.org-Supportforum gibts mehrere Threads dazu:
    WordPress › Support Tags — wp_remote_post
    WordPress › Support Tags — wp_remote_request

    Könnte demnach mit inkompatiblen Plugins zusammenhängen. Du hast doch hoffentlich vor dem Upgrade zumindest mal die üblichen Verdächtigen gecheckt und auch alle Plugins deaktiviert?

    Eventuell mal den gesamten Inhalt des Plugin-Verzeichnisses löschen (lokal sichern!). Falls dann das Blog erstmal wieder läuft kannst du ja die Plugins einzeln wieder hochladen und aktivieren.

    die hälfte des problems ist schon sozusagen gelöst
    -> http://forum.wordpress-deutschland.org/konfiguration/…dann-posts.html


    [SIZE="1"](Ich führe die Threads nachher mal zusammen, ja?)[/SIZE]

    Zitat

    folgendes problem...
    ...und zwar ist da irgendwie noch son fehler im ganzen code.. weil wenn ich eine kategorie anklick, erscheinen dazu perfekt die dazugehörigen posts.. wenn ich dann jedoch auf einen artikel klick, erscheinen in der artikelliste alle artikel, also nicht die, die da aus der ausgewählten kat..


    Mmh, rein logisch sollte das passen. Lass dir doch bitte mal die Variable mal vor dem Sidebar-Loop ausgeben. Steht da die korrekte ID drin?

    PHP
    var_dump($categoryvariable);
    Zitat

    dass er unter der kategorie, die da erscheint, wenn man draufklickt, in einem weiteren "widget" - falls vorhanden - eine unterkategorie erscheint...


    Also in einem Kategoriearchiv soll zusätzlich ein Sidebar-Element ("Widgets" im WP-Sinn sind das ja eigentlich nicht, was du da hast...) mit den Unterkategorien dieser Kategorie erscheinen, korrekt? Da nehmen wir mal ein Codex-Beispiel her:

    PHP
    <?php $childcats = wp_list_categories('title_li=&child_of=' . $categoryvariable . '&echo=0'); ?>
    <?php if ($children) : ?>
      <ul><?php echo $children; ?></ul>
    <?php endif; ?>


    (Das Beispiel steht so auf der Codex-Seite zu wp_list_pages() - für die Kategorien gehts aber analog. ;-))

    Okay, hochgeladen. Auch beides Themes jeweils aktiviert und deaktiviert. Keine Veränderungen. (Farben habe ich wieder geändert.)


    Nein, passieren kann da nichts. Nur deine Änderungen werden überschrieben.
    (Am besten wärs, wenn du "dein" Theme nochmal in ein anderes Verzeichnis kopierst, z.B. "mein_default". Dann wirds auch bei einem Komplettupgrade nicht überschrieben. Aber das hilft uns hier ja jetzt mal nicht weiter...)

    Zitat

    Wo finde ich die error.log-Datei? Im Ordner errordoc liegen nur vier HTML-Dateien von 2007, im Ordner logs liegt keine Datei error.log


    Verzeichnis /logs ist richtig. Schade. Dann gibts entweder keine Fehler (unwahrscheinlich), oder dein Hoster stellt dir kein error.log bereit. Frag vielleicht mal bei dem an, vielleicht hast du auch was übersehen.

    Zitat

    Habe als Versuch jetzt mal unter "Lesen" eine statische Startseite eingestellt und eine der Pages dafür ausgewählt. Die erscheint dann dort auch fehlerfrei.


    Aha. Gut.

    Zitat

    Beim Zurücksetzen auf "Latest 10 posts" erscheint wieder die Suche dort.


    Mmmh. Nochmal die Frage: eine home.php hast du nicht im Theme? (Obwohl, Theme-Wechsel hat ja auch nicht geholfen...) Und auch keine Plugins? (Mmh, sagtest du ja bereits... :?)

    Das gleiche Problem bleibt. Auch nach Tauschen und jeweils Speichern der Themes. In der Vorschau sehe ich die Seite immer noch so, wie sie eigentlich aussehen sollte.


    Überspiel doch nochmal die Themes mit den jeweils aktuellsten Versionen (aus dem Downloadpaket).

    Zitat

    Und: Da steht zwar, dass das eine deutschsprachige Version sei, aber sowohl auf der Oberfläche als auch in der Admin ist weiterhin alles auf Englisch.


    Ist die Sprachdatei mitgekommen? Die liegt in "wp-content/languages". Vielleicht hast du die vergessen.

    Zitat

    Hm, ich vermute, jetzt sind wir beide ratlos...
    Vielleicht fällt dir trotzdem noch was ein? Viele Grüße.


    Ziemlich... sagt das error.log des Servers vielleicht irgendwas was uns weiterhilft?