Alles anzeigenDie Fehlermeldung "The file can not be opened in write mode" bedeutet, dass WordPress keine Schreibrechte für die Datei oder den Ordner hat, in dem die Datei gespeichert ist. Das kann verschiedene Ursachen haben, wie z.B. falsche Ordnerberechtigungen, eine volle Speicherplatzbegrenzung oder ein fehlerhafter temporärer Ordner.
Um den Fehler zu beheben, kannst du folgende Schritte ausprobieren:
- Überprüfe die Ordnerberechtigungen für den Ordner wp-content/cache/matomo/assets und stelle sicher, dass sie auf 755 gesetzt sind. Das bedeutet, dass der Besitzer des Ordners lesen, schreiben und ausführen kann, während andere nur lesen und ausführen können. Du kannst die Ordnerberechtigungen mit einem FTP-Programm wie Filezilla.
- Überprüfe, ob du die Speicherplatzbegrenzung deines Hosting-Service überschritten hast. Wenn ja, musst du entweder einige Dateien löschen oder deinen Speicherplatz erweitern.
- Überprüfe, ob der temporäre Ordner von WordPress funktioniert. Der temporäre Ordner wird verwendet, um Dateien vorübergehend zu speichern, bevor sie in den endgültigen Ordner verschoben werden. Wenn der temporäre Ordner nicht existiert oder beschädigt ist, kann WordPress die Dateien nicht schreiben. Du kannst den temporären Ordner in der Datei wp-config.php ändern, indem du die Zeile
hinzufügst. Erstelle dann einen Ordner namens temp im Ordner wp-content.
Ich habe erstes und letztes wie beschrieben gemacht.
Doch leider ändert sich nichts.
Am Speicherplatz kann es nicht liegen, da genug Platz vorhanden ist.
Aber vielleicht hilft dies?
# Matomo
* Matomo-Plugin-Version: 5.0.3
* Config existiert und ist schreibbar.: Ja ("$abs_path/wp-content/uploads/matomo/config/config.ini.php" )
* JS Tracker existiert und ist schreibbar.: Ja ("$abs_path/wp-content/uploads/matomo/matomo.js" )
* Plugin-Verzeichnisse: Yes ([{"pluginsPathAbsolute":"$abs_path\/wp-content\/plugins\/matomo\/plugins","webrootDirRelativeToMatomo":"..\/plugins"}])
* Tmp-Verzeichnis schreibbar: Yes ($abs_path/wp-content/cache/matomo)
* Matomo-Version: 5.0.2
* Matomo Blog idSite: 1
* Installierte Matomo-Version: 5.0.3 (Install date: 2024-02-08 08:56:59)
* Upgrades outstanding: No
* Upgrade in progress: No
## Endpoints
* Matomo JavaScript Tracker URL: ($site_url/wp-content/uploads/matomo/matomo.js)
* Matomo JavaScript Tracker - WP Rest API: ($site_url/wp-json/matomo/v1/hit/)
* Matomo HTTP Tracking API: ($site_url/wp-content/plugins/matomo/app/matomo.php)
* Matomo HTTP Tracking API - WP Rest API: ($site_url/wp-json/matomo/v1/hit/)
## Crons
* Server-Zeit: 2024-02-08 16:56:24
* Blog-Zeit: 2024-02-08 17:56:24 (Die nachfolgenden Daten werden in der Blog-Zeitzone angezeigt)
* Sync users & sites: Next run: 2024-02-09 08:58:15 (15 Stunden 1 Minuten) ( Last started: 2024-02-08 08:58:15 (-8 Stunden 58 Minuten). Last ended: 2024-02-08 08:58:15 (-8 Stunden 58 Minuten). Interval: daily)
* Archive: Next run: 2024-02-08 17:57:03 (39 Sek.) ( Last started: 2024-02-08 17:01:38 (-54 Minuten 46s). Last ended: 2024-02-08 17:01:39 (-54 Minuten 45s). Interval: hourly)
* Update GeoIP DB: Next run: 2024-03-09 08:58:15 (29 Tage 15 Stunden) ( Last started: 2024-02-08 08:58:15 (-8 Stunden 58 Minuten). Last ended: 2024-02-08 08:58:17 (-8 Stunden 58 Minuten). Interval: matomo_monthly)
## Vorgeschriebene Prüfungen
* PHP-Version >= 7.2.5: ok
* PDO Erweiterung: ok
* PDO\MYSQL Erweiterung: ok
* MYSQLI Erweiterung: ok
* Weitere erforderliche Anforderungen: ok
* Erforderliche Funktionen: ok
* Benötigte PHP Konfiguration (php.ini): ok
* Verzeichnisse mit Schreibzugriff: ok
* Verzeichnisse mit Schreibzugriff auf Tag Manager: ok
## Optionale Prüfungen
* 64-bit PHP Binär: ok
* Tracker-Status: ok
* Speicherlimit: ok
* Zeitzone: ok
* Öffnen einer URL: ok
* GD > 2.x + FreeType (Grafiken): ok
* Andere Erweiterungen: ok
* Andere Funktionen: ok
* Dateisystem: ok
* Letzter erfolgreicher Abschluss der Archivierung: ok
* Datenbankfähigkeiten: ok
* Maximale Packetgröße: ok
* Standorterkennung: ok
* Update über HTTPS: ok
* Mobile Messaging SMS Provider: ok
* Supports Async Archiving: No
* Async Archiving Disabled in Setting: No
* Location provider ID: geoip2php
* Location provider available: Yes
* Location provider working: Yes
* Matomo URL: Yes ($site_url/wp-content/plugins/matomo/app/)
## Matomo Settings
* Track mode: disabled
* Track ecommerce: Yes
* Track codeposition: footer
* Track api endpoint: default
* Track js endpoint: default
* Version history: 5.0.3
* Core version: 5.0.2
* Last tracking settings update: 1707379072
* Last settings update: 1707379072
## Logs
* Keine:
# WordPress
* Home URL: $site_url
* Site URL: $site_url
* WordPress Version: 6.4.3
* Number of blogs: 1
* Multisite Enabled: No
* Network Enabled: No
* WP_DEBUG: No
* WP_DEBUG_DISPLAY: Yes
* WP_DEBUG_LOG: No
* DISABLE_WP_CRON: -
* FORCE_SSL_ADMIN: Yes
* WP_CACHE: No
* CONCATENATE_SCRIPTS: -
* COMPRESS_SCRIPTS: -
* COMPRESS_CSS: -
* ENFORCE_GZIP: -
* WP_LOCAL_DEV: -
* WP_CONTENT_URL: $site_url/wp-content
* WP_CONTENT_DIR: $abs_path/wp-content
* UPLOADS: -
* BLOGUPLOADDIR: -
* DIEONDBERROR: -
* WPLANG: -
* ALTERNATE_WP_CRON: -
* WP_CRON_LOCK_TIMEOUT: 60
* WP_DISABLE_FATAL_ERROR_HANDLER: -
* MATOMO_SUPPORT_ASYNC_ARCHIVING: -
* MATOMO_ENABLE_TAG_MANAGER: -
* MATOMO_SUPPRESS_DB_ERRORS: -
* MATOMO_ENABLE_AUTO_UPGRADE: -
* MATOMO_DEBUG: -
* MATOMO_SAFE_MODE: -
* MATOMO_GLOBAL_UPLOAD_DIR: -
* MATOMO_LOGIN_REDIRECT: -
* Permalink Structure: /%postname%/
* Possibly uses symlink: No
* Upload base url: $site_url/wp-content/uploads
* Upload base dir: $abs_path/wp-content/uploads
* Upload url: $site_url/wp-content/uploads/2024/02
* Custom upload_path:
* Custom upload_url_path:
* Compatible content directory: Yes
# WordPress Plugins
* Antispam Bee: 2.11.5
* Complianz | GDPR/CCPA Cookie Consent: 6.5.6
* Disable & Remove Google Fonts: 1.5.9
* Limit Login Attempts Reloaded: 2.26.2
* Maintenance: 4.08
* Matomo Analytics - Ethical Stats. Powerful Insights.: 5.0.3
* Solid Security Basic: 9.3.1 (Network enabled)
* UpdraftPlus - Backup/Restore: 1.23.16
* Vafpress Post Formats UI: 1.5
* WordPress Popular Posts: 6.4.0
* WP-PageNavi: 2.94.1
* WP Comment Policy Checkbox: 0.4.1
* Yoast SEO: 22.0
* Active Plugins: 13 (antispam-bee:2.11.5 better-wp-security:9.3.1 complianz-gdpr:6.5.6 disable-remove-google-fonts:1.5.9 limit-login-attempts-reloaded:2.26.2 maintenance:4.08 matomo:5.0.3 updraftplus:1.23.16 vafpress-post-formats-ui-develop:1.5 wordpress-popular-posts:6.4.0 wordpress-seo:22.0 wp-comment-policy-checkbox:0.4.1 wp-pagenavi:2.94.1)
* Theme: adoxa (adoxa-child)
# Server
* Server Info: Apache
* Apache AddHandler support: Supported
* PHP OS: Linux
* PHP Version: 8.2.13
* PHP SAPI: fpm-fcgi
* PHP Binary Name: /usr/sbin/php82-fpm
* PHP Maxmind DB extension: Not loaded
* PHP Error Reporting: 4437 After bootstrap: 4437
* PHP Found Binary: /usr/bin/php -q
* Timezone: UTC
* WP timezone: Europe/Berlin
* Locale: de_DE
* User Locale: de_DE
* Memory Limit: 256M (At least 128MB recommended. Depending on your traffic 256MB or more may be needed.)
* WP Memory Limit: 256M
* WP Max Memory Limit: 256M
* Timezone version: 0.system
* Time: 1707411384
* Max Execution Time: 30
* Max Post Size: 200M
* Max Upload Size: 209715200
* Max Input Vars: 10000
* Disabled PHP functions: No
* zlib.output_compression is off: Yes
* Curl Version: 7.81.0, OpenSSL/3.0.2
* Suhosin installed: No
# PHP cli
* PHP cli Version: 7.2.34-nmm8
* MySQLi support: ok
# Database
* MySQL Version: 10.6.16
* Mysqli Connect: Yes
* Force MySQL over Mysqli: No
* DB Prefix: 1u5gi_
* DB CHARSET: utf8
* DB COLLATE:
* SHOW ERRORS: No
* SUPPRESS ERRORS: No
* Uses Socket: No
* Uses IPv6: No
* Matomo tables found: 47
* DB tables exist: Yes
* Matomo users found: 1
* Matomo sites found: 1
* Erforderliche Berechtigungen: OK
# Browser
* Browser: (Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/120.0.0.0 Safari/537.36 OPR/106.0.0.0)
* Language: de-de,de,en-us,en
Alles anzeigen