Laufen dort irgendwelche Sicherheitsplugins?
Beiträge von b3317133
-
-
Man kann auch z.B. keine Cookies verwenden, keine externen Einbindungen verwenden, kein Kontaktformular anbieten. Das vereinfacht vieles.
-
Viele Cookie-Banner sind (wie oben beschrieben) falsch oder gar nicht eingerichtet.
Wogegen was verstösst, das kann am besten ein entspr. Anwalt beantworten.
-
Der Code wäre im [FONT=Courier New]header.php[/FONT] o.ä. des jeweils verwendeten Theme/Child-Theme/Code-Snippet-Plugin einzufügen.
Alternativ folgt man der WordPress Anleitung des Herstellers dieses Consent Managers.
Möglicherweise muss man dann noch verwendete Cookies und externe Einbindungen im Theme bzw. Plugins in WordPress an diesen Manager anpassen.
Tipp am Rande: Wenn der Code auf einen externen Server verweist, ist er wg. der IP-Adresse an Drittanbieter ohne Zustimmung nicht DSGVO konform.
-
Die aufgerufene Funktion gibt es ab PHP 8 nicht mehr. Deine WordPress Installation ist offenbar nicht PHP 8 kompatibel.
Ergänzung: Das (lt. Google Cache) verwendete Theme Patio ist von 2015, das könnte z.B. das Problem sein.
Oder aber die (lt. Google Cache) verwendete WordPress Version 4.8. Zu der passt auch direkt die gezeigte Zeilennummer in der Fehlermeldung [FONT=Courier New]wp-includes/compat.php on line 502[/FONT].Lösungsansatz: Temporär PHP 7.4.x nutzen, um die Installation auf eine PHP 8 kompatible WordPress Version zu aktualisieren, das wäre mind. WordPress 5.6.x für PHP 8.0. Alternativ die WordPress Systemdateien per FTP ersetzen.
-
Derzeit erscheint hier allgemein für die Seite und auch die Login Seite eine weisse Seite mit Fehler 500.
Der Server läuft derzeit (wie auch bei Deiner anderen Frage) mit PHP 8.1.19, das ist mit WordPress 5.7.x nicht wirklich kompatibel.
Mit dem SSL Problem hat dieser Fehler 500 vermutlich erstmal nichts zu tun.
Ergänzung: Mehr zur Ursache kann man ggf. im Error-Log nachlesen.
-
Was steht in Design > Sidebar Replacements in Deinem Screenshot?
Ergänzung: Und was steht in OceanWP > My Library?
-
Was steht in Footer 1, 2, 3, 4 in Deinem Screenshot?
-
-
Hier funktioniert die Seite, das Zertifikat ist jetzt für die korrekte Domain und 90 Tage gültig.
Nur das Plugin, das AGB/Datenschutz anzeigt, ist offenbar noch inaktiv o.ä., es erscheint ein Shortcode statt Inhalt.
-
- Das aktuell verwendete SSL-Zertifikat ist auf [FONT=Courier New]*.kasserver.com[/FONT] ausgestellt, nicht auf die genannte Domain.
-
Was kann ich tun?
Beispielsweise folgendes:- Repariere/Verlängere das SSL-Zertifikat beim Hosting Anbieter.
- Deaktiviere das Cache Plugin.
- Deaktiviere ggf. vorhandene Simple SSL/https o.ä. Plugins.
- Benenne die Datei [FONT=Courier New].htaccess[/FONT] um, so dass sie nicht beachtet wird.
- Leere den Browser Cache.
- Versuche dann den Login.
Die [FONT=Courier New].htaccess [/FONT]Datei kannst Du später via Einstellungen > Permalinks > Speichern (ohne Änderungen) von WordPress neu erstellen lassen. - Repariere/Verlängere das SSL-Zertifikat beim Hosting Anbieter.
-
Ich hatte nach Installation der Webseite das Securityplugin "WP Hide & Security Enhancer" genutzt, ... Ob es damit zusammenhängt?
Das kannst Du so herausfinden:- Entferne das Plugin Verzeichnis [FONT=Courier New]wp-content/plugins/wp-hide-security-enhancer[/FONT] oder benenne es um.
- Entferne den [FONT=Courier New]BEGIN/END WP Hide & Security Enhancer[/FONT] Block in der Datei [FONT=Courier New].htaccess[/FONT]
Ergänzung: Nach Änderungen jeweils den Browser Cache leeren. - Entferne das Plugin Verzeichnis [FONT=Courier New]wp-content/plugins/wp-hide-security-enhancer[/FONT] oder benenne es um.
-
Jetzt funktioniert es besser. Nur die Zahl scrollt noch etwas oben raus, ggf. ist das aber so gewollt.
Der bereits genannte Scriptfehler ist nach der Aktivierung der beiden Cache Plugins wieder vorhanden.
-
Der Scriptfehler ist nach dem Deaktivieren der Plugins nicht mehr vorhanden. Er wird also durch eines oder die Kombination aus beiden Plugins verursacht.
Das eigentliche Problem ist auch mit Firefox oder Google Chrome sichtbar, möglicherweise hat es mit Animationseffekten der jeweiligen dem Anker übergeordeneten Bereichen zu tun, dort werden diverse transitions und translateY CSS verwendet. Evtl. hilft das Dir oder auch anderen Helfern schon weiter.
-
Bei der Suche nach Darstellungsproblemen deaktiviere alle Cache-, Minify- und Optimierungsplugins - derzeit mindestens aktiv: Autoptimize, WP Fastest Cache.
Anmerkung am Rande: Die Funktionen dieser beiden Plugins überschneiden sich, je nach Konfiguration kann/wird das zu Fehlfunktionen führen.
Derzeit erzeugt die Seite einen Scriptfehler in der Browser Konsole:
Evtl. hängt es auch damit zusammen. -
-
- Wo/wie genau wird das Error Log eingesehen?
- Was erscheint im Error Log wenn jetzt und heute der Fehler 500 aktuell auftritt?
- Wurden in [FONT=Courier New]wp-config.php[/FONT] manuelle Einträge vorgenommen? Gibt es andere/zusätzliche Zeilen im Vergleich zu [FONT=Courier New]wp-config-sample.php[/FONT]? Falls ja, poste diese Einträge. Ausnahme: Datenbank Zugangsdaten DB_XXX und AUTH/KEY/SALT Zeilenblock.
- Welche genaue PHP Version ist im Hosting eingestellt und wird dann ohne den [FONT=Courier New].htaccess[/FONT] "Cheatcode" verwendet?
-
- Was steht (ausser diesem "Cheatcode") noch in [FONT=Courier New].htaccess[/FONT]? Was erscheint im Error Log wenn das Umbenennen einen weissen Bildschirm ergibt?
- Von wann genau ist diese PHP Deprecated get_currentuserinfo Meldung? Zeit/Datum wurde abgeschnitten. Welches Theme und welche Plugins waren zu exakt diesem Zeitpunkt aktiv?
- Welche genaue Theme Version? Wird ein Child Theme verwendet?
- Was steht (ausser diesem "Cheatcode") noch in [FONT=Courier New].htaccess[/FONT]? Was erscheint im Error Log wenn das Umbenennen einen weissen Bildschirm ergibt?
-
- Was steht (ausser diesem "Cheatcode") noch in [FONT=Courier New].htaccess[/FONT]?
- Was erscheint im Error-Log des Servers? Alternativ bei Aktivierung von [FONT=Courier New]WP_DEBUG[/FONT] im Browser?
Woran kann es wohl noch liegen, dass PHP 8 nicht läuft?
- An manuellen fehlerhaften Einträgen z.B. mit falschen Hochkommata in [FONT=Courier New]wp-config.php[/FONT]
- An nicht PHP 8 kompatibler WordPress Version (für PHP 8.0 mind. WP 5.6)
- An nicht PHP 8 kompatiblem Theme, welche Themes genau wurden gewechselt/getestet?