Der Endpunkt [FONT=Courier New]/real-queue/[/FONT] ist keine Standard Funktion der WordPress REST-API.
Welche Plugins sind jetzt aktiv?
Um schreiben oder kommentieren zu können, benötigen Sie ein Benutzerkonto.
Sie haben schon ein Benutzerkonto? Melden Sie sich hier an.
Jetzt anmeldenHier können Sie ein neues Benutzerkonto erstellen.
Neues Benutzerkonto erstellenDer Endpunkt [FONT=Courier New]/real-queue/[/FONT] ist keine Standard Funktion der WordPress REST-API.
Welche Plugins sind jetzt aktiv?
Eventuell ist das fast ein Jahr alte Theme nicht mit aktuell verwendeter WordPress Version und/oder anderen Komponenten des Websites kompatibel. Vor dem Einspielen von Updates sollte man immer die Kompatibilität prüfen.
Mögliches Vorgehen:
Ergänzung: Alle Seiten des Websites geben derzeit einen HTTP Status Internal Server Error 500 zurück, auch wenn sie Inhalt zeigen. Das Problem ist daher nicht (nur) der Slider.
Über den geposteten Admin Login haben helfende Hände den Plugin Code [COLOR=#ff0000]geändert[/COLOR] und [COLOR=#ff0000]ergänzt[/COLOR], damit der Website nicht mehr abstürzt, so wie auf der Juhu Seite und auch oben [COLOR=#ff0000]in rot[/COLOR] in diesem Thread erklärt. Weitere Fehler muss der Plugin Support beheben. Ab hier darf jemand anders weiter erklären, bin raus.
Und dann hast Du einen Admin Login gepostet und dann haben helfende Hände das Plugin so geändert, dass es nicht mehr den Website komplett mit den o.g. Meldungen crasht. Die o.g. [COLOR=#ff0000]weiteren Bugs[/COLOR] darf der Plugin Support lösen...
Die Plugins dort werden nicht von WordPress zur Verfügung gestellt, sondern von irgendwelchen Leuten, die diese dort hochladen.
In der bing_map_functions.php Zeile steht auch: [COLOR=#ff0000]// ergänzt, unklare Funktion/Nutzung[/COLOR]
Das Plugin wurde über Deinen o.g. Login von helfenden Händen auf Deinem Website in einen Zustand gebracht, so dass es nicht mehr direkt den Website crasht. Den Rest, damit das alles funktioniert was Du wie willst, in der Plugin Dokumentation nachlesen und die restlichen Fehler mit dem Plugin Support besprechen... viel Erfolg!
.. Befehl für die GEO2Map. Wie habt Ihr dies eingebunden?
Es zeigt aber nicht an, wo die Bilder entstanden sind.
Das Plugin bindet das ein, wenn es aktiv ist. Beschäftige Dich mit den Plugin Einstellungen. Zur Anzeige wo Bilder entstanden sind siehe auch den Hinweis unten über der Karte in rot:
[COLOR=#ff0000]Und weitere Bugs, die noch nicht behoben sind, damit die Bilder in der Karte gezeigt würden…[/COLOR]
Ohne Link kann man das Problem nicht wirklich nachvollziehen. Die gezeigte Menü Einstellung ist zudem nicht der standard Menü Editor von WordPress.
Die Codezeile steht in der Original Datei so wie unter [COLOR=#ff0000]alt:[/COLOR]
In der auf Deinem Website geänderten Datei steht deshalb der Text: [COLOR=#ff0000]neu (auf dem Website geändert):[/COLOR]
Mach als erstes ein Komplett Backup, z.B. mit Updraft Plus o.ä., das Du leicht zurückrollen kannst. Und dann viele Datenbank Backups vor/nach einzelnen Schritten, geht auch mit Updraft. Und beschäftige Dich genauer mit den Tiefen diesen ACF Templates. Viel Erfolg.
Es geht in dieser Phase nicht um echtes Codieren, sondern nach wie vor nur um das Herausfinden (über Weglassen), wo genauer das Problem liegt.
Evtl. kannst Du mit dem aktuellen Wissen bzgl. was wirklich gebraucht wird auch ein ACF Template oder auch mehrere je nach Fall parallel neu aufbauen oder das bestehende duplizieren und für Tests zusammenstreichen usw.
Von aussen ist es ansonsten schwer bzw. unmöglich, in so einem Fall wie hier zu sagen, das liegt an diesem ACF Feld oder an jenem.
Die grundlegende Herangehensweise wie man Langsamkeit auf die Spur kommt, sollte damit aber schonmal klarer geworden sein.
Diverse Ergänzungen.
Wenn alle sonstige eingreifende Plugins deaktiviert sind, kann man sich im Code anschauen wie/was Du mit ACF gemacht hast bzw. ob es daran liegen kann. Dazu testweise einfach mal die Hälfte der ACF Ausgaben (oder auch sonstiger Ausgaben) auf den Register Seiten im Code auskommentieren. Dann die anderen Hälfte. Und dann wieder deren Hälfte, wenn man eine Verbesserung ermittelt. Das ist ein Weg, wie man Zeitfresser erstmal rudimentär ermitteln kann.
Ergänzung: Selbstverständlich mit deaktiviertem Cache-Plugin, falls das unklar ist.
In der Datei functions.php ist die Zeile 590 bereits so.
Ja, deshalb steht da auch der Text: [COLOR=#ff0000]neu (auf dem Website geändert):[/COLOR]
Ergänzung zu 3. Deaktiviere auch a3 Lazy Load (das man jetzt erst sieht).
Kurz: Erstmal alles raus, was ständig in die Ausgaben eingreift. Erst dann kann man erkennen, wo die tieferliegenden Performance Killer sind.
4. Stelle zudem sicher, dass alle Bilder vorhanden sind, derzeit 404:
<link rel="icon" href="https://barsbarsbatigol.de/wp-content/uploads/2022/11/elementor/thumbs/BBB-Logo-Rund-py1yig9fpvnze5iij2g70fepakuy5yhjicpnt0o3hq.png" sizes="32x32" />
5. Finde heraus, warum Autoptimize manche Scripts nicht zusammenfügt, Beispiel:
<script src='https://barsbarsbatigol.de/wp-includes/js/dist/vendor/wp-polyfill-inert.min.js?ver=3.1.2' id='wp-polyfill-inert-js'></script> <script src='https://barsbarsbatigol.de/wp-includes/js/dist/vendor/regenerator-runtime.min.js?ver=0.13.11' id='regenerator-runtime-js'></script> <script src='https://barsbarsbatigol.de/wp-includes/js/dist/vendor/wp-polyfill.min.js?ver=3.15.0' id='wp-polyfill-js'></script> <script src='https://barsbarsbatigol.de/wp-includes/js/dist/hooks.min.js?ver=c6aec9a8d4e5a5d543a1' id='wp-hooks-js'></script> <script src='https://barsbarsbatigol.de/wp-includes/js/dist/i18n.min.js?ver=7701b0c3857f914212ef' id='wp-i18n-js'></script>
Tipp: Autoptimize selbst kann auch ein Performance Killer werden, wenn es unpassend eingerichtet ist. Im Zweifel auch mal komplett weglassen bei der Suche.
6. Ergänzung: Hinterfragen ob man (erst jetzt sichtbare) Plugins wie Dynamic Visibility for Elementor braucht. Unterschiedliche Einstellungen je nach Breakpoint z.B. kann Elementor auch alleine.[size=24][/SIZE]
Vergleiche dann die Geschwindigkeit.
Der genannte Fehler wird mit dem bereits genannten Codeblock behoben. Die Funktion [FONT=Courier New]array_key_exists()[/FONT] ist aktuelles PHP und nichts spricht gegen eine Nutzung.
Der Fehler besteht darin, dass der Array Key [FONT=Courier New]$exif_ifd0['COMPUTED'][/FONT] je nach Bild nicht existiert und daher auch dann PHP Hinweise erzeugt wenn wie neu vorgeschlagen mit einem [FONT=Courier New]is_array()[/FONT] trotzdem darauf zugegriffen wird.
Seltsame Anführungszeichen wie hier führen zudem zu weiteren PHP Fehlern:
Aber vermutlich sollte das alles gar nicht hilfreich sein, bei manchen ist das schwer zu erkennen...
Ich brauche dringend deine Hilfe.
CSS mit „display:none!important;“ hat leider auch nicht geholfen, obwohl ich in der „style.css“ eine entsprechende Klasse geschrieben habe und im „li“-Tag auch die Klassenreferenz enthalten war.
Ein Bug im Geo2 Maps Add-on ist in Zeile 590 functions.php des Plugins:
alt:
// Aperture
if (@array_key_exists( 'ApertureFNumber', $exif_ifd0['COMPUTED'] ) ) {
neu (auf dem Website geändert):
// Aperture
if (
@array_key_exists( 'COMPUTED', $exif_ifd0 ) &&
@array_key_exists( 'ApertureFNumber', $exif_ifd0['COMPUTED'] )
) {
Alles anzeigen
Das behebt den Fatal Error:
Und noch ein kleiner Fix in Zeile 816 bing_map_functions.php
Bleiben ggf. noch weitere PHP Warnings im Geo2 Maps Add-on bzw. NextGEN Plugin selbst, die man derzeit sieht, weil in PHP [FONT=Courier New]error_reporting[/FONT] mit [FONT=Courier New]E_WARNING[/FONT] eingestellt ist.
Die entspr. Membership Plugins durchsehen, welches am besten passt.
Wenn ich dies einfüge und dann auf speichern klicke kommt die Meldung " JSON-Antwort" und es lässt mich nicht speichern.
Ursache sind Ränder/Position Einstellungen beim "Get Access" Button bzw. dem dort übergeordneten Container.