Beiträge von b3317133

    Ich will ein komplett neues Wordpress instalieren.
    Reicht es wenn ich alle Dateien und Verzeichnisse bis zum Basisverzeichnis lösche?


    Zur Deinstallation löscht man alle Dateien und Verzeichnisse im Installationsordner von WordPress und den Inhalt der zugehörigen Datenbank. Bei ggf. Nutzung der gleichen Datenbank auch für andere Dinge nur die WordPress Tabellen löschen.

    Kann ich mit der neuen, frischen Webseite auf eine andere Domain umziehen?


    Das macht man üblicherweise mit einem sog. Migrationsplugin. Viele verwenden dafür Duplicator, alle nötigen Anpassungen von URLs usw. werden damit im Verlauf des Umzugs automatisch vorgenommen.

    Wenn nach der Änderung der Zeile 194 nach wie vor der og. [FONT=Courier New]__wakeup() must have public visibility[/FONT] Eintrag im Server Error Log erscheint, hast Du das ggf. im falschen Ordner oder auf dem falschen Server geändert.

    Oder der Server Error Log Eintrag hat nichts mit dem zu tun, was Du derzeit testest und was "keine Änderung bewirkt".

    Eine WordPress Datei [FONT=Courier New]/wp-content/debug.log[/FONT] wird angelegt, wenn entspr. Einstellungen wie im o.g. Link zur Debug-Dokumentation beschrieben vorhanden sind und WordPress einen Fehler abfangen kann.

    Der Code des Themes ist augenscheinlich nicht mit der verwendeten PHP Version kompatibel.

    Du kannst versuchen, das Theme selbst anzupassen, für die im Server Error Log genannte Meldung z.B. so:

    Code
    wp-content/themes/droow/inc/merlin/includes/class-merlin-logger.php on line 194
    
    
    private function __wakeup() {}
    
    
    ändern in
    
    
    public function __wakeup() {}


    Es kann dann natürlich noch zu weiteren Meldungen kommen.

    Deine sonstige Beschreibung passt nicht ganz zu dieser Meldung, auch die WordPress Datei [FONT=Courier New]debug.log[/FONT] wird offenbar weiterhin nicht angelegt.

    Generell sollte man hier aber wirklich ernsthaft überlegen, ob man ein nicht mehr angebotenes Theme ohne Updates und Support wirklich verwenden möchte.

    Leider ist dort offenbar nicht [FONT=Courier New]WP_DEBUG[/FONT] mit [FONT=Courier New]WP_DEBUG_LOG[/FONT] aktiv, ein Log in der Datei [FONT=Courier New]/wp-content/debug.log[/FONT] existiert derzeit nicht.

    Aktiviere die Debug Einstellungen inklusive Log und deaktiviere alle Plugins bis auf Droow Functionality Plugin & Gutenberg Blocks und Elementor. Erscheint dann weiterhin "Es gab einen kritischen Fehler auf dieser Website"?

    Weiterhin stelle auf dem Server maximal PHP 8.2.x ein, für PHP 8.3.x gibt es in WordPress derzeit nur “beta support”.

    • Wie genau heisst das Theme?
    • Welche genaue Version des Themes wird verwendet?
    • Welche genaue Version von WordPress wird verwendet?
    • Welche PHP Version wird verwendet?
    • Link zur vollständigen Datei [FONT=Courier New]debug.log[/FONT]? Die beiden genannten Ausgaben erzeugen keinen kritischen Fehler.


    Generell sollte man natürlich überlegen, ob man ein nicht mehr angebotenes Theme bei dem der Support nicht zuverlässig antwortet, wirklich verwenden möchte.

    Welches Theme genau wird verwendet? Es gibt bei Theme Forest z.B. mehrere mit Droow im Namen.

    Generell: Prüfe die Kompatibilität des Themes mit Deiner WordPress und Elementor Version. Viele ältere Themes sind nicht wirklich mit aktuellen WordPress und/oder Elementor Versionen kompatibel.

    Wurde WordPress und/oder Elementor nach der Neuinstallation (ggf. automatisch) aktualisiert?

    Du kannst zudem über [FONT=Courier New]WP_DEBUG[/FONT] mit [FONT=Courier New]WP_DEBUG_LOG[/FONT] ein Log in der Datei [FONT=Courier New]/wp-content/debug.log[/FONT] erzeugen, das weitere Hinweise zu kritischen Fehlern enthalten kann. Alternativ bzw. bei schwereren Fehlern kann man mehr Informationen im Error Log beim Hosting nachlesen, da hilft der Hosting Support sicher gerne.

    ich hatte bisher einige statische Seiten und sonst direkt die Kategorien-Übersichten in der Hauptnavigation verlinkt.

    Im jetzigen Theme Twenty-Twentyfive finde ich diese Möglichkeit nicht mehr.

    Versuche es z.B. über Design > Website-Editor > Navigation > drei Punkte > Bearbeiten > in Deine Menüzeile klicken > plus Symbol > Block hinzufügen > Alle durchsuchen > Kategorie-Link > Deine Kategorie auswählen

    Die Gestaltung von Menüs und auch anderen Dingen mit dem neuen WordPress Site Editor ist leider nicht sehr intuitiv.

    Eigentlich sollte Dein Vorhaben relativ einfach möglich sein, siehe auch WordPress Dokumentation Multisite Domain Mapping. Man legt die Subseite erst als Subdomain in Multisite an und ersetzt die Subdomain URL dann durch die volle Domain, die auf den gleichen Ordner wie die Hauptdomain zeigt.

    Zitat

    In the network admin dashboard, click on Sites to show the listing of all the subsites, and then click on edit for the subsite you want to map to. In our example, this is subsite1.mynetwork.com.

    In the Site Address (URL) field, enter the full URL to the domain name you’re mapping – [plain]https://example.com[/plain] – and click save.


    Oder sollen die Inhalte der einzelnen vollen Domains zu 100% identisch sein und aus einer einzigen Installation kommen? Was am Rande bemerkt für die Suchmaschinen etwas verwirrend wäre? Dann bräuchte man keine Multisite Installation sondern nur einen Filter z.B. über eine [FONT=Courier New]wp[/FONT] Action, in dem man on-thy-fly in der Ausgabe die eigentliche WordPress Installationsdomain durch die jeweils aufgerufene andere Länder Domain sucht/ersetzt.

    Die o.g. Scriptfehler erscheinen damit nicht mehr, offenbar ist also das Litespeed Plugin schon mal nicht kompatibel für diese Installation. Lasse es deaktiviert.

    Was noch erschienen ist, sind viele Ajax Aufrufe mit 400 Bad Request Ergebnis wenn man Eingaben z.B. beim Benutzernamen und Passwort macht. Es wird dabei versucht eine Action [FONT=Courier New]afacr_update_user_abandoned_cart_with_cart_blocks[/FONT] aufzurufen, augenscheinlich läuft da noch ein extra Plugin bzgl. Warenkorb Abandoned Cart Recovery von Addify (Plugin Ordner [FONT=Courier New]addify-abandoned-cart-recovery[/FONT]) das warum auch immer in die Login Eingaben eingreift. Deaktiviere das auch.

    Prüfe dann, ob es weitere Fehlermeldungen von Benutzern bzgl. Login gibt.

    Die Seite erzeugt derzeit Scriptfehler in der Browser Konsole.

    Code
    Uncaught ReferenceError: wp is not defined
    Uncaught TypeError: owlFurniture.owlCarousel is not a function
    Uncaught TypeError: jQuery(...).jPages is not a function
    Uncaught TypeError: jQuery.datepicker is undefined
    ...


    Deaktiviere als erstes alle Cache-, Minify- und Optimierungsplugins, derzeit mindestens aktiv: Litespeed

    Nahezu jede WordPress Installation erlebt tagtäglich eine Vielzahl von Anmeldeversuchen von Tausenden von Bots über die verschiedensten IP Adressen, der Log-Eintrag dürfte einer davon sein.

    Deine Installation hat den Versuch mit HTTP Status 403 Forbidden abgelehnt.

    Das ist ein Forum für Hilfe zur Selbsthilfe, jeder soll aus den beschriebenen Problemen, Rückfragen und Antworten lernen können.

    Ob z.B. jeweils die Pro Version installiert ist und welche Versionen verwendet werden, wie genau die Migration vorgenommen wurde und wo genau dann Daten fehlen, sind z.B. sehr wichtige Informationen, um mögliche Ursachen von Migrationsproblemen weiter eingrenzen zu können.

    Wenn Du direkte Hilfe benötigst, kannst Du z.B. ein Gesuch im Bereich "Jobbörse" des Forums posten, dann darf man Dir lt. Forenregeln entspr. Angebote zusenden.

    Das Galerie Feld benötigt ACF Pro, ist die Pro Version in beiden Installationen aktiv? Von welcher genauen ACF Version auf welche wurde migriert? Fehlen die Galerien im Backend oder nur im Frontend? Bitte zudem alle Fragen von oben beantworten.

    Wo von wem hast Du was genau erfahren? Was bedeutet konkret "nicht mehr richtig übernommen"? In welcher Form liegen diese "alten ACF Daten" vor? Von wo nach wo sollen diese Daten "migriert" werden? Wie genau gehst Du dabei vor? Was genau fehlt danach?

    Weil ich eine zweite Webpage aufbaue., also 2 Sites in meiner wp Installation benötige.


    Ok. Man kann auf einem Server auch mehrere eigenständige WordPress Installationen parallel betreiben. Wenn z.B. nur eine Datenbank verfügbar ist, verwendet man dann ein unterschiedliches Datenbank-Präfix. Das nur am Rande.

    Viel Erfolg mit Multisite, man muss dabei nur wissen, dass das eher ein Sonderfall in der selbstgehosteten WordPress Welt ist, daher siehe o.g. Hintergrund der Fragen.