Beiträge von b3317133

    Verwende maximal PHP 8.2.x mit der neusten WordPress Version, neuere PHP Versionen haben derzeit nur beta Unterstützung.

    Welche genaue "kritische Fehler Error Meldung" wird angezeigt?

    Das Imagick Modul ist wie dort genannt "optional", wird vom WordPress Website Zustand aber trotzdem als fehlend bemängelt, mehr dazu und wie man das ausblenden kann siehe ein älterer Blogbeitrag hier.

    Tipp am Rande: Wenn Theme oder Plugins "auf dem aktuellen Stand" ohne Updatehinweis angezeigt werden, muss das nichts heissen, für vieles gibt es seit Jahren keine Updates mehr, die entspr. PHP Kompatibilität muss man jeweils manuell recherchieren.

    Der HTML Code der Seiten im Frontend bricht derzeit frühzeitig während der Ausgabe noch innerhalb des [FONT=Courier New]<head>[/FONT] Bereichs ab, daher wird im Browser nichts angezeigt.

    Ein HTML-Checker sollte das eigentlich bemerken, alternativ kann man es auch im HTML Seitenquelltext im Browser sehen.

    Derzeit wird auf dem Server die PHP Version 8.3.21 verwendet, die ist zu neu und hat in WordPress derzeit nur beta Support. Verwende maximal PHP 8.2.x. Löst das bereits das Problem?

    Falls nicht, deaktiviere temporär der Reihe nach einzeln alle Plugins um hier Wechselwirkungen auszuschliessen.

    Du kannst zudem über [FONT=Courier New]WP_DEBUG[/FONT] mit [FONT=Courier New]WP_DEBUG_LOG[/FONT] ein Log in der Datei [FONT=Courier New]/wp-content/debug.log[/FONT] erzeugen, das weitere Hinweise zu Fehlern enthalten kann. Alternativ bzw. bei schwereren Fehlern kann man mehr Informationen im Error Log beim Hosting nachlesen, da hilft der Hosting Support sicher gerne.

    Nach irgend einem Update (wahrscheinlich) geht das Frontend nicht mehr.


    Vermutlich wurden PHP-Umstellung oder sonstige Aktualisierungen in WordPress ohne vorherige Recherche zur Kompatibilität der verwendeten WordPress Version, des Themes, der Plugins usw. vorgenommen. Stelle sicher, dass jemand die Seite betreut, der sich wenigstens rudimentär mit einem solchen Vorgehen auskennt.

    Lege den fehlenden Ordner an:

    Lege den Ordner [FONT=Courier New]wp-content/plugins/[/FONT] per FTP an und kopiere die Datei [FONT=Courier New]wp-content/themes/index.php[/FONT] dort hinein.


    Danach sollte die Installation von Plugins in WordPress wieder funktionieren.

    Vermutlich hast Du bei Deiner damaligen Fehlersuche den ganzen Ordner [FONT=Courier New]wp-content/plugins/[/FONT] umbenannt statt nur einzelne Plugins Ordner darin.

    Im Screenshot sind neben dem überzähligen Ordner [FONT=Courier New]wp-admin-alt[/FONT] u.a. noch eine offenbar umbenannte [FONT=Courier New].htaccesss[/FONT] (mit 3 s) und Reste des Plugins Wordfence zu sehen, das könnte man noch bereinigen, wenn keine Einträge dazu in der echten [FONT=Courier New].htaccess[/FONT] sind.

    plugins_path: /home/www/wordpress/wp-content/plugins
    plugins_size: directory not found
    ..
    plugins: not writable


    Das passt zur o.g. Ergänzung:

    Ergänzung: Derzeit existiert augenscheinlich lt. Browser der Ordner [FONT=Courier New]wp-content/plugins/[/FONT] (noch) gar nicht, das sollte nicht sein, dieser Ordner und die darin befindliche [FONT=Courier New]index.php[/FONT] gehören zu einer WordPress Installation dazu, hier stellt sich die Frage, wie das passieren konnte.


    Lege den Ordner [FONT=Courier New]wp-content/plugins/[/FONT] per FTP an und kopiere die Datei [FONT=Courier New]wp-content/themes/index.php[/FONT] dort hinein.

    • Wie genau wurde WordPress installiert? Über einen Webgo One-Click-Installer oder manuell per FTP?
    • Wie genau wurde das eigene Theme und Child-Theme installiert? Über WordPress oder manuell per FTP?


    Weiteres geht ggf. hieraus hervor: WordPress > Werkzeuge > Website-Zustand > Tab Bericht > Button "Bericht in die Zwischenablage kopieren" > wpde Forum > Button "Einfügen", das ist das "+" Plus Symbol und dann "Code" > den Bericht posten.

    Ergänzung: Derzeit existiert augenscheinlich lt. Browser der Ordner [FONT=Courier New]wp-content/plugins/[/FONT] (noch) gar nicht, das sollte nicht sein, dieser Ordner und die darin befindliche [FONT=Courier New]index.php[/FONT] gehören zu einer WordPress Installation dazu, hier stellt sich die Frage, wie das passieren konnte.

    • Wie genau wurde WordPress installiert? Bist Du einer Anleitung gefolgt? Welcher?
    • Was genau siehst Du nach dem Login? Screenshot der ganzen Seite, wenn möglich?


    Möglichweise hat der Account, mit dem Du Dich jetzt anmeldest, keine "Administator" Rechte sondern hat nur die sog. "Abonnent" bzw. englisch "Subscriber" Benutzerrolle, damit findet man nach Anmeldung dann nur die eigene Benutzer Profil Seite.

    • Wann/wo genau erscheint diese Meldung? Bei welchem Link?
    • Wie ist Zwei-Faktor für das Backend realisiert? Mit einem Plugin? Mit welchem?


    Üblicherweise deaktiviert man in solchen Fällen das entspr. Plugin z.B. durch temporäres Umbenennen des Ordners des Plugins z.B. [FONT=Courier New]wp-content/plugins/das-tolle-zwei-faktor-plugin/[/FONT] in [FONT=Courier New]wp-content/plugins/das-tolle-zwei-faktor-plugin-deaktiviert/[/FONT] was meist die Login Möglichkeit wiederherstellt. Dann wendet man sich an den Support des Zwei-Faktor Plugins und zeigt denen das Phänomen.

    Es handelt sich weiterhin oder wieder um das gleiche Problem, wie in Deinem älteren Thread beschrieben:

    Weiterhin den aktuellen Aufbau der Seite, derzeit bricht hier z.B. das Laden der Startseite vor dem eigentlichen Ende ab. Dazu könnte es Einträge im Error Log auf dem Server geben.

    Ergänzung: Vom verwendeten Enfold Theme gab es vor ca. einer Woche ein 7.1 Update, das auch eingespielt ist. Evtl. könnte man auf einen Backup Stand von vor dem Update zurückgehen, um das als Ursache auszuschliessen.


    Es gilt alles weiter, was im alten Thread dazu ausgeführt wurde...

    Zwischenzeitlich erscheint jetzt eine funktionierende WordPress Einrichtungsseite statt der vorherigen 403 Forbidden Fehlermeldungen. Offenbar wird die [FONT=Courier New]wp-config.php[/FONT] der alten extra Installation im Unterordner nicht gefunden oder Daten darin, z.B. das Tabellen Präfix stimmen nicht (mehr).

    Die extra WordPress Installation im von Dir genannten Unterordner ist offenbar defekt oder Dateien bzw. Ordner darin sind ggf. serverseitig gesperrt.

    Einige Daten der extra Installation sind offenbar noch vorhanden und erreichbar, z.B. das Logo und andere Dateien und Bilder und auch zumindest Teile des WordPress Core:

    Code
    https://polyfill.at/Absamer_Naturbetten/wp-content/uploads/2016/06/Naturbetten_Logo_web.png
    https://www.google.com/search?q=inurl%3Ahttps%3A%2F%2Fpolyfill.at%2FAbsamer_Naturbetten%2Fwp-content%2F
    https://polyfill.at/Absamer_Naturbetten/wp-includes/css/admin-bar.css
    https://polyfill.at/Absamer_Naturbetten/wp-includes/js/jquery/jquery.min.js

    Deaktiviere testweise das Plugin Interactive Map of Austria for WP (austriahtmlmap), es lädt ein "nicescroll" Script, das ggf. Einfluss auf das Scollverhalten hat und verursacht lt. Browser Console hier Scriptfehler. Verwendet wird Plugin Version 2.2 bis max. WordPress 5.1.x, aktuell wäre Version 2.7 bis max. WordPress 6.8.

    @uha Es wurden nach meinem o.g. Hinweis auf den Bereich "Unterhaltung" FTP Zugangsdaten zugeschickt und ein kurzer Einblick ergab folgendes:

    Hauptproblem war das unvollständige Theme Catch Base, es fehlten darin praktisch alle PHP Dateien im Unterordner [FONT=Courier New]inc[/FONT], das führte zum Server Error. Auch mind. ein Plugin war direkt sichtbar im Frontend unvollständig, es fehlten darin u.a. Ordner mit CSS Dateien. Ursache für beides war offenbar fehlender Speicherplatz auf dem Server beim Einspielversuch der Installation. Dazu kam noch ein kleineres Folgeproblem wegen des Reparaturversuchs durch den umbenannten Theme Ordner. Nach dem Freimachen von Speicher durch Entfernen eines grossen alten ungenutzen Cache Ordners und Entfernung von tausenden Apple [FONT=Courier New].-[/FONT] Meta-Dateien und Vervollständigung der Theme Dateien mit korrekter Benennung des Theme Ordners war die Seite wieder online.