Beiträge von b3317133

    Bei diesem Website ist es noch haarsträubender, sogar der Banner selbst mit der Zustimmungsverwaltung wird von einem externen Server eingebunden.

    Du hast das grundlegende Problem noch nicht verstanden, siehe auch oben:

    Einfach irgendein Plugin zu installieren, ist nicht ausreichend. Jeder Consent-Banner muss je nach Website individuell eingerichtet werden. Dazu können je nach Website auch individuelle Anpassungen von Plugins oder Themes notwendig werden, damit diese überhaupt mit einem Consent-Banner zusammenarbeiten (können).

    Es ist bei technisch nicht notwenigen Inhalten egal, ob sie aus Europa oder sonstwoher kommen. Die IP-Adressen der Besucher sind lt. DSGVO persönliche Daten. Jede Einbindung externer Inhalte liefert diese persönlichen Daten direkt an den externen Server. Daher ist vorher eine Zustimmung erforderlich. Cookies sind dann noch ein zweites Thema.

    Ob man die DSGVO als Schwachsinn erachtet oder nicht, darf jeder für sich selbst entscheiden. Die aktuell dadurch gültige Rechtslage führt derzeit zu vielen Abmahnungen und bösen Überraschungen für viele Websitebetreiber.

    Daher hat auch wordpress.org reagiert und für externe Google Webfonts das Problem z.B. hier bei make.wordpress.org exemplarisch kurz erklärt, weiteres beim Anwalt der Wahl.

    Auch dieser Website lädt lt. "Waterfall" Liste usw. technisch nicht notwendige externe Einbindungen z.B. von jquery.com und ezocdn.com vor dem Zustimmen, während der Consent-Banner gezeigt wird.

    Ergänzung:
    Man kann solche Einbindungen auch in jedem Browser manuell selbst nachvollziehen, ein Dienst wie webpagetest.org o.ä. ist dafür nicht nötig, die verlinkten Listen dienen nur der Verdeutlichung.

    Einfach irgendein Plugin zu installieren, ist nicht ausreichend. Jeder Consent-Banner muss je nach Website individuell eingerichtet werden. Dazu können je nach Website auch individuelle Anpassungen von Plugins oder Themes notwendig werden, damit diese überhaupt mit einem Consent-Banner zusammenarbeiten (können).

    Wer einen Website betreibt, braucht wenigstens grundsätzlichen technischen Sachverstand oder entspr. Hilfe von Dritten (am besten im direkten persönlichen Umfeld), die den Website technisch betreuen.

    Leider verstehe ich an dieser Stelle gar nichts.

    • Der Code ist fehlerhaft.
    • Die darin genannte Funktion existiert nicht.
    • Jeder Seitenaufruf von WordPress erzeugt damit PHP Fehler.
    • Die Error Logs auf dem Server werden mit zig Meldungen wie dieser stetig zugemüllt:
    Code
    PHP Warning:  call_user_func_array() expects parameter 1 to be a valid callback, function 'disable_theme_update_notification' not found or invalid function name in /wp-includes/class-wp-hook.php

    Dieser Code ist schlichtweg falsch, die darin verwendete Filterfunktion [FONT=Courier New]disable_theme_update_notification[/FONT] fehlt. Falls diese Zeile vermeintlich funktioniert, dann nur aus dem Grund, dass intern bei jedem Aufruf des Filters ein PHP Fehler auftritt und das fehlende eigentlich als Ergebnis erwartete Array anderweitig ab- bzw. aufgefangen wird.

    Für spätere Mitleser erneut der Hinweis: Theme Updates können sicherheitsrelevante Fehlerbehebungen enthalten und sollten nicht endlos aufgeschoben/ausgeblendet werden.

    Die hier als "Lösung" genannte Herangehensweise ist a) fehlerhaft und b) auch ohne Fehler keinesfalls empfehlenswert.

    Evtl. zu viele Plugins mit ggf. überschneidenden Funktionsbereichen, weniger ist mehr.

    Ergänzung:

    Diesmal habe ich noch Ninjascanner ... mitdeaktiviert


    Der Hinweis, alle "Sicherheits" Plugins zu deaktivieren stand auch schon oben:

    Deaktiviere Ninja-FW und alle ähnlichen "Sicherheits" Plugins.

    Oder Autoptimize bzw. WP Super Cache sind/waren auch für angemeldete Benutzer aktiv (was generell nicht empfehlenswert ist) und haben veraltete Inhalte geliefert bzw. darin vorkommende "minified" Dateien nicht mehr gefunden usw.

    Es wird bei diesem Login bei Aufruf der Plugins Übersicht auch eine entspr. Meldung angezeigt, dass das Plugin (mit dem vorherigen Ordnernamen) nicht mehr gefunden wurde und daher deaktiviert wurde.

    Im zitierten Code sind zunächst mal alle Hochkommata falsch, was ggf. kann auch am fehlerhaften Einfügen (nicht als "Code") im Forum liegen könnte. Bitte korrekt einfügen.

    Weiterhin wurde der Code offensichtlich einfach 1:1 von irgendwelchen Webseiten kopiert und passt daher ggf. nicht zum verwendeten Theme, das nicht genannt wurde und/oder zur PHP Version. Link zum Website? Siehe auch Forenregeln, Punkt II.

    Du suchst nach einer Ursache, die in Deine URL Struktur eingreift, Ezoic macht sowas. "Aber ich brauche Umsatz" ist ggf. kein wirklich stichhaltiges Argument bei Abmahnung wg. Tracking, IP-Weitergabe usw. ohne Zustimmung, dazu am besten einen Anwalt befragen.

    Deaktiviere offensichtlich vorhandene Zusatzplugins für Elementor oder aktualisiere diese Plugins auf eine aktuelle mit Deinem Elementor kompatible Version.

    Alternativ spiele vorerst ein Backup Deines Websites mit einer älteren Elementor Version von vor dem Auftreten dieses Problems ein und recherchiere dann weiteres zur Kompatibilität der verwendeten Plugins.

    Alternativ wende Dich an die Person, die den Website technisch betreut bzw. ursprünglich eingerichtet hat, die müsste am besten wissen, welche(s) Plugin(s) hier eine Ursache sein könnte.

    Im Code des veralteten Plugins muss dann wie auch aus der Fehlermeldung bereits ersichtlich [FONT=Courier New]_register_controls()[/FONT] in [FONT=Courier New]register_controls()[/FONT] geändert werden, der Unterstrich am Anfang fällt weg, siehe auch Elementor Entwickler Dokumentation.