Einen Fatal Error sehe ich aber sofort, wenn ich versuche, woocommerce zu aktivieren -
Screenshot des Fatal Errors?
Bei Host Europe kann in den PHP Einstellungen auch eingestellt sein, dass Debugging nicht per Script überschrieben werden kann.
Um schreiben oder kommentieren zu können, benötigen Sie ein Benutzerkonto.
Sie haben schon ein Benutzerkonto? Melden Sie sich hier an.
Jetzt anmeldenHier können Sie ein neues Benutzerkonto erstellen.
Neues Benutzerkonto erstellenEinen Fatal Error sehe ich aber sofort, wenn ich versuche, woocommerce zu aktivieren -
Screenshot des Fatal Errors?
Bei Host Europe kann in den PHP Einstellungen auch eingestellt sein, dass Debugging nicht per Script überschrieben werden kann.
Man kann bei so grossen Datenmengen auch einfach z.B. [FONT=Courier New]wp-content/uploads/[/FONT] als Ausnahme für das Duplikator Paket einstellen und das Verzeichnis manuell per FTP selbst kopieren. Oft befinden sich auch komplette Backups mit in [FONT=Courier New]wp-content[/FONT] Ordnern oder anderweitige Ordner im WordPress Hauptverzeichnis, die bei Duplicator mitgesichert werden, wenn man keine Ausnahme dafür einrichtet.
Das Asgaros Forum Plugin ist derzeit inaktiv/gesperrt, siehe auch Pluginbeschreibung.
Das sollte man wohl vorerst nicht benutzen. Evtl. enthält es Sicherheitslücken o.ä.
Sowas kann viele Ursachen haben. Wende Dich am besten direkt an den JetPack Support, den hast Du mitgekauft.
Von aussen ohne Login usw. kann man bei diesem Problem leider nicht wirklich weiterhelfen.
Für spätere Mitleser:
Dieses Vorgehen ist wohlgemerkt kein allgemeingültiger Ansatz.
Normalerweise sollte man WordPress durch die verschiedenen Versionen in kleineren Schritten aktualisieren, also in diesem Fall 3.9.6->3.9.37 (erstmal auf die neuste im Zweig), dann 4.0.36->4.2.34->4.4.x->4.6.x usw., das ist nur hier wegen der erfolgten PHP Umstellung nicht mehr möglich. Ab 5.6.10 ist WordPress PHP 8 kompatibel, daher würde man es in diesem Notfall damit versuchen.
Die beste Lösung wäre ein Einspielen des Backups auf einen anderen Server mit der alten PHP Version und dann schrittweises Aktualisieren von WordPress, Theme, Plugins und PHP die jeweils zeitlich ähnlich veröffentlicht wurden und kompatibel sind und dann der Umzug auf den Liveserver.
Du löschst nicht [FONT=Courier New]wp-config.php[/FONT]. Du ersetzt alle Dateien und Ordner bis auf [FONT=Courier New]wp-content[/FONT] aus einem frischen WordPress Download Archiv, da ist [FONT=Courier New]wp-config.php[/FONT] nicht betroffen.
Ob der Login mit alleine der neuen WordPress Version funktioniert, ist nicht klar, daher siehe die anderen beiden Punkte bei "Du kannst per Filezilla einspielen".
Besorge am besten zuerst aktuelle PHP 8 kompatible Archive des Themes und ggf. kommerzieller Plugins bzw. informiere Dich bei den Autoren/Herstellern, ob es diese gibt.
jetzt gibts einen Fatal Error, wenn ich Woocommerce aktiviere.
Welcher Fatal Error genau? Der o.g. Auszug aus dem Error Log sind keine Fatal Errors.
Welche WordPress Version wurde verwendet? Welches Theme und Version (steht in Datei style.css des Themes)? Welche Plugins?
Du kannst per Filezilla einspielen:
Details zur eigentlichen Ursache ergeben sich aus dem PHP Error Log im Hosting.
Wenn das Theme 750px Contentbreite hat, sprich das Bild 750px breit dargestellt wird, dann erstelle das Bild in 750*2=1500px Breite im PNG Format und versuche es damit.
Viele Seiten sind abmahngefährdet. Aus den verschiedensten Gründen.
Ohne Link zu Deiner eigenen Seite wird man Dir kaum Tipps geben können, ob bei Dir was im Argen liegen könnte. Siehe auch Forenregeln, Punkt II.
Die von Dir genannten Google Analytics, GoogleTag Manager und Matomo sind keine standardmässigen Funktionen von WordPress.
Alternativ suche einen Anwalt Deiner Wahl auf und lasse Deine Seite dort prüfen.
Rechtssichere Aussagen kannst und wirst Du in "irgendeinem Internetforum" wie diesem hier sicher nicht bekommen.
Im Grunde egal welches, es muss nur zu Deinen Anforderungen passen und entspr. für Deinen Website eingerichtet werden.
Oft besteht der Irrglaube, man müsse nur irgendein Cookie Plugin installieren und alles wäre damit erledigt.
Derzeit werden auf Deinem Website beispielsweise externe Inhalte von facebook, youtube, google eingebunden, das darf alles erst nach Zustimmung erfolgen.
.. wenn man ein "leeres" Template auswählen kann (damit kein zusätzliches CSS vom Template geladen wird) in der Seitenerstellung und nur der Inhalt des Editors angezeigt wird, geht so etwas auch?
Das geht so:
Möglichkeiten:
Die Gestaltung des Supports bzw. der Updates ist je nach Theme Anbieter unterschiedlich.
Bei manchen Theme Forest bzw. Envato Themes kann es z.B. sein, dass man die eigentlich weiter verfügbaren Updates jeweils manuell aus dem Account dort herunterladen und selbst installieren muss, das erfährt man aber oft nicht, wenn der technische Support für Installation o.ä. bereits abgelaufen ist, bei anderen Themes dort können Updates bequem über das Envato Market Plugin installiert werden, wenn ein Token erzeugt/hinterlegt wurde, usw. Also gibt es auch innerhalb eines Marktplatzes Unterschiede.
Generelle Aussagen dazu kann man nicht treffen, alles genau lesen, ggf. auch Altverträge genau lesen, daher auch immer alles runterladen bzw. archivieren, die Bedingungen können sich von aktuellen Angeboten auch mal unterscheiden.
Versuche es mit der Elementor Anleitung für Popups, z.B. google: Elementor Pro Popup
Du kannst versuchen, über FileZilla die aktuelle Version des Plugins, die heute veröffentlicht wurde, in den passenden Pfad hochzuladen:
ZitatVersion 2.1.3:https://github.com/Codeinwp/otter…v2.1.2...v2.1.3Fixed a crash issue for users with PHP8.0 & PHP8.1 with WP version lower than 6.1
Mit dem Benutzer sollte das nichts alles zu tun haben. Verwendest Du ggf. das JetPack Plugin in Deiner Installation?
Kommt auf Deinen sonstigen Code an. Link zu Deinen Boxen? Siehe auch Forenregeln, Punkt II.
Ergänzung: Allgemeines Beispiel: https://jsfiddle.net/2ze586x0/
Stelle sicher, dass mind. eine Seite oder ein Beitrag publiziert/öffentlich ist, dann sollte die Startseite Einstellung erscheinen.
Es liegt vermutlich wie bereits ausgeführt daran, dass Dein sehr altes Theme und/oder das offenbar aktuell damit verwendete uralte Page Builder Plugin nicht zum aktuell installierten neusten WordPress passt.
Die WordPress Version wurde aktualisiert, ohne die Kompatibilität zu prüfen. Das war der Hauptfehler.
Die PHP Version jetzt auch noch zu aktualisieren, wird das Problem eher verschärfen.
Installiere testweise noch die Plugins Classic Editor und Classic Widgets und Enable jQuery Migrate Helper, evtl. hilft das etwas weiter, allerdings mit wenig Erfolgsaussichten bzw. bei letzterem Plugin nicht als Dauerlösung.
Die wohl beste Lösung wird sein: Neuaufbau der Seite mit neuem aktuellen Theme und nicht diesem Page Builder.
Deaktiviere alle Cache-, Minify- und Optimierungsplugins, derzeit mind. aktiv: Better WordPress Minify (das ist übrigens uralt und sollte am besten gar nicht genutzt werden).
Dann leere Deinen Browser Cache.
Stelle zudem sicher, dass im Menü Einstellungen > Lesen die richtige Startseite eingestellt ist.
Das Plugin WooCommerce muss nicht aktiviert werden, wenn es nicht genutzt wird.
Die PHP Version wird im Hosting eingestellt, nicht in WordPress.
Das Theme ist vom August 2021 und es gibt seitdem keine Updates, verwendet auf dem Website wird derzeit aber WordPress 6.1. Es ist durchaus möglich, dass die Versionen nicht zueinander kompatibel sind.
Möglicherweise wurde WordPress aktualisiert, ohne die Kompatibilität zu prüfen. Wende Dich ggf. an den ursprünglichen Ersteller des Websites und lasse ein Backup mit der passenden WordPress Version einspielen und entscheide dann, wie es mit dem Projekt weitergeht.