Beiträge von b3317133

    Schön, dass es jetzt funktioniert wie gewünscht.

    Anmerkung am Rande: Wenn Du weiterhin extra den Master-ID Link für cgi-bin Zugriff benötigst, sind immer noch irgendwelche Weiterleitungen o.ä. unpassend eingerichtet. Das sollte man im Hinterkopf behalten, wenn irgendwann in Zukunft dann wieder/auch etwas anderes mal nicht funktioniert wie man es erwarten würde.

    Was genau sagte man Dir im Forum von wpDiscuz?

    Das Plugin beachtet die WordPress Felder [FONT=Courier New]comment_moderation[/FONT] bzw. [FONT=Courier New]comment_previously_approved[/FONT] aus Einstellungen > Diskussion > Bevor ein Kommentar erscheint, offensichtlich derzeit nicht.

    Ein deaktivieren des Plugins per FTP brachte nichts, auch das umbennen des kompletten Plugin Ordner hat nichts gebracht (Loginversuche mit wp-admin.php und wp-login.php). ...

    Wie sieht es daneben mit der .htaccess aus? Könnte die hier noch (ohne selbst getätigte Veränderungen) das Problem verursachen und wenn ja, woher bekommt er eine "Standard" Version?


    Was genau erscheint bei o.g. Loginversuch mit umbenannten Plugins? Screenshot?

    Versuche den Login unter [FONT=Courier New]example.com/wp-admin/[/FONT]

    Benenne die[FONT=Courier New] .htaccess[/FONT] temporär um, was erscheint dann bei Loginversuch?

    Standard Version (mit "pretty" Permalinks) zum Vergleich z.B. hier in WordPress Dokumentation.

    Existiert eine [FONT=Courier New]/wp-admin/.htaccess[/FONT]? Falls ja, benenne die um oder lösche sie, ist kein WordPress Standard.

    Ergänzung: Und leere Deine Browser Cache bei jeder Änderung!

    Zeigt das die zweite (blaskapelle) Domain?

    Um die geht es bei der Rückfrage nach dem aktuellen Server Error dort, siehe Antwort #27 oben, und bei der Rückfrage nach dem aktuellen Error Log.

    Die Spalte mit den Rechten, die weiter rechts stehen sollte, z.B. [FONT=Courier New]rw-r--r--[/FONT] oder [FONT=Courier New]rwxr-xr-x[/FONT] usw. ist im Screenshot abgeschnitten.

    Die Fehlermeldung deutet auf Zugriffsrechte hin und passt lt. Uhrzeit nicht zu einem aktuellen Aufruf.

    Poste einen Screenshot wo man die Zugriffsrechte des Ordners [FONT=Courier New]cgi-bin[/FONT] und auch von der Datei [FONT=Courier New]sql.pl[/FONT] sieht.

    Bei der zweiten Domain.. erstellt gerade ein Profi eine neue Homepage. Die bestehende Android APP läuft aber dort.


    Also sollte auf der zweiten Domain diese [FONT=Courier New]/cgi-bin/sql.pl[/FONT] laufen? Sehe da aktuell Server Error 500, was genau wird dazu im entspr. Error Log gezeigt? Oder stimmen da auch einfach nur die Rechte der Datei derzeit nicht? Ist die zweite Domain ein zweiter anderer Strato Account?

    Das Einrichten einer extra Weiterleitung durch Dich ist für Strato App Installationen eigentlich nicht nötig, das macht meines Wissens der Strato App Installationsprozess selbst.

    Die Rechte des [FONT=Courier New]cgi-bin[/FONT] Ordners bei Strato sind 750, die Scripts darin 755.

    Leider hast Du nie die Fehlermeldung oder den Eintrag aus dem Error Log eines dieser (lt. Deinen Angaben nicht mehr) funktionierenden Scripts aus der Anroid App gepostet. Das hätte alles sehr verkürzt.

    Ergänzung: Eine Datei [FONT=Courier New]sql.pl[/FONT] scheint es übrigens dort, wo die o.g. Datei [FONT=Courier New]Umgebungsvariablen.pl[/FONT] liegt und jetzt funktioniert, nicht zu geben.

    Da das [FONT=Courier New]Umgebungsvariablen.pl[/FONT] Script jetzt funktioniert, sieht es so aus, als wären bisher die Rechte des Scripts und/oder des [FONT=Courier New]cgi-bin[/FONT] Ordners unpassend gesetzt gewesen.

    Ein Android APP die auf die DB in dieser Domain mit cgi-bin scripe zugreift läuft nicht mehr.


    Bist Du sicher, dass Deine Android App dieses [FONT=Courier New]Umgebungsvariablen.pl[/FONT] Script verwendet? Die Ausgabe sieht wie ein einfaches Perl Testscript aus.

    Poste einen Screenshot wo man die Zugriffsrechte des Ordners [FONT=Courier New]cgi-bin[/FONT] und auch von diesem [FONT=Courier New]Umgebungsvariablen.pl[/FONT] Script sieht.

    Poste weiterhin die ersten 2 Zeilen des Scripts (über das Symbol [FONT=Courier New][+][/FONT] und Code im Forum Editor).

    Theoretisch müsste bei Strato das Mapping von [FONT=Courier New]/cgi-bin/[/FONT] auch funktionieren, wenn Du Deine Domain für eine Strato-App im Unterordner verwendest.

    Evtl. liegt das Problem daher auch "nur" in Deinem Script selbst, das wäre dann eher ein Fall für ein Perl Forum und hat mit WordPress nichts mehr zu tun.

    Dafür hilfreich wären die Einträge im Error Log, auch bereits oben gefragt, für die echten Scripts aus der Android App, nicht für ein Bild.

    Sinnvoller wäre zu erfahren, was erscheint bzw. im Error Log steht, wenn Du eines dieser (lt. Deinen Angaben jetzt nicht mehr) funktionierenden Scripts aufrufst?

    Wie/ wo muss ich WP dann installieren?


    Manuell in [FONT=Courier New]/[/FONT] statt als Strato-App.

    und wie wäre dann der Link dazu.


    Der Link wäre z.B. die Domain die auf [FONT=Courier New]/[/FONT] zeigt. Leider sind die oben ergänzten Fragen zur Domain noch nicht beantwortet.

    Falls schon eine aufwändig mit vielen Daten befüllte Strato-App Installation exisitert, könnte man die passend verschieben und in eine manuelle Installation umwandeln (ggf. in eine andere Datenbank kopieren, damit die Strato-App Verwaltung da nicht später querschiesst).