Ich habe ein Blog, das von Seiten des Hosters (Host Europe) migriert wurde - danach hatte ich etliche Fehlermeldungen und riesige Probleme.
Host Europe hat augenscheinlich ein merkwürdiges PHP für ihre Kunden installiert und muss vor diesem Hintergund merkwürdiges in den Scripten eintragen, damit diese auf ihren Servern läuft.
Ergo: zuerst einmal die Anleitung von Host Europe besorgen, wie was an Wordpress geändert werden muss, damit es funktioniert.
War eh ein olles 2.x-Wordpress
Die Version ist wichtig, wenn du die Daten noch retten möchtest. Du kannst mit der db Version die verwendete Wordpress Version finden
http://codex.wordpress.org/WordPress_Versions
und ich müsste nun einiges von Hand in die diversen Config-Dateien eintragen.
Und was müsstes in die diversen Config-Dateien eintragen?
Sinnvoller wäre also wohl das Ganze neu aufzusetzen und die Plugins neu zu machen.
Warum sollte dies sinnvoller sein? Musst du dann nicht einiges von Hand in die diversen Config-Dateien eintragen?.
Das Gute: Die SQL-Datenbank mit den Einträgen seit 2003 ist noch da und scheint unangetastet zu sein. Kann ich die irgendwie retten (Backup habe ich gemacht) und ist es sinnvoll, den gesamten Kram zu löschen und einfach das Ganze neu einzuspielen? Da kommt dann allerdings wenn ich die wp-install.php aufrufe dummerweise der Hinweis, dass ich alle Einträge meiner DB löschen soll, was ich natürlich nicht will.
Wenn du sicher bist, dass du die Datenbank mit allen Datensätzen von dir wiederhergestellt werden kann (d.h. nicht mit PhpMyAadmin von dem Hoster gesichert) - warum nicht das upgrade skript nicht starten?
Im Moment kommt nur die übliche "Internal Server Error" und ein zusätzlicher 500er Error.
Den Support vom Hoster anrufen! Wenn alle Ihre Hoster wegen "Internal Server Error" anrufen würden, würden die fastcgi installationen von PHP vermutlich verschwinden....
Bin leider nicht der große Admin und war froh, dass das Ganze lief, wesegen ich auch seit mindestens drei Jahren nicht mehr WP aktualisiert hatte. Das rächt sich nun.
Es gibt Dienstleister, die dies für dich machen können.
Kann man eine existierende Datenbank (nur per "Export" exportiert) in ein neu aufgesetztes Blog einfließen lassen? Hätte noch eine zweite leere DB übrig... danke für Eure Tipps.
Wenn Wordpress funktioniert, stellt Wordpress dafür selbstverständlich Werkzeuge zur Verfügung. Aber bei dir kommt ja nur ein 500er Error....
Ergo. aktuelle Version besorgen - die wp-config nicht überschreiben - und alle anderen PHP Dateien von Wordpress überschreiben und das Upgrade Script aufrufen - wenn du glück hast... wenn nicht ... hier gibt es ein job forum.
viel Glück
ralf