Beiträge von r23


    Hatte dabei einige Probleme mit dem Fehler "8888 Localhost"

    und was ist das für ein Fehler? Ich kenne diese Meldung leider nicht und kann mir auch nicht vorstellen, was du gemachten haben könntest für die Beseitigung :)


    Dachte nun durch einige Forum Beiträge die richtige Lösung zu haben.

    Welche - was hast du gemacht? oder auch nicht?


    musste ich mich aber wieder, wie beim ersten mal anmelden. Die Daten vom lokalenserver scheinen weg.

    Ich verwende für einfache Umzüge das Import und export Pluigin von Wordpress. D.h. ich installiere bei dem Hoster das Blog
    und passe evtl. an die Umgebung an und importiere von der lokalen Umgebung die Änderungen und Anpassungen.

    hilft dies dir weiter?

    ralf


    Nach meinen vergeblichen Recherche habe ich diese Emails gelöscht.
    Nun habe ich gestern und heute von Google Webmaster Tools eine Mitteilung bekommen, dass von meinem Blog große Mengen Emails versendet werden.

    Ich habe leider überhaupt keine Idee, wie das passieren kann oder wie ich das nachprüfen und verhindern kann.


    [COLOR=#000000]wie das passieren[/COLOR]
    zum Beispiel
    http://www.drweb.de/magazin/spam-g…ntaktformulare/


    wie ich das nachprüfen

    log Files vom mail Server prüfen, wenn kein zugriff sich an den Provider wenden.

    und verhindern kann

    Log Files vom WebServer prüfen, die Sicherheitslücke finden und dann beseitigen - wenn man diese nicht selber findet, sich einen Dienstleister suchen, der dies findet und ganantiert beseitigt.

    es gibte viele Möglichekeiten... ich mag zum Beispiel
    http://www.projecthoneypot.org/index.php

    Hoffe die Antwort Hilft weiter

    ralf

    ... egal was ich mache, Artikel erstellen, Dateien im Editor bearbeiten - nach dem Speichern bekomm ich den berühmten weißen Bildschirm. Ich hatte sonstwelchen Sch**ß gedacht, aber ist nicht so.

    Ich würde auch ja keinem verraten, welche PHP Version ich in welcher Umgebung (vermutlich fastcgi bei einem Masenhoster) verwende. ;)


    Ein austauschen der Dateien via ftp brachte keinen Erfolg.

    Tipp: PHP Scripte im ASCII Mode übertragen

    Vermutlich wird durch eine leere Zeile nach ?> gesendet. Dies kann man recht einfach mit einer Abfrage prüfen.


    Das komischste an der ganzen Sache, wenn ich die URL nach dem speichern einkürze auf "meinedomain/wp-admin/" komm ich wieder ins Dashboard und darüber auch wieder zu den Dateien, deren Änderungen wirksam wurden, trotzdem ich rausgeschmissen wurde. WP ist aktuell (3.4.2) - es nervt entsetzlich,

    verwende PHP als Apache Modul :)
    oder lösche alle überflüssigen ?> (Datei ende)
    oder verwende eine richtigen Editor, der dir leere Zielen zeigt
    verwende den Debug von Wordpress
    http://codex.wordpress.org/Editing_wp-config.php#Debug

    und passe deine error Meldungen an
    http://de3.php.net/errorfunc

    Evtl. hängt sich ein Pluigin auf ... bei mir war es mal WP Smush.it...

    aber dies wollen wir keinem verraten


    Ich bin bloss ein begeisteter Benutzer von Wordpress, nicht jedoch ein Profi bezüglich der Installation, weshalb ich mich auch nicht tiefergehend damit beschäftigen möchte.

    Wenn du dich nicht "tiefergehend damit beschäftigen" möchtest, gibt es für dich hier ein Job Forum. Dienstleister können dir sicherlich hier kostengünstig helfen - und wenn Sie Schrott abliefern, nimmst du diese eben in Haftung :)


    Derzeit arbeite ich mit der Version 3.1.1

    keine gute Idee. aktuelle Wordpress Version ist 3.4.2


    Dort steht immer nur die aktuellste Version (3.4.2) zur Auswahl - diese möchte ich jedoch nicht haben, da ich nicht alle Plugins, Templates, etc. wieder anpassen möchte.

    Ein automatisches Update über die Web-Oberfläche ist keine sehr gute Idee - hierbei bleiben die veralteten Scripte auf dem Server leigen. Diese alten Scripte können auch Sicherheitslücken enthalten - ergo: update immer per Hand über den FTP Server gehen und nach der Anleitung von dieser Seite vorgehen. Nicht mehr verwendete Dateien löschen - vorher eine Datensicherung erstellen usw.


    Ich bin mir bewusst, dass ich die Version 3.1.4 auf meinen Server downloaden und diese dann manuell über die bestehende Version installieren könnte, dies möchte ich jedoch wenn irgendwie möglich umgehen.

    3.1.4 ist nicht sicher. verwende 3.4.2 - Die Plugins, die in 3.4.2 nicht mehr funktionieren sollten (mir fällt zurzeit Pluigin ein) kannst du sicherlich lcoker verzichten.... ungepflegte Sachen hält man nicht!

    Viel Glück bei der Dienstleister suche!

    ralf

    Hallo, habe auf wp 3-4-2 upgedated

    wie?


    und erhalte Serverfehler http 500, bin ... bei ... netclusive.

    wie ist PHP konfiguriert. (als CGI oder Modul im WebServer, welche PHP Version...


    Der Adminbereich funktioniert.

    wp-config wurde nicht überschrieben - schon mal gut. den Debug Modus von Wordpress schon einmal eingeschaltet?


    Kann mir jemand helfen http://www.fotoblogg-ak.de/

    Tipp: Job Forum ist vorhanden.

    Wenn PHP als CGI im Apache läuft kann eine Leerzeile nach ?> in einer PHP Datei zum 500 führen. Damit man diese Datei findet gibt es im PHP Handbuch http://www.php.net ein Code den man in seine Script einfügen kann und erhält je nach Fehlerkonfiguration eine sinnvolle Meldung zurück.

    Viel Glück

    ralf


    Doch als ich die Plug In's wieder aktivieren wollte, erschien nur noch eine Fehlermeldung
    (Fatal error: Call to undefined function get_front_page_template() in /users/www/meinusername/wp-includes/template-loader.php on line 26)

    Die fehleden Funktion ist in der Datei

    /users/www/meinusername/wp-includes/template.php

    vermutlich ist der uplaod per FTP fehlerhaft erfolgt. oder ein zu großer update sprung? von welcher Wordpress Versioon wolltest du das Update durchführen?

    Was passiert, wenn du die Debug Fuktion in wp-config.php einschaltest...

    viel Glück

    ralf


    nun habe ich gehoert, das man bei einer auf linux basierenden wordpress installation, php schadcode ganz einfach ausfuehren kann. mir wurde gesagt, das man dadurch dateien auf den wp server hochladen kann und noch schlimmer..

    das rechte system soll dabei eine rolle spielen.

    Du wirst in der Regel von deinem Provider kein abgesichertes System erhalten. D.h. du must dich auch (zuerst) mit der Sicherheit deines System beschäftigen.

    Es gibt entsprechende Bücher, Foren und Anleitungen.

    Solltest du kein entsprechendes Wissen verfügen - Finger Weg vom Server - und miete einen managed server
    Zum Beispiel
    http://www.df.eu/de/server-host…aged%2520server

    Wer PHP Anwendungen abgesichert auf einem Server betreiben möchte - muss leider auch über sehr gute PHP Kenntnisse verfügen. ein Pluigin in der Anwendung reicht hier nicht aus. Wer dies glaubt kennt die PHP Probleme nicht.

    Hier zum Beispiel
    http://www.heise.de/security/meldu…it-1618687.html

    oder zuletzt im Mai
    http://www.heise.de/security/meldu…en-1570510.html


    Wenn man nun auf seinem einen Server alles absichert hat - muss man sich auch mit der Absicherung von Wordpress beschäftigen.
    Hier die bekannte Sicherheitslücken
    http://www.exploit-db.com/search/?action…ption=wordpress

    Hier beim letzten Punkt kannst du hier im Forum -über das Job Forum- dir Dienstleister suchen, die dir deine Installation absichern.

    Viel Glück

    ralf


    leider kann ich nicht mit einem phperrorlog dienen, da das serverseitig ausgeschaltet ist.

    Warum schaltest du es nicht ein?

    zum Beispiel, wenn ini_set erlaubt ist

    PHP
    ini_set('error_reporting',E_ALL & ~E_NOTICE);
        ini_set('display_errors',0);
        ini_set('log_errors',1);
        ini_set('error_log',  '/dein/pfad/auf/dem/server/zu/einem/Verzeichnis/logs/php_error.log');

    Dein Server sendet diesen Header

    mmh...


    Zitat

    ass ich meine seite über http://www.passioninterior.de erreiche sondern nur über passioninterior.de

    dies kann sinnvoll sein, da es doppelten Content verhindert. deine Seite http://www.passioninterior.de leitet auf passioninterior.de weiter. ob dies jetzt 301 ist habe ich nicht geprüft.

    Zitat


    gelegentlich kommt es außerdem auch im backend (zum beispiel beim posten von artikeln zum whitescreen)

    du verwendet varnish

    wenn deine PHP/5.3.16 als CGI läuft kannst du evtl. mit http://php.net/manual/de/function.headers-sent.php
    prüfen ob ein leere Zeile nach einem Datei- Ende mit ?> das Problem ist.

    Die Theme scheint auch etwas veraltet..

    Viel Glück

    ralf


    Verstehe leider nicht ganz was du meinst.

    Konfiguration von zum Beispiel gd-lib und hier die Erweiterung die für png oder jpg usw....


    Error Log ist leer.
    memory_limit 45M 45M

    bei nur 45M stimmt etwas mit deiner error-Log Konifiguration nicht. mit 45 M hast du leider nicht nur ein ein Bild upload Problem. Deine Bilder sind vermutlich viel zu groß für den kleinen Speicher.

    define('WP_MEMORY_LIMIT', '256M');

    in die wp-config eintragen... evtl. darfst du ja den Wert ändern... Wenn nicht, musst du dich an deinen Provider wenden...

    hallo,
    bekomme ich die Fehlermeldung HTTP Fehler. Das Bild befindet sich dann zwar in der Mediathek, hat jedoch eine Größe von 0x0. Ich habe auch schon ein Update von WP auf 3.4.1 duchgeführt, in der Hoffnung, dass das Problem verschwindet, leider vergebens.

    Kann man die Bilddatei auf dem lokalen Rechner mit Gimp öffnen? Dh. ist die Bilddatei nicht von einem fehlerhaften Bildbearbeitungsprogramm beschädigt worden?

    Wie soll Wordpress die Bilder bearbeiten. gd-lib usw. Wenn ja welche Version? (bitte passend zum Bildformat). bei png auch die Information ob alphakanal verwendet wird. Wie wird übertragen (flash? evtl. ändern - je nach verwendetem Plugin)

    Was steht in der Error Log vom Server?


    Kann ich jetzt einfach alles via ftp löschen

    Warum möchtest du die Grafiken und Bilder löschen? benötigst du diese nicht mehr?

    man löscht
    ~/wp-admin
    ~/wp-includes

    prüft aber vorher
    * welche Pluigns unter der zukünftigen Version nicht funktionieren könnten
    * und welche besonderheiten bei den Themes besteht.


    sowie den export, sowie die datenbank gesichert),

    Wie wurde die Datenbank gesichert - es gibt leider einige PHP Basierte Datenbanktools, die behaupten, sie hätten gesichert - haben sie aber in der Regel alllerdings leider nicht richtig. Zu diesen Tools zählt leider auch phpmyadmin. Damit sicherheit man nicht!

    Dh. prüfe, ob deine Sicherung auf einem lokalen System installierbar ist und alle Daten enthält.


    die Benachrichtigung vom Provider abwarten und dann neu installieren? Ich könnte dann vom Provider her direkt WP 3.3.2 installieren...

    dann würde ich mir gleich einen anderen Provider suchen - sorry - wer installiert bei den Sicherheitsbedenken jetzt noch eine veraltete Wordpress Version. finger weg - auch von 3.3.2


    empfehlt Ihr mmir eher diesen Weg und danach ein Upgade auf 3..4.1 oder soll ich direkt selber 3.4.1 installieren?

    Dein Provider soll seine Umgebung auf den aktuellen Stand bringen - wenn danach noch deine Wordpress Version läuft ein update nach der Anleitung durchführen (von dieser Seite verwenden)


    Lasse ich die Datenbank in php admin so drin oder sollte ich die auch vor dem Versionswechsel löschen und später wieder einspielen(habe hier auh eine sicherung gzip. gemacht)

    Warum möchtest du eigentlich immer löschen? Im Update - werden alte Dateien selbstverständlich gelöscht. ich lösche in der Regel
    bei so einem Sprung erst viel, sehr viel später - wenn ich die Dateien auf dem Server aufräume...

    Wenn du dir nicht sicher bist - beauftrage doch über das Jobforum hier einen Dienstliester - am besten den, der meint, man könnte Wordpress in 5 Minuten installieren :)

    [QUOTE=buss90;455043

    [CODE]
    $wp_query= null;
    $wp_query = new WP_Query();
    $wp_query->query( array( 'category__and' => array( 429, 1335 ), 'showposts=5'.'&paged='.$paged));
    [/QUOTE]

    dafür steht dir query_posts zur Verfügung

    PHP
    query_posts( array( 'category__and' => array(429,1335), 'posts_per_page' => 5, 'orderby' => 'title', 'order' => 'DESC' ) );

    http://codex.wordpress.org/Function_Reference/query_posts

    hth

    ralf


    Ich habe ein Blog, das von Seiten des Hosters (Host Europe) migriert wurde - danach hatte ich etliche Fehlermeldungen und riesige Probleme.

    Host Europe hat augenscheinlich ein merkwürdiges PHP für ihre Kunden installiert und muss vor diesem Hintergund merkwürdiges in den Scripten eintragen, damit diese auf ihren Servern läuft.

    Ergo: zuerst einmal die Anleitung von Host Europe besorgen, wie was an Wordpress geändert werden muss, damit es funktioniert.


    War eh ein olles 2.x-Wordpress

    Die Version ist wichtig, wenn du die Daten noch retten möchtest. Du kannst mit der db Version die verwendete Wordpress Version finden

    http://codex.wordpress.org/WordPress_Versions


    und ich müsste nun einiges von Hand in die diversen Config-Dateien eintragen.

    Und was müsstes in die diversen Config-Dateien eintragen?


    Sinnvoller wäre also wohl das Ganze neu aufzusetzen und die Plugins neu zu machen.

    Warum sollte dies sinnvoller sein? Musst du dann nicht einiges von Hand in die diversen Config-Dateien eintragen?.


    Das Gute: Die SQL-Datenbank mit den Einträgen seit 2003 ist noch da und scheint unangetastet zu sein. Kann ich die irgendwie retten (Backup habe ich gemacht) und ist es sinnvoll, den gesamten Kram zu löschen und einfach das Ganze neu einzuspielen? Da kommt dann allerdings wenn ich die wp-install.php aufrufe dummerweise der Hinweis, dass ich alle Einträge meiner DB löschen soll, was ich natürlich nicht will.

    Wenn du sicher bist, dass du die Datenbank mit allen Datensätzen von dir wiederhergestellt werden kann (d.h. nicht mit PhpMyAadmin von dem Hoster gesichert) - warum nicht das upgrade skript nicht starten?


    Im Moment kommt nur die übliche "Internal Server Error" und ein zusätzlicher 500er Error.

    Den Support vom Hoster anrufen! Wenn alle Ihre Hoster wegen "Internal Server Error" anrufen würden, würden die fastcgi installationen von PHP vermutlich verschwinden....


    Bin leider nicht der große Admin und war froh, dass das Ganze lief, wesegen ich auch seit mindestens drei Jahren nicht mehr WP aktualisiert hatte. Das rächt sich nun.

    Es gibt Dienstleister, die dies für dich machen können.


    Kann man eine existierende Datenbank (nur per "Export" exportiert) in ein neu aufgesetztes Blog einfließen lassen? Hätte noch eine zweite leere DB übrig... danke für Eure Tipps.

    Wenn Wordpress funktioniert, stellt Wordpress dafür selbstverständlich Werkzeuge zur Verfügung. Aber bei dir kommt ja nur ein 500er Error....

    Ergo. aktuelle Version besorgen - die wp-config nicht überschreiben - und alle anderen PHP Dateien von Wordpress überschreiben und das Upgrade Script aufrufen - wenn du glück hast... wenn nicht ... hier gibt es ein job forum.

    viel Glück

    ralf


    Ich bin mir nicht sicher was gerade passiert ist, aber ich wollte ein Backup meiner Seite erstellen und hab dazu die f.a.q meines providers (strato) benutzt und jetzt ist aus diversen gründen nichts mehr vorhanden? oder doch??

    Hat der Massenhoster seine FAQ offen und kannst du mal einen Link veröffentlichen?


    Folgendes hab ich gemacht. Via ftp: Backup.strato.de aufgerufen und Ordner .Backup.01 runtergeladen und wieder hochgeladen, wie bei strato beschrieben.


    klingt wild und irgendwie fehlt mir da etwas ...



    Meine Seite wieder aufgerufen und diesmal sollte ich wordpress installieren??

    Bin dann wieder in den ftp client und hab nachgeschaut was da los ist. Alles Dateien sind immernoch vorhanden, wordpress ist installiert. Hab zwar nicht verstanden wieso ich wordpress nochmal installieren soll, hab es aber gemacht. Jetzt hab ich wordpress, so wie man es kennt wenn man es grade neu installiert hat aber alles andere ist weg bzw. wird nicht angezeigt???

    Und dies klingt so, als ob du deine vorhandene Wordpress installation mit einer *neuen* leeren Wordpress Version überschreiben hast. Bei *überschreiben* meine ich die Datensätze in der Datenbank.



    Alle Dateien incl. themes, plugins einfach alles wird ignoriert? Ist aber auf dem server vorhanden!?

    Wordpress benötigt die Datensätze aus der Datenbank.



    Hab bei strato schon angerufen, die Dame hatte nicht wirklich Ahnung an was das liegt und war nicht wirklich hilfreich.

    Ruf die Dame noch einmal an - und bitte darum, dass Sie den Zustand von _gestern_ abend für dich wiederherstellen .
    Provider können dies - ob dies Massenhoster machen - kann ich dir leider nicht sagen.

    Viel Glück


    ralf