Nun habe ich das Problem, dass beim Anklicken mancher Seiten ich immer auf folgende Seite geleitet werde:
Nimm mal den LInk hier raus, die Seite verteilt Schadecode!
Um schreiben oder kommentieren zu können, benötigen Sie ein Benutzerkonto.
Sie haben schon ein Benutzerkonto? Melden Sie sich hier an.
Jetzt anmeldenHier können Sie ein neues Benutzerkonto erstellen.
Neues Benutzerkonto erstellenNun habe ich das Problem, dass beim Anklicken mancher Seiten ich immer auf folgende Seite geleitet werde:
Nimm mal den LInk hier raus, die Seite verteilt Schadecode!
ich hab ein Problem mit dem Mediacenter (WP 3.8). Wenn ich unter einer meiner Domains was Uploaden will (egal ob Bild oder Video), kommmt "HTTP-Fehler" und das wars. Gehe ich aber dann raus und nochmal ins Mediacenter rein, liegt das Bild da drinnen (nur ohne kleines Thumbnail).Ich hab ne WP 3.7 in ein Unterverzeichnis installiert um es auch nochmal auszuprobieren. Dort ists genau so.
Ich hab meinen Server von PHP 5.3 auf 5.4 und zurück gesetzt, um zu sehen obs daran liegt. Tuts nicht.
Für die Thumbnail Erstellung aus einem Bild benötigst du auf deinem Server (für PHP) die gd-lib
http://php.net/manual/de/book.image.php
ist diese Vorhanden?
Wenn ja - auch für das gewünschte Bildformat (gif, png, jpg)? Wie groß ist das Bild? Hast PHP genug Zeit für die Berechnungen und
ausreichend Speicher? mit kleinen Bildern 700 x 700 px zum beipsiel im jpg mal prüfen...
hth
ralf
Mit WP Security sieht man auch, dass innerhalb einer Nacht mindestens 4 LOCKOUTS stattgefunden haben, d.h. meine Seite ist permanent under attack.
nur 4? und du redest von "unter feuer"?
Wenn nur du oder dir bekannte Autoren auf deinem Blog Zugriff auf den Admin haben sollten, könntest du den Admin-Bereich
mit HTTP-Authentifizierung schützen.
Was ist HTTP-Authentifizierung?
http://de.wikipedia.org/wiki/HTTP-Authentifizierung
Wie du dies bei dir einrichtest, erklärt dir dein Provider.
Ist mein WP selbst schon derart korrumpiert und muss komplett neu augesetetzt werden?
Frage, gibt es einen Benutzer: Admin? und hat dieser Benutzer die ID 1? Und ist dein Blog im März, April 2012 so online gegangen? Dann hast du vermutlich seit Monaten einen Gast in deinem System.
Such dir über das Job-Forum jemanden, der dein System prüft - und dir sinnvolle Nachrichten von deinem System zur Verfügung stellt. (mindestens 4 LOCKOUTS stattgefunden - macht nur nervös - bringt aber nichts) Mich interessiert zum Beispiel in der Regel nur
a- welche Dateien sind neu auf dem Server
b- welche Dateien wurden in den letzten 24 Stunden geändert
c- welche Dateien wurden in den letzten 24 Stunden gelöscht.
d- evtl. unter welchem Link wurde eine SQL-Injection versucht
http://de.wikipedia.org/wiki/SQL-Injection
Als Gegenmaßnahmen habe ich zur Zeit GOTMLS-Plugin und All in One WP Security installiert.
Mit einem PHP Script möchtest du Schadecode finden und deine Seite in Quarantäne schicken? mmh... gewagt und sehr mutig.
Ich betrachte bereits PHP als Problem. Egal.
Google stellt Informationen zur Verfügung - wenn man sich keinen Profi leisten möchte
[h=1][size=10]Verhindern einer Malware-Infektion[/SIZE][/h]https://support.google.com/webmasters/answer/163635
cu
Ralf
Ich habe eine WP Seite die zu Zeit auf der IP http://134.255.239.66 läuft.
Da ich aber eine Domain habe, wollte ich dies auch benutzen.In kis.hosteurope wurde die AutoDNS bearbeitet. So das wenn man http://www.angry-mob.de eingibt automatisch auf die IP weitergeleitet wird.
Eine Domain wird nicht weitergeleitet sondern zeigt auf eine IP oder wird aufgelöst
http://de.wikipedia.org/wiki/Domain_%28Internet%29
Deine Domain ist mit der IP 134.255.239.66 gebunden.
PING angry-mob.de (134.255.239.66) 56(84) bytes of data. ---
64 bytes from 134.255.239.66: icmp_seq=1 ttl=54 time=5.75 ms
64 bytes from 134.255.239.66: icmp_seq=2 ttl=54 time=5.71 ms
64 bytes from 134.255.239.66: icmp_seq=3 ttl=54 time=5.71 ms
64 bytes from 134.255.239.66: icmp_seq=4 ttl=54 time=5.95 ms
Du verwendest
Apache/2.2.16 (Debian)
und Port 80 ist auch offen.
Vermutlich ist der V-host vom Apache nicht richtig konfiguriert:
http://httpd.apache.org/docs/2.0/de/vhosts/
Beispiel
# Ensure that Apache listens on port 80
Listen 80
# Listen for virtual host requests on all IP addresses
NameVirtualHost *:80
<VirtualHost *:80>
DocumentRoot /www/example1
ServerName http://www.angry-mob.de
# Other directives here
</VirtualHost>
ich hoffe, die Antwort hilft dir weiter
ralf
Ich habe mir ein Theme gekauft, welches in einem Unterverzeichnis als "Landing Page" oder "Coming Soon" Page dienen soll...
Und der Verkäufer hat keinen Support und du bekommst dein Geld nicht zurück?
Ich habe 2 gekaufte und 1 Theme von einem Kollegen, welches noch nicht benutzt wurde.
gut zu wissen ![]()
Ganz egal welches ich per ftp in das richtige Verzeichnis lege...es kommt IMMER die Fehlermeldung, dass die style.css fehlt...
Wordpress erwartet bei einem Template / theme in dem Verzeichnis
~/wp-content/themes/_dein_skin_/
eine style.css
Ich habe mir ein Theme gekauft, welches in einem Unterverzeichnis als "Landing Page" oder "Coming Soon" Page dienen soll...
Wordpress kennt kein Unterverzeichnis! Du kannst eine Seite erstellen
http://www.example.org/dein_Verzeichnis_warum_auch_immer/
Bei der Erstellung der Seite, wählst du bei der Text-Erfassung rechts aus dem Pulldown-Menue unter Template dein Page-Template aus.
Damit Wordpress das Template für die Landing Page findet, muss du dieses nach
~/wp-content/themes/_dein_skin_/
kopieren. Lege hier kein neues Verzeichnis an, sonst findet Wordpress das Template nicht.
Hoffe die Antwort hilft dir weiter
ralf
Ich erhalte bei der Installation von manchen Plugins folgende Fehlermeldung:"Warning: Invalid argument supplied for foreach()
Was hat das zu bedeuten und wie läßt sich das Problem beseitigen ?
Du prüfst einfach im Script, ob der Inhalt ein Array ist.
in deinem Script steht zum Beispiel
Daraus machst du:
ich würde vermutlich von den Plugins auch Abstand nehmen
Ralf
Da schon etliche Jahre Arbeit in dem Blog steckten, hab ich versucht, über Strato ein Backup zu ergattern, denn mein Missgriff ist nun grad eine Woche her. Aber Strato sagt, die automatischen Backups, die dort gespeichert werden, sind alle gelöscht, sobald ich ne neue Datenbank anlege.
Bitte Strato umgehend noch einmal den Zustand von der WebSite von vor einer Woche herzustellen. Dateien und Datenbank! Das Backup wird nicht durch die Erstellung einer neuen Datenbank gelöscht sondern durch die Zeit. D.h. nach x- Tagen wird das Backup durch ein neues Backup gelöscht. Vor diesem Hintergrund solltest du dich umgehend an den Support wenden.
Es gibt kein Backup - System, dass durch die Erstellung einer neuen Datenbank gelöscht wird. Sollte das System bei Strato chaotisch konfiguriert sein, benötigen Sie evtl. aus einer alten
~/wordpress/wp-config.php Deine alten Zugangsdaten:
D.h. diesen Bereich
/** MySQL Einstellungen - diese Angaben bekommst du von deinem Webhoster. */
/** Ersetze database_name_here mit dem Namen der Datenbank, die du verwenden möchtest. */
define('DB_NAME', '');
/** Ersetze username_here mit deinem MySQL-Datenbank-Benutzernamen */
define('DB_USER', '');
/** Ersetze password_here mit deinem MySQL-Passwort */
define('DB_PASSWORD', '');
/** Ersetze localhost mit der MySQL-Serveradresse */
define('DB_HOST', '');
/** Der Datenbankzeichensatz der beim Erstellen der Datenbanktabellen verwendet werden soll */
define('DB_CHARSET', '');
/** Der collate type sollte nicht geändert werden */
define('DB_COLLATE', '');
Alles anzeigen
Viel Glück
Ralf
Hallo,
Nun unser Problem. In Tunesien haben wir einen sehr schlechte Internet Infrastruktur daher will ich unsere Seite http://www.tuareg-live.com lokal mitnehmen. Auf was für einer Platform (Hardware und Betriebssystem) sollten ich das WP aufsetzen?
ich habe unter Windows mit einer Xampp Umgebung recht gute Erfahrungen
http://www.apachefriends.org/de/xampp.html
Wenn man noch keine Erfahrung von Linux hat würde ich evtl. openSUSE mit Handbuch empfehlen
http://www.edv-buchversand.de/suse/url.php?cnt=home&act=1
Wer Lizenzkosten sparen will oder jenseits von Standardlösungen eine Infrastruktur aufbauen möchte, die sich sehr stark an die individuellen Bedürfnisse anpassen lässt, der sollte kostenlose Standard-Distributionen wie CentOS, Ubuntu Server oder Debian einsetzen.
Generell ist CentOS eine gute Empfehlung. CentOS ist binärkompatibel zu RedHat-Linux und gilt als äußerst stabil. Wer daran denkt, später einmal Produkte einzusetzen, die nicht im Source-Code verfügbar sind, kann alle Binaries für RedHat auch auf CentOS ausführen. Wer das höchste Maß an Modularität sucht, sollte Debian verwenden.
wir haben so rund 400 Zugriffe täglich davon 200 innerhalb einer 1/2 Stunde während der abendlichen Fahrerbesprechung.Da wir eine Amateur Veranstaltung sind und ist unser Budget eher klein. Ich hab noch einen Panasonic Laptop mit XP und oder ist windows nicht so geeignet?
Dem Laptop fehlt sicherlich eine Netzwerkkarte?
Hier eine Anleitung, wie man ein LAN - Netzwerk aufbaut
http://www.feierabend.de/Leben/Computer…inden-18025.htm
Viel Spass bei der Rallye
Ralf
Hallo,
//
url:'[COLOR=#000080]<?php echo admin_url('admin-ajax.php'); ?>[/COLOR]',
lege aus Sicherheitsgründen deine Scripte in ein Plugin Verzeichnis und vermeide
den Zugriff vom Blog auf den Dashboard.
Es gibt in der Regel eingentlich auch fertige Plugins, die dies können.
Neues Problem:
sobald ich versuche auf die admin-Anmeldeseite zu kommen ([domain]/wp-admin), werde ich komischerweise
auf die alte Domain des Gratis-Providers weitergeleitet.
Die Adresse und der Pfad zu deiner Installation stehen in der Datenbank. Ändere die Einträge. In der Datenbank stehen auch die Links zu deinen Seiten und Artikel. Ändere auch hier eben die URL.
Das Komische ist jetzt nur, dass ich jetzt das gleiche Problem bei dem Support.wordpress.com-Link habe, den du hier angibst. Folgende Fehlermeldung kommt: "Der Server unter de.support.wordpress.com braucht zu lange, um eine Antwort zu senden."
nö - der Link
http://de.support.wordpress.com/com-vs-org/
funktioniert hier bei mir ohne Probleme.
cu
ralf
Hallo,
Rechts davon möchte ich in einem eingebundenen PDF-Reader die Anleitung, welche als .pdf vorliegt anzeigen und zum Download anbieten.
dies ist auch bei anderen CMS - Systemen ein kleines Problem. Ich bin den Weg über eine Flash-Lösung gegangen.
Der "eingebundenen PDF-Reader" war / ist kostenpflichtig und zur HTML5 Lösung kann ich noch nichts sagen.
Aus dem "eingebundenen PDF-Reader" habe ich mir dann ein Wordpress Plugin erstellt.
cu
ralf
Problem:
Nachdem ich die Dateien auf den neuen Server geladen habe und die Domain registriert war, habe ich gleich versucht darauf zuzugreifen ([meinedomain]/wp-admin). Leider kam da schon die erste Fehlermeldung: 403 Forbidden Data usw. Danach erstmal mit Berechtigungen (.htaccess-Datei, 777, 755, etc.) rumprobiert und siehe da: Eine neue Fehlermeldung!
Nämlich folgende:
Warning: require(/www/htdocs/w0115d98/wp-includes/load.php): failed to open stream: No such file or directory in /www/htdocs/w0115d98/wp-settings.php on line 21
Die Datei /www/htdocs/w0115d98/wp-includes/load.php sollte lesbar sein. d.h. chmod 644 rw- r-- r-- Verzeichisse haben bei mir 755 rwx r-x r-x rechte.
und was hast mit der .htaccess gemacht?
habe snitch installiert. Wie kan ich sehen welche Abfragen nicht OK sind? wonach muss ich suchen?
die, dir dir nicht geheuer sind..., die, die nicht antworten... die, die man nicht verwenden darf, ... die suchen, die den fehler verursachen könnten.
die, die beim editeren eines Beitrages wild duch die Gegend Verbindungen aufbauen...
das ist meine conf im Moment. Ich bekomme den error ja auch schon wen ich nur einen text auf de Seite verändere!
aber eben erst seit dem ich online bin.
Active Plugins
- Akismet 2.5.9
- All In One SEO Pack 2.1
- Fast Secure Contact Form 4.0.18
- Google Analyticator 6.4.5
- Google XML Sitemaps 3.4
- Hupso Share Buttons for Twitter, Facebook & Google+ 3.9.23
- NextGEN Gallery 1.9.13
- qTranslate 2.5.38
- UpdraftPlus - Backup/Restore 1.8.2
- WordPress Importer 0.6.1
Ich kenne nicht alle Plugins - du kannst aber mit
http://playground.ebiene.de/snitch-wordpress-netzwerkmonitor/
prüfen, welches Plugin ausgehende Verbindungenaufbaut. oder einfach dir - wie schon vorgeschlagen ansehen, welche Datenbank-Abfragen dein Template so erzeugt. Ich vermute in dem Template den Fehler.
cu
ralf
Habe folgende Meldung in de Apache2 error.log wen das passiert:
[Tue Dec 10 19:44:23 2013] [error] [client 213.204.207.140] PHP Fatal error: Maximum execution time of 120 seconds exceeded in /var/www/sdtours/wp-includes/functions.php on line 336, referer: http://www.sdtours.net/wp-admin/post...edit&message=1
Deine Server Konfiguration scheint ja in Ordnung zu sein. Evtl. greifst du in der akteullen PHP Version 5.5.7 mit PHP mysql zu. Wenn du keine aktuelle PHP version verwendest, mach ein update.
Ich verwende hier im Apache 2.4.x und php 5.5.x http://wordpress.org/plugins/mysqli/
Wenn du keine aktuelle PHP Version verwendest, mach ein update.
Deine Theme hat einige serverlastige Aktionen auf Lager. Du kannst mit dem Pluignin Debug Queries von Frank Bültge
http://bueltge.de/wordpress-perf…ren-plugin/558/
dir deine Datenbank-Aktionen ansehen.
PHP Fatal error: Maximum execution time of 120 seconds
Holst du irgendwelche Inhalte über eine Socket-Verbindung? erhöhe einfach die ausführbare Zeit? Kann ja möglich sein, dass du SEO-Optimierung oder Tag-Wolken so erweiterst.
define('WP_SITEURL', 'http://www.deine-richtige-adresse.xyz');
define('WP_HOME', 'http://www.deine-richtige-adresse.xyz');In meinen Wordpress Einstellungen sind diese nun grau hinterlegt.
Bei einem Update sind diese Inhalte auf der wp-config.php nicht mehr vorhanden und
meine Seite ist "kaputt" wie oben beschrieben.Kann ich etwas tun, damit ich nicht nach jedem Update wieder die neuen URLs
in die wp-config.php eintragen muss und meine Seite nicht jedesmal mal "kaputt" aussieht?
http://www.deine-richtige-adresse.xyz dafür gibt es http://example.org/
unter ...
http://example.org/wp-admin/options-general.php
kannst die daten erfassen. Sollte diese URL für dich auch nicht erreichbar sein - kannst du mit PHPMyAdmin in der Datenbank die Daten ändern.
cu
ralf
hab mir gerade 2 tutorials dazu angeschaut und jetzt habe ich nur ein blödes PRoblem: ich soll in der .htaccess Datei was ändern und ich finde die nicht! Kann mir da wer weiterhelfen? Habe schon gesucht, nix angezeigt - Hiiiilfe
Wenn du sinnvolle Permaments verwendest - soltle eine .htaccess vorhanden sein.
Im FTP-Cleint kannst du dir *versteckte* Dateien im verzeichnis auf dem Server anzeigen lassen.
Sollte wirklich keine .htaccess auf dem Server vorhanden sein, kannst du diese mit einem normalen Editor auf deinem Rechner erstellen und mit dem FTP-Programm übertragen.
Und ich finde auch keinen Hinweis darauf, dass mein Provider Flash generell verbietet.Unfassbar! Komme da einfach nicht weiter...
Und warum fragst du deinen Provider nicht? Verwendest du einen kostenlosen WebSpace?
Permission denied
Fehler: Kritischer Dateiübertragungsfehler
Wenn dies die Meldung von einem richtigen FTP-Cleint ist solltest du dich wirklich an deinen Provider wenden. Vor evtl. noch prüfen, ob andere Datei-Formate (.php .jpg .png) funktionieren.
Bei einigen Providern trägt man FTP-Zugangsdaten in die wp-config.php ein. hier könnten Probleme auftreten, wenn PHP kein FTP kann oder die falschen Zugangsdaten hinterlegt sind. Aber auch im FTP-Cleint können fehlerhafte Zugangsdaten zu Fehlermeldungen führen.
Ich würde den Provider fragen
cu
ralf
Ich habe eine Theme installiert und auch darin Veränderungen vorgenommen. Nun möchte ich aber alles wieder auf dem Ausgangszustand zurücksetzen.
Die Datensicherung zurück spielen. Evtl. stellt dir dein Provider eine entsprechende Daten-Auswahl zur Verfügung.
Oder Wordpress neu installieren.
Ich hatte auch schon das Theme gelöscht, aber wenn ich es neu installiere sind meine Inhalte auch wieder da.
Man kann auch alle Seiten und Beiträge über den dashboard leicht löschen.
Wenn du einen wichtigen "Ausgangszustand" hast, solltest du meiner Meinung nach eben eine Datensicherung von der Datenbank pp und deinen Dateien erstellen. Ich verwende hierfür mysqldumper - dies läuft auch bei Massenhsotern und wurde wegen diesen auch entwicklet.
Damit wird zukünftig "zurück zum Ausgangspunkt" zumindest etwas leichter
cu
Ralf