Vor kurzem habe ich ein Update gemacht, das bei der Installation einer neuen Pluginversion abgebrochen ist. Ich bekam dann immer nur eine white page.
Plugin update oder Wordpress update oder Theme update?
Also habe ich den Pluginordner umbenannt und der Blog lief wieder.
mutig - wie kommt man auf solche brutalen Sachen? Und warum sollte jetzt der Blog _laufen_? Alle Plugins werden nicht mehr gefunden, verwendete Shortcodes funktionieren nicht - alle Seo Optimierungen über Plugins sind hin - und alle Content Erweiterungen über Plugins sind nicht mehr funktionsfähig... soetwas nenne ich sicherlich nicht laufen... sondern mutwilliges zerstören.
Seitdem kann ich mich aber nicht mehr in den Adminbereich einloggen, da ich immer einen 500 Internal Server Error bekomme.
Dies ist ein „Sammel-Statuscode“ für unerwartete Serverfehler. Wende dich an deinen Provider. Dieser schreibt:
http://strato-faq.de/article/1377/H…P-Scripten.html
/*
Dieser Fehler erscheint, wenn die Zugriffsrechte falsch bzw. nicht gesetzt sind oder wenn sich eine "php.ini"-Datei im Hauptverzeichnis befindet.
*/
ich kenne zwar andere Gründe - aber wer bei Strato ist - muss damit halt rechnen.
Nun gibt es im Netz diverse Lösungsvorschläge von denen aber keiner für mich funktioniert. Ich habe bereits folgendes probiert:
- manuelles deaktivieren der Plugins
- erhöhen des php memory limits durch php.ini
- umbenennen der htaccess datei
- ersetzen der ordner wp-admin und wp-includes mit neu heruntergeladener version
- definition der php version in der htaccess
Alles anzeigen
sorry - da kannst du auch dein Auto waschen, weil es regnet.
Nach diesem rummfummeln würde ich den ursprünglichen Zustand über ein Backup herstellen.
Ich bin bei Strato und nutze PHP5.5.
und deine Theme und dein Plugins kommen mit PHP 5.5.<zahl fehlt natürlich> klar?
Manchmal erscheint anstatt des 500 Errors auch eine Aufforderung die Datei wp-login.php runterzuladen.
dann kann dein Sever kein PHP mehr... vermutlich kommt der Fehler nach dieser aktion: definition der php version in der htaccess
Merkwürdig ist auch, dass ich php-login.php aufrufen kann, wenn ich in der adresszeile des browsers ein www. vor die adresse schreibe.
www. ist eigentlich Teil einer gültigen Adresse.
Gebe ich dann aber meine Daten ein und will mich einloggen, dann kommt statt des Adminbereichs wieder der 500 Error oder die Aufforderung wp-admin.php runterzuladen.
dies würde mich nerven... aber wenn man die htaccess mal eben unbennt - sollte dies doch nicht wundern? In der htaccess werden in der Regel die Permament Links von wordpress aufgelöst und Weiterleitungen zur Vermeidung von doppeltem Content eingerichtet. Die Datei ist super wichtig für Wordpress und den Webserver und sollte man maxiaml verändern aber nicht entfernen.
wenn du kein Backup hast, mche mal deine Änderungen rückgängig:
- manuelles deaktivieren der Plugins
- erhöhen des php memory limits durch php.ini
- umbenennen der htaccess datei
- ersetzen der ordner wp-admin und wp-includes mit neu heruntergeladener version
- definition der php version in der htaccess
und trage in die wp-config.php den debug-modus von false auf true und wirf einen Blick in die error log datei vom webserver.
und wende dich an den support von deinem provider - du hast zurzeit ein chaos angerichtet.
viel glück
ralf