Beiträge von r23

    Leider läuft es auf einer unserer Blogs nicht, der Fehler lautet: "Das Plugin kann nicht aktiviert werden, da es einen fatalen Fehler erzeugt".

    Das Plugin lief nur in Compatible up to: 2.8 und ist jetzt veraltet.

    Der Entwickler von dem kostenpflichten wpSEO war dem Open Source Entwickler von izioseo - Ideenklau damals vor...

    http://playground.ebiene.de/wpseo-wird-beklaut/

    verwende einfach Yoast
    https://yoast.com/wordpress/plugins/seo/

    Kennt jemand weitere Statistiken zu gehackten Internetseiten außer den unten genannten??
    Danke!

    http://www.google.com/transparencyreport/safebrowsing/?hl=de

    Angriffs-Websites 95% am 6/22/14

    wow - ich habe etwas verpasst...


    [h=2]Statistik: gehackte Internetseiten[/h]

    es steht ja google darn - dann muss man sich mit dem sicherlich beschäftigten?

    [COLOR=#ff0000]google ist teil des problems und nicht die lösung[/COLOR]

    meine Empfehlung ist die Sicherheit und nicht die Statistik.

    https://www.allianz-fuer-cybersicherheit.de/


    Das Problem ist, dass PHP versucht, eine Datei auszupacken, die garnicht da ist...

    Warum sollte Wordpress dies freiwillig in einer funktionierenden Umgebung tun?

    Wenn du über update-core.php gehst
    http://example.org/wordpress/wp-admin/update-core.php

    [attach='10663.vB'][/attach]

    klickst du auf aktualiesieren Übersetzungen

    und ohne Probleme bekommst du die Bestätigung

    [attach='10664.vB'][/attach]

    Wordpress sucht [COLOR=#ff0000]keine Aktualisiere Übersetzungen für Akismet (ru_RU)[/COLOR]

    in einer fehlerfreien Umgebung.

    Bilder zeigen 5 Minuten Installation von wp 4.0 de von dieser Seite.

    wenn du gehackt wurdest - klar, dann kennt er deine Sprache vermutlich nicht mehr...


    Es ist PHP 5.3.3 installiert.

    ist veraltet...


    Ich bin bei Hostloco. Hab dort das Gold Packet und meine HP Url ist diese. http://www.freiheitenwelt.de.

    HTTP/1.1 200 OK
    Date: Fri, 17 Oct 2014 22:04:36 GMT
    Server: Apache
    Vary: Accept-Encoding,Cookie
    Last-Modified: Fri, 17 Oct 2014 21:58:16 GMT
    ETag: "5a71-764c2e00"
    Accept-Ranges: bytes
    Content-Length: 23153
    Cache-Control: max-age=3219, public
    Expires: Fri, 17 Oct 2014 22:58:16 GMT
    X-Powered-By: W3 Total Cache/0.9.4
    X-Pingback: http://freiheitenwelt.de/wordpress/xmlrpc.php
    Pragma: public
    Keep-Alive: timeout=4, max=100000
    Connection: Keep-Alive
    Content-Type: text/html; charset=UTF-8
    Content-Encoding: gzip


    Wenn man meint...


    Das Memory Limit hatte ich schon zurückgesetzt. 1. 2. 3. also damit geklärt.

    nicht eine Frage wurde bis jetzt beantwortet:

    Ich würde einfach mal für den Anfang etwas mehr Informationen über das System hier zur Verfügung stellen

    upload_max_filesize =
    [TABLE="class: cms_table"]

    [tr]


    [TD="class: cms_table_number"][/TD]
    [TD="class: cms_table_content"]post_max_size = [/TD]

    [/tr]


    [/TABLE]


    [TABLE="class: cms_table"]

    [tr]


    [TD="class: cms_table_number"][/TD]
    [TD="class: cms_table_content"]max_execution_time =


    php Version [/TD]

    [/tr]


    [/TABLE]


    Bildgröße

    pd lib Version
    oder
    imagick

    Version

    und den Debug mal einschalten.


    Also mit aktiviertem Debugmode hat sich im Browser erstmal nix gezeigt. Die Debug.log hab ich im Ordner Content erstellt. Diese ist aber leer. Schreibberechtigung liegt auf 755 für den ganzen Ordner...

    die Datei muss für PHP beschreibbar sein. chmod 666 ... aber vorsicht - dann darf jeder schreiben.



    Somit -> hat mich leider nicht weiter gebracht...

    Es ist PHP 5.3.3 installiert. Aktuell ist 5.3.29 - ich würde keine Minute länger mich mit dem System beschäftigen. da einfach zu viele bekannte Fehler in PHP sind
    http://php.net/ChangeLog-5.php#5.3.29


    Ich habe PHP 5.3.3

    aktuell ist 5.3.29
    http://php.net/ChangeLog-5.php#5.3.29


    weil ein Update von PHP möglicherweise das System unbrauchbar macht (Plesk).

    dann such dir einen System Admin der dein System auf den aktuellen Stand halten kann. Deine PHP version ist fehlerhaft. die Fehler sind beseitigt.

    Deine Fehlermeldung wird in

    ~/wp-admin/...class-pclzip.php

    erzeugt.

    Für den Anfang würde ich die leere Zeile nach ?> entfernen in Zeile 5687


    Die letzen drei Jahre lief aber alles perfekt.

    Die PHP Umgebung wird in der Regel ständig aktualisiert. Vermutlich hat der Provider eine Version eingestellt. Ein Massenhoster hat vor ein paar Tagen php 5.2. eingestellt - hier gab es einige Problme mit 1und1.

    Bitte die Suche hier verwenden.


    Welche Php Version da läuft kann ich leider nicht abrufen.

    cool -

    du erstellst ein Script - eine Datei - nennen wir diese zum Beispiel php_info.php

    in diese Datei trägst du ein

    PHP
    <?php
    
    
    // Zeigt alle Informationen (Standardwert ist INFO_ALL)
    phpinfo();

    Diese Datei übeträgst du per FTP auf den Webserver und rufst diese im Browser auf:

    http://example.org/php_info.php

    Handbuch
    http://de1.php.net/manual/de/function.phpinfo.php


    Über die WP-config Datein hatte ich versucht das mit der Bildgröße anzupassen. (//define('WP_MEMORY_LIMIT', '64MB');) -> hat aber keine Änderung gebracht.


    Bitte die Änderungen rückgängig machen.
    1 die Angabe MB ist fehlerhaft.
    2. 64 ist viel zu klein.
    3. Wenn du kein Geld für einen Provider hst, darfst du per se diesen Wert nicht ändern.


    Debug einschalten = -> Hmmm - wie wo genau?

    in der wp-config.php

    trägst du ein

    PHP
    // define('WP_DEBUG', true); //enable the reporting of notices during development - E_ALL
    // define('WP_DEBUG_DISPLAY', false); //use the globally configured setting for display_errors and not force errors to be displayed
    // define('WP_DEBUG_LOG', true); //error logging to wp-content/debug.log
    // define('SCRIPT_DEBUG', true); //loads the development (non-minified) versions of all scripts and CSS and disables compression and concatenation,
    // define('E_DEPRECATED', true); //E_ALL & ~E_DEPRECATED & ~

    // ist auskommentiert. wenn du etwas verwenden möchtest musst du // löschen also:

    PHP
    define('WP_DEBUG', true); //enable the reporting of notices during development - E_ALL
    define('WP_DEBUG_DISPLAY', true); //use the globally configured  setting for display_errors and not force errors to be displayed
    // define('WP_DEBUG_LOG', true); //error logging to wp-content/debug.log
    //  define('SCRIPT_DEBUG', true); //loads the development (non-minified)  versions of all scripts and CSS and disables compression and  concatenation,
    // define('E_DEPRECATED', true); //E_ALL & ~E_DEPRECATED & ~

    schaltet den debug ein und gibt evtl. fehlermeldungen an den Browser aus... wenn PHP nichts mehr an den Brower senden kann oder man sieht nichst... schreibt man die Meldungen in eine Datei:

    PHP
    define('WP_DEBUG', true); //enable the reporting of notices during development - E_ALL
    define('WP_DEBUG_DISPLAY', false); //use the globally configured  setting for display_errors and not force errors to be displayed
    define('WP_DEBUG_LOG', true); //error logging to wp-content/debug.log
    //  define('SCRIPT_DEBUG', true); //loads the development (non-minified)  versions of all scripts and CSS and disables compression and  concatenation,
    // define('E_DEPRECATED', true); //E_ALL & ~E_DEPRECATED & ~

    die Log Datei muss für php schreibbar sein... evtl. die rechte pürfen.


    Jemand eine Idee was das sein kann?

    o.k rate ich mal mit

    - Provider hat die PHP version geändert und wichtige funktionen fehlen
    - die bilder sind mega groß
    - kein speicherplatz (webspace ist voll) mehr


    oder
    https://wordpress.org/support/topic/…ia-upload-wp-39

    oder
    http://de.forums.wordpress.org/topic/http-feh…i-bilder-upload

    Ich würde einfach mal für den Anfang etwas mehr Informationen über das System hier zur Verfügung stellen

    upload_max_filesize =


    Bildgröße

    pd lib Version
    oder
    [h=2]imagick[/h] Version

    und den Debug mal einschalten.


    habe WP 4 neu und auf einem frisch installierten System installiert.
    er sagt mir das ich die Sprache Aktualisieren soll. geht nicht also es folgt keine Rückmeldung.
    Wenn ich ein Plugin installiert habe, erscheint weiter unten folgender Text;

    Und PHP hat bei dir Möglichkeit zip Dateien zu entpacken. Wenn ja, welche

    verwendest du in welcher PHP Version....


    Habe seit einigen Jahren meine Webseite in html betrieben.
    Jetzt habe ich in einem Unterverzeichnung Wordpress installiert und meine neue Website fertig gestellt.
    Dann habe ich gelesen, dass ich WP nicht unbedingt in die Root legen muss, sondern im Unterverzeichnis lassen kann ohne Nachteile.
    Habe einfach die index.php in die Root gelegt und meine WP Seite ist online.
    Geht soweit auch alles.

    Ich persönlich mag saubere und klare Strukturen und würde Wordpress nicht in einem Unterverzeichis haben wollen. Aber egal, wenn es bei dir läuft und funktioniert. Ich lege halt Wordpress ins Docroot vom WebServer.


    Meine alten html Seiten werden in google ganz gut gefunden.
    Wenn ich die jetzt lösche ist das sicherlich sehr nachteilig.

    Wenn du diese löscht - erhält Google beim nächsten google crawling eine 404 Meldung und wird die Seite langsam aus den index nehmen ... bis die Seite bei google in der Sichtbarkeit verschwunden ist

    hier gibt es mehr Informationen
    http://static.googleusercontent.com/media/www.goog…optimierung.pdf


    Hab dann "https://wordpress.org/plugins/permalink-finder/" installiert
    Aber ich weiss nun nicht wie ich vorgehen soll und wie ich es einstellen sollte.

    Ich würde das Plugin nicht in der Wordpress Version 3.4 verwenden wollen ... und eine Wp Version 3.5.2 würde ich nicht mehr verwenden. Das Plugin ist veraltet.



    Soll ich meine alten html Dateien auf jeden Fall löschen d.h. meinen ganzen alten Kram erst einmal bzw prinzipiell vom Webspace entfernen?

    Man entfernt keine Dokumente im Web. wirklich nicht ... Wenn die Datei veraltet ist und gelöscht werden sollte... sendet man an den Browser (Besucher kommen über Lesezeichen oder Links)

    ein 410 header // Die angeforderte Ressource wird nicht länger bereitgestellt und wurde dauerhaft entfernt.

    Und wenn der Inhalt in Wordpress zu finden ist.
    eine 301 header // Die angeforderte Ressource steht ab sofort unter der im „Location“-Header-Feld angegebenen Adresse bereit (auch Redirect genannt). Die alte Adresse ist nicht länger gültig.

    oder
    ein 303 header // Die Antwort auf die durchgeführte Anfrage lässt sich unter der im „Location“-Header-Feld angegebenen Adresse beziehen. Der Browser soll mit einem GET folgen, auch wenn der ursprüngliche Request ein POST war.

    oder
    ein 308 header // Experimentell eingeführt via RFC; die angeforderte Ressource steht ab sofort unter der im „Location“-Header-Feld angegebenen Adresse bereit, die alte Adresse ist nicht länger gültig. Der Browser soll mit derselben Methode folgen wie beim ursprünglichen Request (d. h. einem POST folgt ein POST). Dies ist der wesentliche Unterschied zu 302/303

    weitere Informationen über 308
    https://tools.ietf.org/html/draft-reschke-http-status-308-07


    Sollte ich die Dateien lassen und in den html Dateien Umleitungen/Weiterleitungen machen? (eher nicht denke ich)

    eine Umleitung per html ist nicht sinnvoll, da hier ein "falscher" header gesendet wird, den google nicht folgt.



    Oder sollte ich alles alte löschen und über die htaccess bei Fehlermeldungen auf die index.php leiten?

    nein bei einem nicht gefunden sollte der Server einen 404 header senden und bei einem fatal error einen 500 header.



    Oder was macht das o.g. Plugin dann genau.

    keine ahnung, verwende ich nicht.

    Hoffe, die Antwort war für die weitere google Suche hilfreich.

    cu

    ralf

    Hallo,

    Ich habe zwar Sicherungen aber nicht von jedem einzelnen Tag.

    warum nicht? Wie willst du deine Pflichten als Shopbetreiber erfüllen, wenn du keine Sicherungen dem Finanazamt vorlegen kannst?
    Auch bei der Kunden-Kommunikation benötigst du eingentlich auch Datensicherungen. Oder wie machst du dies mit dem Wirderrufsrecht und dem Widerrufsformular? Und wo pflegst du die SEPA Mandate?

    Einmal am Tag sollte ein Shop schon gesichert werden. Such dir einen Provider, der dies macht oder bastel dir eine Lösung mit zum Beispiel Backwpup Pro
    http://marketpress.de/product/backwpup-pro/

    Aber Vorsicht, die Kundendaten haben nichts in der Dropbox verloren.
    http://www.n-tv.de/technik/7-Mill…le13776751.html


    Was macht denn dieser MailPoet genau?.

    Es ist ein Newsletter Plugin und liegt nicht gepflegten gekauften woocommerce Templates gerne bei.

    Golem beschreibt die Situation
    http://www.golem.de/news/angriff-u…407-108088.html
    auch lesenswert:
    http://www.golem.de/news/wordpress…408-108438.html



    Ich bin am überlegen als Vorsichtsmasnahme eine Neuinstallation vom Shop durchzuführen nur das kann ich nur für wordpress und plugins machen.

    Angreifer legen sich Accounts an (dein 1001001 user ohne passwort) Aber in der Regel ändern sie den Code und veröffentlichen sich Tools. Diese können zum Beispiel in Unterverzeichnissen von /wp-content/uploads/..../
    liegen. Hier solltest du die PHP Scripte entfernen und deine PDFs und Grafiken auf Schadecode prüfen.



    Irgendwann muss ich die Datenbank importieren und damit bekomme ich eventuell dann das Problem wieder an Bord. Wie kann ich manuell reinigen in der Datenbank? Nach was muss ich suchen?

    Du kannst den Daten nicht trauen - verwende die Daten aus der Datensicherung.

    Viel Glück

    ralf


    [FONT=Geneva][COLOR=#000000]meinen Freund -dem die Homepage eigentlich gehört, ist mit [/COLOR][/FONT][FONT=Geneva][COLOR=#000000]dieser aussagen nicht zufrieden.
    Habt ihr auch schon mal so ein Problem gehört und was kann ich tun?

    [/COLOR][/FONT]

    Die Plugins sind nicht weg - sondern die Seite ist gehackt worden. Das die Aussagen von dem Provider nicht gefallen kann ich verstehen.

    Der Aufwand von 3 Stunden ist optimistisch geschätzt. Nach der Beschreibung (Plugins weg und keine Datensicherung vorhanden)
    würde ich mit mehr Stunden rechnen.

    Zeitaufwendig ist die Suche der Sicherheitslücke und die Beseitigung.


    [COLOR=#000000][FONT=Geneva]Wiederherstellung der Webseite durch ein Backup aus Ihrem Bestand von vor der Infizierung (scheinbar Mitte 2014)[/FONT][/COLOR]
    [FONT=Geneva][COLOR=#000000][/COLOR][/FONT]

    Ist ein solches Backup vorhanden? und kann man mit dem Datenverlust (auf alle Veröffentlichung ab mitte 2014) leben?

    Viel Glück

    ralf

    Hallo,

    hab ich getestet aber Fehler kommt immer noch sporadisch

    Wordpress bietet wirklich Imagick support an. Es gibt sogar einen class-wp-image-editor-imagick editor. Und damit beginnt auch schon das Drama.


    in Zeile 42 wird geprüft ob

    PHP
    // First, test Imagick's extension and classes.
            if ( ! extension_loaded( 'imagick' ) || ! class_exists( 'Imagick' ) || ! class_exists( 'ImagickPixel' ) )
                return false;
    
    
            if ( version_compare( phpversion( 'imagick' ), '2.2.0', '<' ) )
                return false;

    imagick und in einer aktuellen version vorhanden ist.

    Du verwendest in einer x bit Umgebung von PHP x.y.z eine 3.1.2 Version Imagick. Solltest es Speicherprobleme geben, werden diese unterdrückt:

    Zeile 124

    PHP
    @ini_set( 'memory_limit', apply_filters( 'image_memory_limit', WP_MAX_MEMORY_LIMIT ) );

    das @ verhindert halt Informationen in der Log und ist halt *böse*

    Ich würde vermutlich Imagick mit return false; unter test ausschalten und die gd-lib verwenden. Oder den Speicher erhöhen, da Imagick mehr Speicher benötigt. (dafür sind die Bilder schärfer, schöner, besser...)

    Schade, dass Wordpress Imagick und nicht Gmagick...

    das steht dann in der log:
    libgomp: Thread creation failed: Resource temporarily unavailable

    Verwendest du ImageMagick? Wenn ja Wie und in welchen Versionen?

    Bei 1und1 hilft bei ImageMagick in der wp-config

    PHP
    putenv( "MAGICK_THREAD_LIMIT=1" );

    Aber evtl. verwendest du die original Wordpress Version ohne veraltete Wp Plugins... mit der gd-lib.


    Wie kann ich das reparieren in der Datenbank?
    Welches php-file ist für die Vergabe der IDs zuständig?

    Dies macht MySQL automatisch.

    mySQL Handbuch
    [h=3]3.6.9. Verwendung von AUTO_INCREMENThttp://dev.mysql.com/doc/refman/5.1…-increment.html[/h]
    Du kannst den Wert ändern
    http://www.strassenprogrammierer.de/mysql-autoincr…n_tipp_404.html


    Besser ist ein zurücksichern der Datenbank mit dem letzten fehlerfreien Kunden-Datensatz "Der letzte war 428".

    1001001 wurde gerne bei der MailPoet Sicherheitslücke erzeugt. Hier kannst du per se keiner Datei und keinem Datensatz mehr trauen.


    Stehe da nur ein bisschen auf dem Schlauch, wie finde ich das und wie kann ich so etwas bereinigen ?

    Google stellt sehr gute Informationen über die nächsten Schritte zur Verfügung.
    https://support.google.com/webmasters/answer/163634?hl=de

    Hilfreich könnten die Links über weitere "Hilreiche Ressourcen" sein.


    Mein Problem ist, das seit längerem unsere Website von Virenscanner

    Blick in die Log-Dateien wird etwas umständlich... evtl. findest du deine Sicherheitslücken in einer Exploit Datenbank.

    http://www.exploit-db.com/


    Ich persönlich kann die Website ohne Probleme öffnen

    Da deine Seite Schadecode verteilt, wirst du vermutlich deinen eigenen Rechner verseucht haben.
    http://www.avast.com/de-de/index

    Such dir am besten jemanden, der dir deine Wordpress Version säubert und absichert.

    Viel Glück

    Ralf

    Aber woran kann es sonst liegen?

    Dies steht in der Error - Log Datei von deinem webServer. Wenn du ein Speicherplatz Problem hast steht dort:
    PHP Fatal error: Allowed memory size of xxxxxx bytes exhausted (tried to allocate xxxxxxxx bytes) in /usr/.../blog/wp-includes/ein_script.php on line yyy

    wenn du keinen Zugriff auf eine Error - Logdatei hast - solltest du den Provider wechseln.


    Aber das Problem ist noch nicht gelöst:

    Hast du die Beschreibung von dem Plugin gelesen? Wenn ja - was bitte hast du nicht verstanden? Mit dem Plugin kannst du dir die Übersetzungen erstellen. So einfach ist dies.


    Denn es ist folgendes: ich habe im jeweiligen templates bei wootique die Language-Datei gelöscht

    schön ... und warum erstellst du dir nicht eben neue mit dem o.g. Plugin?


    Woher zieht WP jetzt passende Language-Pack her?

    wenn du diese gelöscht hast - gar nicht.


    mir geht es quasi im Header oben rechts umd die Suchbox da ist noch was englisches drin

    Steht vermutlich in dem Template:
    ~/wp-content/themes/*skin*/header.php

    skin = deine Theme Verzeichnis.