35 MB sollten wirklich dicke reichen für WordPress. Du kannst ja mal das "Memory Usage"-Plugin installieren und schauen, ob WP im Normalbetrieb schon an der Speichergrenze kratzt. Ob das Posten über externe Programme mehr Speicher als der normale WP-Aufruf benötigt, weiß ich nicht, käme mir aber komisch vor. Ausnahme wäre vielleicht höchstens, wenn Du in den Beiträgen riesige Bilder mitschickst. Hast Du denn bei Deinen Versuchen Bilder drangehangen?
Beiträge von Ammaletu
-
-
-
is_home ist true auf der Blog-Startseite, welche die aktuellesten Posts anzeigt. Für eine statische Startseite gibt es is_front_page(). Siehe: http://codex.wordpress.org/Conditional_Tags
-
Wenn die ganze Sidebar weg soll, müsstest Du die sidebar.php des Themes bearbeiten. Wenn nur einzelne Elemente weg sollen, wäre es am besten, wenn Du ein widgetfähiges Theme benutzt, dann kannst Du das im Backend unter Design > Widgets einstellen.
-
Die Frage ist doch, was soll Dein Code tun und wann soll er aufgerufen werden?
-
Zitat
Hat einer von euch noch eine Lösung für mich?
Der nächste sinnvolle Schritt wäre es IMHO, im Error-Log nachzuschauen, was der eigentliche Fehler ist. Error 500 ist nur ein Sammelbegriff für alle möglichen Fehler. Ohne eine genaue Fehlermeldung, wie sie normalerweise in einem Logfile landen sollte, kann man nur raten, und das führt selten wirklich zum Ziel.
-
Zitat
"Streambox" per "Copy 'n paste" - Ja hab es so eingefügt aber wieso wird es in internet explorer richtig gezeigt?
Weil der IE viele Sachen lascher handhabt als der Firefox und andere Browser. Deshalb sollte man auch auf einem standardkonformen Browser entwickeln und dann hinterher schauen ob es im IE geht (und bei Bedarf Fixes speziell für den IE einbauen). Andersrum ist witzlos.

Außerdem sorgen die vielen Bugs des IE manchmal auch dafür, dass etwas richtig angezeigt wird, obwohl es eigentlich kaputt ist.
ZitatAmmaletu -- falsch geschachtelt ?
Ja, es wird ein div-Tag geschlossen, welches nicht geschlossen werden sollte. Soweit ich das sehe, hast Du ganz rechts zwei Text-Widgets. Oben sind zwei Videos drin, unten die Streambox, richtig? Das obere Widget enthält ein schließendes div, obwohl gar kein öffnendes div drinsteht. Das bringt die ganze Sidebar durcheinander. Wäre das Theme an sich valide, hätte der Validator Dir jetzt zwei, drei Fehler angezeigt und man wüsste sofort, wo der Fehler liegt. Bei 93 größtenteil völlig unnötigen Fehlern im Theme muss man sich das einzeln aus dem Quelltext raussuchen.
-
Ok, also nochmal: Wenn Du aufrufst /unterordner/datei-die-existiert, sollte das auch mit der jetzigen Konstruktion schon gehen. Genauso für /unterordner/noch-ein-ordner-der-existiert oder direkt /unterordner. Was nicht geht ist /unterordner/datei-die-existiert/url-parameter, wo dann der URL-Parameter ähnlich wie die Permalinks von WordPress ausgewertet wird, z.B. über eine weitere .htaccess. Aus Sicht von Apache ist das dann keine existierende Datei und der Aufruf geht an WordPress weiter, wo er im 404 mündet (und ich nehme mal an, dass eine 404-Fehler von WordPress das ist, was Du ursprünglich beschrieben hast).
Oben vorgeschlagene Lösung sorgt dafür, dass die WP-Rewrite-Regel nicht angewendet wird, wenn der Aufruf in das zu schützende Unterverzeichnis führt. Das würde WP überschreiben, wenn Du die Permalink-Einstellungen neu abspeicherst, was man ja aber normalerweise nicht so oft macht. Mit etwas mehr Kenntnis der .htaccess-Regeln kann man das auch sicher so schreiben, dass man es in der .htacces außerhalb des WP-Blocks angeben kann,dann lässt WP das auch in Ruhe.
Und was ich vermutlich gleich hätte fragen sollen: Du versuchst jetzt aber nicht, einen Teil von WP damit zu schützen, also z.B. eine Kategorie oder so, oder? Es geht um externe Dateien, die mit WP nichts zu tun haben und nur zufällig in einem Unterordner innerhalb von WP liegen?
-
Die Tabelle wp_wppt_preset ist keine Standard-WP-Tabelle. Finde doch erstmal raus, zu welchem Plugin die gehört. Passt "wppt" als Abkürzung zu einem Deiner Plugins oder zu Deinem Theme? Ansonsten poste doch bitte mal eine Liste aller Plugins, die Du verwendest.
-
Hat sich zwischenzeitlich erledigt? Ich sehe keinen Fehler.
-
Geld verlangen kannst Du generell in jedem Fall. Du müsstest Deine Kunden dann nur darüber aufklären, unter welcher Lizenz das Kubrick-Theme steht und was ihnen das für Rechte gibt. Wenn Du das Theme nicht unter die gleiche Lizenz stellen willst (ist Kubrick GPL?), solltest vielleicht besser was eigenes entwickeln. Aber das hat insofern nichts damit zu tun, dass Du den Kunden nicht Deine geleistete Arbeit in Rechnung stellen kannst.
-
Nur als Anmerkung am Rande: Wenn ihr öfters sehr viele gleichzeitige Besucher habt, solltet ihr über Caching nachdenken (WP Super Cache oder ähnliche Plugins). Ich habe keine eigenen praktischen Erfahrungen damit, aber es kann die Serverlast und die Auslieferungszeiten wohl recht drastisch drücken. Dafür ist man dann mit dynamischen Elementen der Seite etwas eingeschränkt (dynamisches müsste über JavaScript und nicht über PHP gelöst werden).
-
Fangen wir doch mal damit an:
http://validator.w3.org/check?verbose=…%2Fwordpress%2FIrgendwas wird da wohl falsch geschachtelt sein, nehme ich an, aber mit so vielen Fehlern kann man den eigentlichen Fehler natürlich nicht sehen.
-
Die .htaccess-Datei von WordPress leitet alle Anfragen, die nicht auf eine physisch existente Datei oder Ordner führen, zur index.php von WordPress um. Der Verzeichnisschutz sollte also eigentlich funktionieren, solange Du eine Datei oder einen Ordner aufrufst, die tatsächlich existieren.
Wenn im Unterordner eine ähnliche Konstruktion wie WordPress liegt, welche Teile der URL als Parameter auswertet, musst Du ggf. in der oberen .htaccess alle Anfragen auf das Verzeichnis von der WP-Prüfung ausnehmen. Das könnte in etwa so aussehen:
Apache Configuration# BEGIN WordPress <IfModule [URL="http://forum.wordpress-deutschland.org/lexikon/?do=showentry&item=mod_rewrite"]mod_rewrite[/URL].c> RewriteEngine On RewriteBase / RewriteCond %{REQUEST_FILENAME} !^/verzeichnisname/* RewriteCond %{REQUEST_FILENAME} !-f RewriteCond %{REQUEST_FILENAME} !-d RewriteRule . /index.php [L] </IfModule> # END WordPressDas ist jetzt aber ungetestet, muss also nicht zwangsläufig stimmen. "verzeichnisname" wäre der Pfad zum Unterverzeichnis. Die Ergänzung müsstest Du nach jedem Speichern der Permalinks wieder einbauen.
-
Du kannst entweder Dein eigenes Widget schreiben. Da kannst Du im Detail bestimmen auf welchen Seiten es angezeigt werden soll. Für alle schon vorgefertigten Widgets hilft Dir das Plugin "Widget Logic" weiter. Da kannst Du bei jedem Widget angeben, auf welchen Seiten es angezeigt werden soll, unter Nutzung der normalen Abfrage-Möglichkeiten, die auch im Theme bestehen.
-
Solange die Permalinks ausgeschaltet sind, ist das korrekt, da hat WP mit der .htaccess ja auch nichts zu tun. Wenn Du eine der anderen Permalink-Strukturen einstellst, müsste der Inhalt der Datei in etwa so aussehen wie in dem ersten Beitrag hier: http://forum.wordpress-deutschland.org/wordpress-mu/2…u-htaccess.html
Sieht dann aber schon so aus, als könnte WP die Datei beschreiben. Das wäre ja sonst noch eine mögliche Fehlerquelle gewesen.
-
Zitat
Falls dem so wäre, würde der Aufruf des upgrade.php-Scriptes die DB anpasen. Siehe Upgrade-Anleitung.
ZitatIch habe den Upgrade auf 2.8.6 mit einer Neuinstallation verbunden und bin jetzt geschockt, weil ich ja jede Tabellenspalte prüfen müsste ... :sad: danke
Ähm... Einfach alle Daten neu drüberkopieren ist keine Neuinstallation, das ist das normale (manuelle) Upgrade, und dafür gibt es eine Anleitung. Wenn Du tatsächlich eine neue DB angelegt hast und diese nutzen willst, kannst Du die Inhalte aus dem alten System natürlich exportieren (vor der Neuinstallation im alten System exportieren über das Tools-Menü z.B.). Aber das macht eigentlich nicht viel Sinn, es sei denn, Du schleppst speziell viele Altlasten in der DB mit.
Generell tut sich zwischen den Minor-Versions nicht viel, das sind meist Bugfix- und Sicherheitsreleases. Ich glaube sogar, die DB ändert sich in diesen kleinen Versionssprüngen nie, normalerweise nur zwischen 2.x zu 2.y.
-
http://forum.wordpress-deutschland.org/lexikon/?do=showentry&item=Widgets
ZitatMit allen anderen Permalink-Formaten kommt wieder die 404-Meldung. Das heißt offenbar, dass tatsächlich irgendeine Voraussetzung vom Server her nicht erfüllt ist, nicht wahr? Wenn es so ist, werde ich wohl b.a.w. mit dem Default-Format leben (müssen). Denn mittels fremder (konkret momentan Deiner) Hilfe mit meinem Betreiber über mögliche Probleme seiner SW verhandeln zu müssen, die ich selbst überhaupt nicht verstehe, ist so ziemlich das Letzte, wonach mein Begehr steht.
Naja, wie gesagt, WordPress ist keine Nischen-Software mehr. Ein ernstzunehmender Hoster sollte eine einfache Frage wie "Erfüllt das Hosting-Package xyz die Voraussetzungen, um WordPress damit zu betreiben?" beantworten können. Und er sollte, wenn man ihn auf diesen Artikel hinweist, auch eine Aussage zu den Permalinks treffen können. Letzteres ist ja auch keine spezielle WP-Erfindung, andere CMS machen das ähnlich.
Allerdings solltest Du vorher sicherstellen, dass die .htaccess-Datei im Root-Verzeichnis der WP-Installation vorhanden ist und den korrekten Inhalt enthält (sprich: dass WP Schreibrechte auf der Datei hat). Was drin stehen sollte sagt Dir WP beim Abspeichern der Permalink-Einstellungen im Backend, und dabei sagt es Dir eigentlich auch, wenn es die Datei nicht beschreiben konnte.
-
Zitat
Ja, das ist das normale Verhalten von WP. Wenn Du keine Widgets konfigurierst, nimmt WP an, dass Du die Widgets nicht nutzen willst und stellt die in der sidebar.php fest konfigurierte Sidebar dar. Die kannst Du bei Bedarf natürlich anpassen oder löschen (in der sidebar.php), aber einfacher ist es halt, die Widgets zu benutzen.
Hat sich da denn nun eigentlich was verändert? Dein letztes Posting klingt so, als würde alles normal funktionieren, während Du oben doch noch schriebst:
Zitatauf der Webseite selbst erscheinen jedoch immer, d.h. völlig unabhängig von meinen Aktivierungen/Deaktivierungen, die Default-Widgets:
?!
Zitat4. ich habe dzt. sowohl Pages als auch Posts; wenn ich Seiten ansehe, ist der Sidebar da; wenn ich Posts ansehe, ist er weg und ich sehe nur die Links zum vorhergehenden und zum nachfolgenden Post
Das ist eine Funktionalität des Default-Themes. Die meisten Themes blenden die Sidebar immer ein. Siehe:
http://faq.wordpress-deutschland.org/kubrick-vollstaendige-sidebar/ -
Um die Permalinks geht's ja schon in Deinem anderen Thread. Das sollte auf jeden Fall hinzukriegen sein. Aber bei den Widgets habe ich ehrlich keine Ahnung. Da kann man eigentlich nur noch mal die Grundlagen überprüfen:
- Das Theme ist widget-fähig. Falls nicht,müsste Dir WP das sagen unter Design > Widgets. Dann müsste es auch mit dem Defail-Theme gehen.
- Du hast Widgets in einer im Theme angezeigten Sidebar gespeichert.
- Das Theme bindet die Widgets richtig ein.Dafür wäre es vielleicht wirklich mal der beste Test, kurz aufs Default-Theme umzustellen. Wenn es damit geht (umstellen, Widget in die Sidebar ziehen + speichern, Seite überprüfen), dann liegt es wohl an Deinem Theme.